Survey by Qualaroo
+ Reply to Thread
Page 3 of 3 FirstFirst 123
Results 41 to 41 of 41

Thread: Lancer 2005 Mech probs....need help...

  1. #1
    PakWheeler Follow
    thread175's Avatar
    Join Date
    Feb 2009
    Location
    Rawalpindi
    Age
    33
    Posts
    283
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Lancer 2005 Mech probs....need help...

    Hi guys,


    I have just bought (2 month earlier) a Lancer 1.6 GLX SR, M/T done 78K Km lhr regd ,in good condition with 'Diel' EFI kit with Emu/advancer installed and 50 kg cylinder.. Me facing the following problems....


    RPM on CNG and Petrol keeps on flutuating all the time... (for petrol it is above 1400 and for CNG it is from 500 to 1100) One expert Mech told to get the throttle body repaired...but still no change..


    Car gives constant vibration on CNG...i have shown it too many Cng and electronic Experts in Pindi...


    all they check is the plugs and the plug coils....they think there is some current leakage... But nobody has been able to solve the problem..


    Cng Mileage is quite heavy .... (75 to 80 km in 350 to 370 Rs cylinder in city) I know it 1.6 Litre..But I have Heard that civics n se saloons do better than this...(may be around 100 km per cylinder)..lancer has a relativiely light engine (lancer 1.6=77 Kw , Civic exi= 81 kw ,Civic vti=96 Kw)ref.... My bros 2004 exi(prosmatec) does 110 km within city...


    Egine gives white smoke...Mechs told me that if the engine is weak.then the engine will evaporate quickly....but I do chk it regularly but its level is very slightly lowered (like every cng veh) have driven 4000 kms so far (using ZIC cng engine oil)


    GuYS Help me and tell me whether these problems are there in all lancers M/T...


    HELP ME PLEASE!!!!

  2. #41
    PakWheeler Follow
    Minarek's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    your ISCV idle speed correction valve is jammed or not working (common mitsu problem) - its located on your throttle body - can be a 3 wire or 6 wire one, thats the only thing controlling your idle speed, its a stepper motor and usually has 2 coils in it, mitsi 6 wire have 3 windings in it, - they go bad if you dont clean it often.

    Then do a BISS (base idle speed set) procedure and check your ignition timing.. maybe you have a stretched T belt or something
    Hello Xulfiqar,

    Do you have any idea where can one get the BISS (base idle speed set) procedure reliably done in isb/rwp?

+ Reply to Thread
Page 3 of 3 FirstFirst 123

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •