Survey by Qualaroo
+ Reply to Thread
Page 2 of 5 FirstFirst 1234 ... LastLast
Results 21 to 40 of 95
Like Tree30Likes

Thread: QG18DE rebuild project

  1. #1
    PakWheeler Follow
    dani_kk's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Posts
    781
    Follows
    4
    Following
    0
    Mentioned
    55 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default QG18DE rebuild project

    As we all know sometimes scrappies hand you 100k km plus engines that deteriorate with certain passage of time. And sometimes engines are good too. Depends on how you know about things. My engine was good but, issue i faced was timing adjuster broke on the way to muree once i somehow managed to reach muree and then came back. This thing brought valve missing in my car.
    Due to timing mismatch, the cams weren't provided with oil flow so they seized Slightly.

    I was somehow dragging the car.

    And it's compression dropped to 140-120-130-138

    Anyhow i planned for working on it and was saving for it.

    My estimated expenditures were around 15-20k

    But they slightly exceeded because people from engineering works set there own rates.

    When the head was lifted up, it appeared a cylinder 2-3 were cross. Head gasket was blown.

    And when inlet valves of 1 cylinder were meant to be opened the contrasting inlet valves of cylinder 2 were to be closed but they were left open.

    I built the head, valves grinding done, seats were replaced so were the tapets, gats and valve stem seals.

    Second issue was smoke, what we saw was almost all pistons were dancing inside the block when they were moved left right. Good rings and pistons never allow this dancing of pistons.

    Anyhows i bought new cams from mushtaq. They were 10/10 cams, i pulled them from a head mushtaq had in his go down also with cam caps.

    Gave him 2500 rs.

    Then i was in a hope he'd be having pistons or a good block assembly but both the things were unavailable. The block's he had were corroded.

    So now finding the Rings was the headache. Kiyani autos said a big no for 80mm rings. The one he had were 82mm but the top ring was very thin, which my mechanic said is inappropriate.

    Anyhow after a slight struggle we know the secret about the Rings, lol which I'll release to the person having this project done. As I've done research on this myself. As when you'll go finding QG18de rings, you'll hear a big no from everyone.

    Moreover the piston pins were loose too and causing loud tak tak sounds while revving the car.

    So pins were changed too.
    Gasket was made of carbon sheet.


    To cut the story short built it very nicely mashallah.

    25k were spent nicely to get almost a new engine.

    Now the engine is on running process. As my mechanic strictly told me not to rev or heat it until 1500-2000km.

    Alhamdulilah all was done good and quality parts were added up to the engine.

    So here goes the whole project.

    So guys don't worry QG18de can be built too.

    Mashallah getting 190-195psi pressure on all cylinders.

    Project consumed 2 days.

    Saturday Sunday night the car was ready.

    Contact me for queries. 03455072961
    Attached Images Attached Images     
    STYLISH BOYZZZ STYLISH ATTITUDE

  2. #21
    PakWheeler Follow
    dani_kk's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Posts
    781
    Follows
    4
    Following
    0
    Mentioned
    55 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    @QamarAhmadawan i need your help in something, please give your contact.
    STYLISH BOYZZZ STYLISH ATTITUDE

  3. #22
    PakWheeler Follow
    dani_kk's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Posts
    781
    Follows
    4
    Following
    0
    Mentioned
    55 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    Btw can anyone tell me the reason of this blown head gasket? I never heated the car so much.

    Secondly I'm facing an issue.
    The check engine wire on ecu pin outs when connected doesn't glows the check engine light on ignition on and but when i ground check engine light wire of meter it works fine.
    Voltmeter readings suggest that chk wire is showing zero volts on ignition on but why it is not glowing the chk engine light?
    As we all know when we turn the ignition on the battery oil and all lights such as abs and. Check engine appear.
    And. If everything is working fine they disappear.

    So im unable to get. Check engine connectd.
    STYLISH BOYZZZ STYLISH ATTITUDE

  4. #23
    Senior PakWheeler Follow
    star2's Avatar
    Join Date
    Oct 2006
    Location
    Lahore
    Age
    31
    Posts
    3,427
    Follows
    6
    Following
    1
    Mentioned
    324 Post(s)
    Tagged
    9 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by dani_kk View Post
    Btw can anyone tell me the reason of this blown head gasket? I never heated the car so much.

    Secondly I'm facing an issue.
    The check engine wire on ecu pin outs when connected doesn't glows the check engine light on ignition on and but when i ground check engine light wire of meter it works fine.
    Voltmeter readings suggest that chk wire is showing zero volts on ignition on but why it is not glowing the chk engine light?
    As we all know when we turn the ignition on the battery oil and all lights such as abs and. Check engine appear.
    And. If everything is working fine they disappear.

    So im unable to get. Check engine connectd.
    voltage difference between the check engine light and the bulb you are trying to connect it with, i think....
    success is the ability to go from one failure to the next without any loss of enthusiasm

  5. #24
    PakWheeler Follow
    dani_kk's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Posts
    781
    Follows
    4
    Following
    0
    Mentioned
    55 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    @star2 bro what should i do about it? When i ground the wire coming from meter, check light glows but while hooking it to check wire on ecu nothing lights up. Im stuck.
    STYLISH BOYZZZ STYLISH ATTITUDE

  6. #25
    Senior PakWheeler Follow
    star2's Avatar
    Join Date
    Oct 2006
    Location
    Lahore
    Age
    31
    Posts
    3,427
    Follows
    6
    Following
    1
    Mentioned
    324 Post(s)
    Tagged
    9 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by dani_kk View Post
    @star2 bro what should i do about it? When i ground the wire coming from meter, check light glows but while hooking it to check wire on ecu nothing lights up. Im stuck.
    maybe wrong engine check light pinout..
    success is the ability to go from one failure to the next without any loss of enthusiasm

  7. #26
    Senior PakWheeler Follow
    star2's Avatar
    Join Date
    Oct 2006
    Location
    Lahore
    Age
    31
    Posts
    3,427
    Follows
    6
    Following
    1
    Mentioned
    324 Post(s)
    Tagged
    9 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Orange Blue line it is.... gives ground at Ign and gets battery 12V+ while engine running...
    success is the ability to go from one failure to the next without any loss of enthusiasm

  8. #27
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,400
    Follows
    131
    Following
    0
    Mentioned
    3988 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by dani_kk View Post
    Btw can anyone tell me the reason of this blown head gasket? I never heated the car so much.

    Secondly I'm facing an issue.
    The check engine wire on ecu pin outs when connected doesn't glows the check engine light on ignition on and but when i ground check engine light wire of meter it works fine.
    Voltmeter readings suggest that chk wire is showing zero volts on ignition on but why it is not glowing the chk engine light?
    As we all know when we turn the ignition on the battery oil and all lights such as abs and. Check engine appear.
    And. If everything is working fine they disappear.

    So im unable to get. Check engine connectd.
    defective factory gasket, its even a problem with nissan QR25 and some early model VQ35 - Nissan chose the cheapest (worst quality) supplier.

    The QR gasket fails in a way that there is never oil/coolant or coolant/oil mix but coolant seeps into cylinder 3 while the engine cools down.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  9. #28
    PakWheeler Follow
    dani_kk's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Posts
    781
    Follows
    4
    Following
    0
    Mentioned
    55 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    Zulfiqar bhai any ideas about my second problem?
    STYLISH BOYZZZ STYLISH ATTITUDE

  10. #29
    PakWheeler Follow
    dani_kk's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Posts
    781
    Follows
    4
    Following
    0
    Mentioned
    55 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    According to diagram chk is on 111
    And green wire with red line on it.
    and ecu is 3row ecu
    STYLISH BOYZZZ STYLISH ATTITUDE

  11. #30
    PakWheeler Follow
    dani_kk's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Posts
    781
    Follows
    4
    Following
    0
    Mentioned
    55 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    @star2 the wire you're telling is giving 12v out.
    And the wire traced by ameer shows check on ignition and check remains and when we shut off the engine the check light remains on for 10secs and relay shut off sound is heard and check light disappears. I don't thinkso chk light remains on.
    STYLISH BOYZZZ STYLISH ATTITUDE

  12. #31
    PakWheeler Follow
    saadzae92's Avatar
    Join Date
    Mar 2008
    Age
    27
    Posts
    999
    Follows
    1
    Following
    0
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    did your mechanic use brand new head bolts and tighten them to Nissan's specified sequence and the correct torque?
    The only way to get rid of temptation is to yield to it... I can resist everything but temptation.

  13. #32
    PakWheeler Follow
    dani_kk's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Posts
    781
    Follows
    4
    Following
    0
    Mentioned
    55 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    Nope same bolts used.
    STYLISH BOYZZZ STYLISH ATTITUDE

  14. #33
    PakWheeler Follow
    bigsuzuhorn's Avatar
    Join Date
    Apr 2016
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Name:  ImageUploadedByPW Forums1462331034.053663.jpg
Views: 132
Size:  163.9 KBjust finished rebuilding this one. I did it all by myself though. It's an old good 3k


    Sent from my iPhone using PW Forums

  15. #34
    Senior PakWheeler Follow
    syncview's Avatar
    Join Date
    Apr 2006
    Location
    Lahore
    Age
    28
    Posts
    3,364
    Follows
    7
    Following
    1
    Mentioned
    436 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by dani_kk View Post
    According to diagram chk is on 111
    And green wire with red line on it.
    and ecu is 3row ecu
    Is your diag for a 3 row ecu too?
    https://www.facebook.com/OsamaAbbasPhotography

  16. #35
    Senior PakWheeler Follow
    syncview's Avatar
    Join Date
    Apr 2006
    Location
    Lahore
    Age
    28
    Posts
    3,364
    Follows
    7
    Following
    1
    Mentioned
    436 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by dani_kk View Post
    Btw can anyone tell me the reason of this blown head gasket? I never heated the car so much.

    Secondly I'm facing an issue.
    The check engine wire on ecu pin outs when connected doesn't glows the check engine light on ignition on and but when i ground check engine light wire of meter it works fine.
    Voltmeter readings suggest that chk wire is showing zero volts on ignition on but why it is not glowing the chk engine light?
    As we all know when we turn the ignition on the battery oil and all lights such as abs and. Check engine appear.
    And. If everything is working fine they disappear.

    So im unable to get. Check engine connectd.
    Check signal wire till ecu
    https://www.facebook.com/OsamaAbbasPhotography

  17. #36
    Senior PakWheeler Follow
    syncview's Avatar
    Join Date
    Apr 2006
    Location
    Lahore
    Age
    28
    Posts
    3,364
    Follows
    7
    Following
    1
    Mentioned
    436 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Wait

    Is the engine original to the car under discussion or a swap?
    https://www.facebook.com/OsamaAbbasPhotography

  18. #37
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,735
    Follows
    16
    Following
    0
    Mentioned
    488 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by dani_kk View Post
    Well to be honest, i never said bore has been widened.
    Same bore is used. Pistons were rattling because of piston pins. They are replaced and pistons are washed up.

    Rings used are of 4af Toyota engine. And the top ring of QG's are not thin. It had the solid steel ring. As xulfiqar said it's not rocket science in building this engine, he is right. . If and only if the owner of car has some knowledge. If he is dumb he'll be looted. And soon the engine will tell them what is called rebuilding a QG.

    And yes i was just increasing the curiosity of the post @Ser bro.

    Therfore i play alot with nissan's so not an issue for me to rebuild this engine.

    Using My Limited Knowledge Even If Cyl Is Honed...It Will Take Out Some Of Metal From Cylinder Walls And Size Diff Will Be There

    That's Why I ask For Piston/Wall Clearance As Its Specific And More Than Others In QG18...
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  19. #38
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,735
    Follows
    16
    Following
    0
    Mentioned
    488 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by dani_kk View Post
    Nope same bolts used.
    QG18 Used TTY Type Heat Bolts? Did You Check Which One Are Those???

    If Those Are TTY Bolts .. They Need To Replaced No Matter What
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  20. #39
    FBB
    FBB is offline
    PakWheeler Follow
    FBB's Avatar
    Join Date
    Sep 2015
    Location
    Peshawar
    Age
    39
    Posts
    520
    Follows
    1
    Following
    2
    Mentioned
    14 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    @syncview he owns 84 model Nissan B11 and he swaped the engine QG18DE in it. @dani_kk I think you have to change your speedometer too because Nissan ECU voltage does not supports toyota voltage. I too have same meter as you know and having same problem with hand brake light.

    Sent from my Z12 using Tapatalk

  21. #40
    Senior PakWheeler Follow
    syncview's Avatar
    Join Date
    Apr 2006
    Location
    Lahore
    Age
    28
    Posts
    3,364
    Follows
    7
    Following
    1
    Mentioned
    436 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Ermmm
    Qg18 speedo communicates with ecu on canbus IIRC
    you cannot simply wire up cel and other lights

    You need the speedometer compatible to the ecu
    https://www.facebook.com/OsamaAbbasPhotography

+ Reply to Thread
Page 2 of 5 FirstFirst 1234 ... LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •