Survey by Qualaroo
+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 41

Thread: Toyota Premio 1.8 strange sound when accelerating

  1. #1
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default NOT SOLVED Toyota Premio 1.8 strange sound when accelerating

    UPDATE # the sound is still there also the sound is audible when car reaches its temperature (middle b/w cold and hot) when car is cold there is no sound and when car is in its temperature the sound can be heard what does this mean?

    AOA. Ramazan mubarak to you all. We recently bought a Toyota Premio and i changed its cvt oil and did basic tuning like cleaning spark plugs throttle body cleaning and oxygen sensor but upon acceleration of car it produces "krrrrr" sound not in neutral but in D or S. Whenever the car is accelerating in 3-4 rpm it produces the sound and when the car is driven on low rpm it does not produce the sound. Also the sound is coming from the very bottom of the car not above. (i think from gearbox area). I checked the oil it is ok and also some otherthings they are also fine but the sound is still coming. the sound is not of knocking. will be looking for suggestions about the problem Regards. will upload the audio of sound as well tomorrow as the car is not with me now. the oil i used was silver tin Toyota original cvti oil 4L

  2. #21
    Senior PakWheeler Follow
    huzaifa.haroon's Avatar
    Join Date
    Aug 2012
    Location
    Islamabad
    Posts
    5,001
    Follows
    10
    Following
    1
    Mentioned
    225 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    If a CVT transmission oil was not changed on time and it got burnt and then you changed it later then the new oil can cause serious damage to transmission. Hopefully its not that but are you sure that krr krr sound is not engine knocking??

    Sent from my ALE-L21 using Tapatalk
    Always respect your parents

  3. #22
    Senior PakWheeler Follow
    Nabeel_Ali's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    24
    Posts
    3,509
    Follows
    2
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by furqanalighazi View Post
    AOA. Ramazan mubarak to you all. We recently bought a Toyota Premio and i changed its cvt oil and did basic tuning like cleaning spark plugs throttle body cleaning and oxygen sensor but upon acceleration of car it produces "krrrrr" sound not in neutral but in D or S. Whenever the car is accelerating in 3-4 rpm it produces the sound and when the car is driven on low rpm it does not produce the sound. Also the sound is coming from the very bottom of the car not above. (i think from gearbox area). I checked the oil it is ok and also some otherthings they are also fine but the sound is still coming. the sound is not of knocking. will be looking for suggestions about the problem Regards. will upload the audio of sound as well tomorrow as the car is not with me now. the oil i used was silver tin Toyota original cvti oil 4L
    This happened with my friend's vitz. It usually happens when car starts without cvt oil or the oil may be too old. He ended up changing the gear box :/ the cvt pulleys were damaged.

    Sent from my SM-N920C using Tapatalk

  4. #23
    PakWheeler Follow
    rashid1834's Avatar
    Join Date
    Apr 2015
    Location
    Rawalpindi
    Age
    37
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Toyota Premio 1.8 strange sound when accelerating

    dignose the vehicle with techstreen tyota dignostic tool and chack error code and live data stream inshaAllah u will find problem


    Sent from my iPhone using PW Forums

  5. #24
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by huzaifa.haroon View Post
    If a CVT transmission oil was not changed on time and it got burnt and then you changed it later then the new oil can cause serious damage to transmission. Hopefully its not that but are you sure that krr krr sound is not engine knocking??

    Sent from my ALE-L21 using Tapatalk
    i think so might be the cause but i smelled the oil and it was nothing like burning oil was just dirty after cvti oil change it is performing as new...my friend also have premio 1.8 2010 i have compared it fells nothing different

  6. #25
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Nabeel_Ali View Post
    This happened with my friend's vitz. It usually happens when car starts without cvt oil or the oil may be too old. He ended up changing the gear box :/ the cvt pulleys were damaged.

    Sent from my SM-N920C using Tapatalk
    i did some research before changing the oil and was very cautious of the steps...i took it to toyota as it has same engine as toyota grande and same gearbox so i did not take any chances as cvt is a little risky for regular mechanics

  7. #26
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by rashid1834 View Post
    dignose the vehicle with techstreen tyota dignostic tool and chack error code and live data stream inshaAllah u will find problem


    Sent from my iPhone using PW Forums
    will definetly give it a try also do you know from pindi/isb where can it be done?

  8. #27
    PakWheeler Follow
    rashid1834's Avatar
    Join Date
    Apr 2015
    Location
    Rawalpindi
    Age
    37
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Toyota Premio 1.8 strange sound when accelerating

    whats app me 00968 99181834


    Sent from my iPhone using PW Forums

  9. #28
    Senior PakWheeler Follow
    huzaifa.haroon's Avatar
    Join Date
    Aug 2012
    Location
    Islamabad
    Posts
    5,001
    Follows
    10
    Following
    1
    Mentioned
    225 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by furqanalighazi View Post
    i think so might be the cause but i smelled the oil and it was nothing like burning oil was just dirty after cvti oil change it is performing as new...my friend also have premio 1.8 2010 i have compared it fells nothing different
    https://youtu.be/o690DovjDAc
    Watch This

    Sent from my ALE-L21 using Tapatalk
    Always respect your parents

  10. #29
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by huzaifa.haroon View Post
    https://youtu.be/o690DovjDAc
    Watch This

    Sent from my ALE-L21 using Tapatalk
    thank u for the info also i did see the old oil which was not as much black as shown in video it was dark red and not smelled like burning also one thing comes in mind that did i use the right oil? ( used Toyota Original tin can cvti oil 4L)

  11. #30
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by furqanalighazi View Post
    thank u for the info also i did see the old oil which was not as much black as shown in video it was dark red and not smelled like burning also one thing comes in mind that did i use the right oil? ( used Toyota Original tin can cvti oil 4L)
    Can ovefilling might be cause? just put a very little extra though not too much
    Toyota Premio 18 strange sound when accelerating -1690212

  12. #31
    Senior PakWheeler Follow
    huzaifa.haroon's Avatar
    Join Date
    Aug 2012
    Location
    Islamabad
    Posts
    5,001
    Follows
    10
    Following
    1
    Mentioned
    225 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by furqanalighazi View Post
    thank u for the info also i did see the old oil which was not as much black as shown in video it was dark red and not smelled like burning also one thing comes in mind that did i use the right oil? ( used Toyota Original tin can cvti oil 4L)
    Thats the correct oil for CVT which came in new shape i guess. Dark red shouldn't be a problem then.

    Sent from my ALE-L21 using Tapatalk
    Always respect your parents

  13. #32
    PakWheeler Follow
    Khurram26's Avatar
    Join Date
    Dec 2006
    Location
    Islamabad
    Age
    38
    Posts
    273
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by furqanalighazi View Post
    AOA. Ramazan mubarak to you all. We recently bought a Toyota Premio and i changed its cvt oil and did basic tuning like cleaning spark plugs throttle body cleaning and oxygen sensor but upon acceleration of car it produces "krrrrr" sound not in neutral but in D or S. Whenever the car is accelerating in 3-4 rpm it produces the sound and when the car is driven on low rpm it does not produce the sound. Also the sound is coming from the very bottom of the car not above. (i think from gearbox area). I checked the oil it is ok and also some otherthings they are also fine but the sound is still coming. the sound is not of knocking. will be looking for suggestions about the problem Regards. will upload the audio of sound as well tomorrow as the car is not with me now. the oil i used was silver tin Toyota original cvti oil 4L
    Nothing to do with CVT or anything. The noise is from your exhaust... probably the cat converter has been removed.

  14. #33
    PakWheeler Follow
    uzeemujeeb's Avatar
    Join Date
    Dec 2008
    Location
    Karachi
    Posts
    381
    Follows
    1
    Following
    5
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    did u also changed the transmission oil filter, the rattle from cvt transmission at certain rpm is most likely dirty oil filter cvt + trans. oil filter shall be changed every 60 ~ 80000 km while the standard atf & filter require change at 40 ~ 60000 kms

  15. #34
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Khurram26 View Post
    Nothing to do with CVT or anything. The noise is from your exhaust... probably the cat converter has been removed.
    got it checked cat isn't removed

  16. #35
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by uzeemujeeb View Post
    did u also changed the transmission oil filter, the rattle from cvt transmission at certain rpm is most likely dirty oil filter cvt + trans. oil filter shall be changed every 60 ~ 80000 km while the standard atf & filter require change at 40 ~ 60000 kms
    i didn't change the cvt oil filter as toyota guys themselve said that it is a flat paper like filter which doesn't require to be changed and also i asked few members here they said it would be alright to just change the oil without the filter

  17. #36
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by rashid1834 View Post
    whats app me 00968 99181834


    Sent from my iPhone using PW Forums
    inshallah will contact u soon

  18. #37
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    also i took it to another mechanic in islamabad working at audi he checked the cvt it is all ok and also got the engine diagnosed with toyota scanner no codes whatsoever he doubts that the toyota guys did not refit the spark plugs and coils correctly which is causing the noise... now i will take it to toyota again to inspect this issue

  19. #38
    PakWheeler Follow
    Ijazzareen's Avatar
    Join Date
    Jan 2013
    Location
    Islamabad
    Age
    51
    Posts
    11
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    what is the difference between Crown royal ,athlete and magistrate

  20. #39
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by huzaifa.haroon View Post
    If a CVT transmission oil was not changed on time and it got burnt and then you changed it later then the new oil can cause serious damage to transmission. Hopefully its not that but are you sure that krr krr sound is not engine knocking??

    Sent from my ALE-L21 using Tapatalk
    sorry to bother but i have updated the issue in main comment will be thankful for opinions

  21. #40
    Senior PakWheeler Follow
    huzaifa.haroon's Avatar
    Join Date
    Aug 2012
    Location
    Islamabad
    Posts
    5,001
    Follows
    10
    Following
    1
    Mentioned
    225 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by furqanalighazi View Post
    sorry to bother but i have updated the issue in main comment will be thankful for opinions
    I still think that its engine knocking which happens due to pre combustion try using fuel from a good pump and hi octane and then check.

    Sent from my ALE-L21 using Tapatalk
    Always respect your parents

+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •