Survey by Qualaroo
+ Reply to Thread
Page 3 of 3 FirstFirst 123
Results 41 to 41 of 41

Thread: Toyota Premio 1.8 strange sound when accelerating

  1. #1
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default NOT SOLVED Toyota Premio 1.8 strange sound when accelerating

    UPDATE # the sound is still there also the sound is audible when car reaches its temperature (middle b/w cold and hot) when car is cold there is no sound and when car is in its temperature the sound can be heard what does this mean?

    AOA. Ramazan mubarak to you all. We recently bought a Toyota Premio and i changed its cvt oil and did basic tuning like cleaning spark plugs throttle body cleaning and oxygen sensor but upon acceleration of car it produces "krrrrr" sound not in neutral but in D or S. Whenever the car is accelerating in 3-4 rpm it produces the sound and when the car is driven on low rpm it does not produce the sound. Also the sound is coming from the very bottom of the car not above. (i think from gearbox area). I checked the oil it is ok and also some otherthings they are also fine but the sound is still coming. the sound is not of knocking. will be looking for suggestions about the problem Regards. will upload the audio of sound as well tomorrow as the car is not with me now. the oil i used was silver tin Toyota original cvti oil 4L

  2. #41
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by huzaifa.haroon View Post
    I still think that its engine knocking which happens due to pre combustion try using fuel from a good pump and hi octane and then check.

    Sent from my ALE-L21 using Tapatalk
    ok i will do this hope it is only knocking

+ Reply to Thread
Page 3 of 3 FirstFirst 123

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •