Survey by Qualaroo
+ Reply to Thread
Results 1 to 11 of 11
Like Tree1Likes
  • 1 Post By mantissa

Thread: Daihatsu Boon/Toyota Passo 2006 Pains

  1. #1
    PakWheeler Follow
    mantissa's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    86
    Posts
    7
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Daihatsu Boon/Toyota Passo 2006 Pains

    Hi All,

    Just as a quick background, I have a Daihatsu Boon/Toyota Passo 2006 - 1KR-FE + Automatic transmission model.

    It was a sturdy car earlier, but since the last 10-15K KMs it's been giving me some serious pain.

    - The car has done 65,000km now
    - The car has started to shake viciously when in R or in D. I've even had the engine mounts changed. It gave me some relief for 2-3 months and then the shaking started again.
    - When going uphill I can tell the car is struggling quite a lot (the engine also sounds under a lot of load - making more noise, and not producing much acceleration - I now have to switch to the slow lane when going on the high road so I don't embarrass myself )
    - I've had the spark plugs, car battery, engine oil, oil & air filter replaced among the routine servicing - still the same results. Have also had transmission oil changed but no effect on the issues faced
    - Switching the car AC causes the car to feel a lot of extra burden, the car also vibrates a lot more in idle. Switching to N or P immediately reduces the vibration
    - Car fuel efficiency is now giving me less < 8km/L

    Some questions with regards to the pain described ( I apologize if these are redundant questions):

    1. Who would be the best mechanic and/or service center in Karachi to have a look at Boons/Passos and take it through a full and professional service and inspection? (ideally someone that wouldn't send me on another wild goose chase or if there's a reliable service center that you could recommend)
    2. Has anyone experienced the same kinds of problems and how were you able to address?
    3. Is it possible that a fault in the AC can cause the sort of performance issues I'm seeing?
    4. Can the throttle body or sensor cause this kind of problem? What's the safest way to clean it?
    5. Which is the best place to get Passo/Boon parts in Karachi?
    6. Can the catalytic converter be responsible for the issues witnessed?

    Any advice would be really appreciated.

    Thanks everyone!

  2. #2
    Senior PakWheeler Follow
    nfssaad's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    29
    Posts
    3,179
    Follows
    0
    Following
    1
    Mentioned
    50 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    does the engine rev ok when in neutral?

    definitely looks like a sensor fault...

    take it to toyota service center for scanning only... to trace the fault...
    the problem is not our govt... its the people..

  3. #3
    PakWheeler Follow
    mantissa's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    86
    Posts
    7
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by nfssaad View Post
    does the engine rev ok when in neutral?

    definitely looks like a sensor fault...

    take it to toyota service center for scanning only... to trace the fault...
    Thanks for the tip!

    I'll definitely start from there then.
    -

  4. #4
    PakWheeler Follow
    mantissa's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    86
    Posts
    7
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Just replying back on this thread in case it helps anyone.

    So it turns out that my catalytic converter was the culprit. After repairs, the car's acceleration was back to normal.

    Hope this helps.
    -

  5. #5
    PakWheeler Follow
    Akhan12's Avatar
    Join Date
    Mar 2012
    Location
    Peshawar
    Posts
    94
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I was facing same problem..today removed its catalytic converter on inspection it was blocked..got it cleaned was washroom wala acid 3bottles and it got cleaned then...on of the foundation of engine was also leaked..I brought new foundation for it...now all the vibration is gone and its pick is very good with Ac on also..

    Sent from my GT-I9300 using PW Forums mobile app

  6. #6
    PakWheeler Follow
    Akhan12's Avatar
    Join Date
    Mar 2012
    Location
    Peshawar
    Posts
    94
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    What mileage was u getting after the change

    Sent from my GT-I9300 using PW Forums mobile app

  7. #7
    PakWheeler Follow
    waqarhassanpk's Avatar
    Join Date
    May 2011
    Location
    Larkana
    Posts
    256
    Follows
    0
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I am facing the problem as well. When at neutral the car starts to vibrate. Or when it is in Reverse or D, and the foot is kept on brakes, it still vibrates.

    Its a relief knowing that the problems can be resolved easily. Would like to know how much did it cost


    Sent from my iPhone using Tapatalk

  8. #8
    Senior PakWheeler Follow
    shaikh229's Avatar
    Join Date
    Jan 2010
    Location
    Karachi
    Posts
    1,070
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I also have passo 2006 can u tell where catalytic converter is located and any good silencer wala in karachi for this job?

    Sent from my WT19i using Tapatalk 2

  9. #9
    Senior PakWheeler Follow
    supraman2jz's Avatar
    Join Date
    Jun 2008
    Location
    Karachi
    Age
    33
    Posts
    2,700
    Follows
    1
    Following
    0
    Mentioned
    76 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mantissa View Post
    Just replying back on this thread in case it helps anyone.

    So it turns out that my catalytic converter was the culprit. After repairs, the car's acceleration was back to normal.

    Hope this helps.
    Not everyone does that. Bravo for coming back with the solution..

  10. #10
    Senior PakWheeler Follow
    shaikh229's Avatar
    Join Date
    Jan 2010
    Location
    Karachi
    Posts
    1,070
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bump

    Sent from my WT19i using Tapatalk 2

  11. #11
    PakWheeler Follow
    zubair26's Avatar
    Join Date
    May 2011
    Location
    Karachi
    Posts
    2
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    In my case the mount was damaged i got it replaced with the new one and the problem got solved still i have the milage issue 1.3 passo gives on only 11.5 km in city how to fix it

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •