Survey by Qualaroo
+ Reply to Thread
Results 1 to 15 of 15
Like Tree2Likes
  • 1 Post By waleed80
  • 1 Post By waleed80

Thread: Passo Eco Mode Light not showing up in meter

  1. #1
    PakWheeler Follow
    adnangulkhan's Avatar
    Join Date
    Mar 2012
    Location
    Islamabad
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Passo Eco Mode Light not showing up in meter

    I'm getting a Passo 2011, it's Eco mode light is not showing up in meter. Is it a big fault and can eco mode be repaired or replaced. How expensive it is? Or I should not buy such car. Please suggest.

    Sent from my GT-I9500 using PW Forums mobile app

  2. #2
    PakWheeler Follow
    faizi91's Avatar
    Join Date
    Jul 2011
    Location
    Karachi
    Age
    25
    Posts
    210
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by adnangulkhan View Post
    I'm getting a Passo 2011, it's Eco mode light is not showing up in meter. Is it a big fault and can eco mode be repaired or replaced. How expensive it is? Or I should not buy such car. Please suggest.

    Sent from my GT-I9500 using PW Forums mobile app
    fasten your seat belts and drive on light foot ECO light will turn up

  3. #3
    Senior PakWheeler Follow
    khalid7shafqat's Avatar
    Join Date
    Sep 2014
    Location
    Karachi
    Age
    24
    Posts
    1,006
    Follows
    0
    Following
    0
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Its probably turned off.

    Go thru the display in ur speedometer, you will find tht the eco mode is off

  4. #4
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,954
    Follows
    5
    Following
    0
    Mentioned
    107 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    are you sure Passo has a eco light?
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  5. #5
    Senior PakWheeler Follow
    tintin1's Avatar
    Join Date
    Jan 2014
    Location
    Lahore
    Posts
    1,832
    Follows
    7
    Following
    2
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    7
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    5

    Default

    Quote Originally Posted by adnangulkhan View Post
    I'm getting a Passo 2011, it's Eco mode light is not showing up in meter. Is it a big fault and can eco mode be repaired or replaced. How expensive it is? Or I should not buy such car. Please suggest.

    Sent from my GT-I9500 using PW Forums mobile app
    These cars are awesome in driving. Specially within the city where lot of signals & jams.
    by the way, what mileage you are getting per liter? am sure it must be 17 or 18 within city.
    Be Addicted To Help Others.

  6. #6
    Senior PakWheeler Follow
    waleed80's Avatar
    Join Date
    May 2006
    Location
    Rawalpindi
    Age
    36
    Posts
    6,690
    Follows
    2
    Following
    0
    Mentioned
    36 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Toggle the menu....It would be written Eco Off...long press the button....It would shift to eco On.....But can someone please tell me how to reset the fuel average indicator

  7. #7
    PakWheeler Follow
    Corollarules's Avatar
    Join Date
    Jan 2011
    Location
    Peshawar
    Age
    25
    Posts
    263
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by waleed80 View Post
    Toggle the menu....It would be written Eco Off...long press the button....It would shift to eco On.....But can someone please tell me how to reset the fuel average indicator
    Once you are on avg hold the button for 3-4 sec and it will reset. You can reset any value this way.

  8. #8
    PakWheeler Follow
    Corollarules's Avatar
    Join Date
    Jan 2011
    Location
    Peshawar
    Age
    25
    Posts
    263
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by waleed80 View Post
    Toggle the menu....It would be written Eco Off...long press the button....It would shift to eco On.....But can someone please tell me how to reset the fuel average indicator
    Once you are on avg hold the button for 3-4 sec and it will reset. You can reset any value this way.

  9. #9
    Senior PakWheeler Follow
    waleed80's Avatar
    Join Date
    May 2006
    Location
    Rawalpindi
    Age
    36
    Posts
    6,690
    Follows
    2
    Following
    0
    Mentioned
    36 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Corollarules View Post
    Once you are on avg hold the button for 3-4 sec and it will reset. You can reset any value this way.
    i know this is how it is supposed to work...but it isnt resetting this way is this an error or something ?

  10. #10
    PakWheeler Follow
    Corollarules's Avatar
    Join Date
    Jan 2011
    Location
    Peshawar
    Age
    25
    Posts
    263
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by waleed80 View Post
    i know this is how it is supposed to work...but it isnt resetting this way is this an error or something ?
    Thats strange the only thing that cannot be reset this way is avg range.

  11. #11
    Senior PakWheeler Follow
    waleed80's Avatar
    Join Date
    May 2006
    Location
    Rawalpindi
    Age
    36
    Posts
    6,690
    Follows
    2
    Following
    0
    Mentioned
    36 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Corollarules View Post
    Thats strange the only thing that cannot be reset this way is avg range.
    average range? there is no average range in Passo bro. first is total car mileage which u cant off course change. then is Eco On or OFF mode...that u can toggle with long press....then is trip A which u can reset with long press...next is trip B, again the same way...then comes this fuel average display, which is NOT resetting by long press.......when u do long press and release, instead of going to zero, it goes back to the first display. i.e. total car mileage

  12. #12
    PakWheeler Follow
    Corollarules's Avatar
    Join Date
    Jan 2011
    Location
    Peshawar
    Age
    25
    Posts
    263
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by waleed80 View Post
    average range? there is no average range in Passo bro. first is total car mileage which u cant off course change. then is Eco On or OFF mode...that u can toggle with long press....then is trip A which u can reset with long press...next is trip B, again the same way...then comes this fuel average display, which is NOT resetting by long press.......when u do long press and release, instead of going to zero, it goes back to the first display. i.e. total car mileage
    I have a vitz 2011 so may be its not there in paso. What is reading on the average display?

  13. #13
    Senior PakWheeler Follow
    waleed80's Avatar
    Join Date
    May 2006
    Location
    Rawalpindi
    Age
    36
    Posts
    6,690
    Follows
    2
    Following
    0
    Mentioned
    36 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Corollarules View Post
    I have a vitz 2011 so may be its not there in paso. What is reading on the average display?
    its 15 km/ liter...when i push the car a little bit, after a while it comes down to 14.7....when driven carefully again, it goes up till 15.4 as it is currently parked in my garage.....how can it variate SO much that too without being reset ever ??? i own a city so i know how these things work....its like if u have gone from pindi to gujranwala and got average lets say 19....even if u drive it like craxy for next 20 kilometrs, average wont drop say less than 18.5....in other case, if u drive it at less speeds and getting 20 km/ liter within few kiilometers, the moment u press it hard it wud come down to 9-10 km/liter within 2 kilometers lets say...but in this passo case, as the fuel average can NOT be reset, it means the average it is showing from day one when the car was produced, right ? its driven 21000 kilometers by now, then how on earth is is possible that only within few kilometers of soft driving it is raised by almost 1 km/liter, drive hard for a kilometer it again comes down....drive soft again it again goes up...and most of all...WHY IS NOT RESETTING at the first place ???

  14. #14
    PakWheeler Follow
    Corollarules's Avatar
    Join Date
    Jan 2011
    Location
    Peshawar
    Age
    25
    Posts
    263
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by waleed80 View Post
    its 15 km/ liter...when i push the car a little bit, after a while it comes down to 14.7....when driven carefully again, it goes up till 15.4 as it is currently parked in my garage.....how can it variate SO much that too without being reset ever ??? i own a city so i know how these things work....its like if u have gone from pindi to gujranwala and got average lets say 19....even if u drive it like craxy for next 20 kilometrs, average wont drop say less than 18.5....in other case, if u drive it at less speeds and getting 20 km/ liter within few kiilometers, the moment u press it hard it wud come down to 9-10 km/liter within 2 kilometers lets say...but in this passo case, as the fuel average can NOT be reset, it means the average it is showing from day one when the car was produced, right ? its driven 21000 kilometers by now, then how on earth is is possible that only within few kilometers of soft driving it is raised by almost 1 km/liter, drive hard for a kilometer it again comes down....drive soft again it again goes up...and most of all...WHY IS NOT RESETTING at the first place ???
    Thats strange. Quick variations are shown by instantaneous avg, but that does not show any reading on stand still. Check it out wit another passo. Or any pakwheeler with passo passo might be able to help. Try posting your query in passo fan club.

  15. #15
    Senior PakWheeler Follow
    khalid7shafqat's Avatar
    Join Date
    Sep 2014
    Location
    Karachi
    Age
    24
    Posts
    1,006
    Follows
    0
    Following
    0
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Corollarules View Post
    Thats strange. Quick variations are shown by instantaneous avg, but that does not show any reading on stand still. Check it out wit another passo. Or any pakwheeler with passo passo might be able to help. Try posting your query in passo fan club.
    Never seen or experienced this before. The only jugar I can think of is to disconnect the wiring to the speedometer, and connect it again

    nd @waleed80..you are right about the quick variations in readings. it shouldnt be the case if the mileage meter has not been reset.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •