Survey by Qualaroo
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 20 of 56
Like Tree12Likes

Thread: Passo 2005 transmission problem O/D light blinking

  1. #1
    PakWheeler Follow
    yasirammaar's Avatar
    Join Date
    Feb 2012
    Location
    Karachi
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Exclamation Passo 2005 transmission problem O/D light blinking

    I have this problem with my passo 2005 that when im driving normally, O/D light starts blinking suddenly and then gear shifting issues start coming up. following are the problems im facing:

    a. It so happens that when the car accelerates it shifts from 1st gear to 3rd gear with a jump.
    b. If car is at idle and gear is shifted to D or to R; car takes a heavy jolt.
    c. when in 1st gear it takes quite an acceleration to move to higher gear that is usually 3rd gear i think.

    The thing is if i switch off ignition and wait, then restart the car, this problem vanishes and may appear after 1 hour or so. it even happens then one day O/D light problem comes, the next day it doesn't! ive asked numerous times on the forum but nobody seems to have an idea.

    Please experts advise me on this case

  2. #2
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Its better,get it scanned.
    Never loose hope in life,every step gives u something.

  3. #3
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,597
    Follows
    31
    Following
    6
    Mentioned
    1018 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    please share some history of vehicle. when did you purchased and what was / is odometer reading, history of engine & transmission fluid changes, random blink O/D light & jolt on P->D or P ->R is : a) low transmission fluid, b). choked transmission fluid filter. - change fluids & filter as scanning will also help.
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  4. #4
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,597
    Follows
    31
    Following
    6
    Mentioned
    1018 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    these 2 topics will be of help as well - your Passo is non-CVT remember that.
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  5. #5
    PakWheeler Follow
    yasirammaar's Avatar
    Join Date
    Feb 2012
    Location
    Karachi
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I purchased to car in Feb 12, its odo reading was 55k. Car was fine from the start except for the fact that its consumption was poor i.e. 9-10 km/L. I changed the transmission fluid at about 60k and put in Toyota T-IV transmission fluid & also changed the entire kit of the oil sump. But i dont remember changing the filter. where is it located?
    - i checked the transmission fluid from dip stick recently , it seems fine. Any other way to check level?
    - Where is the best place to get it scanned from?

  6. #6
    PakWheeler Follow
    mehrhassan's Avatar
    Join Date
    Jun 2012
    Location
    Islamabad
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I had the same issue with my 2007 passo. There is a small sensor which needs to be replaced .. it cost around 4500Rs.

    Quote Originally Posted by yasirammaar View Post
    I purchased to car in Feb 12, its odo reading was 55k. Car was fine from the start except for the fact that its consumption was poor i.e. 9-10 km/L. I changed the transmission fluid at about 60k and put in Toyota T-IV transmission fluid & also changed the entire kit of the oil sump. But i dont remember changing the filter. where is it located?
    - i checked the transmission fluid from dip stick recently , it seems fine. Any other way to check level?
    - Where is the best place to get it scanned from?

  7. #7
    PakWheeler Follow
    yasirammaar's Avatar
    Join Date
    Feb 2012
    Location
    Karachi
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Can you plz tell me which particular sensor and where did u buy it from? details

    Quote Originally Posted by mehrhassan View Post
    I had the same issue with my 2007 passo. There is a small sensor which needs to be replaced .. it cost around 4500Rs.

  8. #8
    PakWheeler Follow
    yasirammaar's Avatar
    Join Date
    Feb 2012
    Location
    Karachi
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bump......

  9. #9
    PakWheeler Follow
    mehrhassan's Avatar
    Join Date
    Jun 2012
    Location
    Islamabad
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    get it scanned from any good workshop and the will diagnose the problem. in my case there was small sensor on top of the engine.

  10. #10
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by mehrhassan View Post
    get it scanned from any good workshop and the will diagnose the problem. in my case there was small sensor on top of the engine.
    I dont think so there is any part called "small sensor" anywhere in the engine
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  11. #11
    PakWheeler Follow
    arcansaggi's Avatar
    Join Date
    Jul 2014
    Posts
    11
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have the Passo 2006, and have the same problem last year, the car won?t pass speed of 40 due to O/D on/off, i visit a renowned mechanic in Islamabad, the blinking of O/D light was occasional and not showing at that time. He scanned the car for errors, which show no error. They checked the transmission oil which seemed 'Ganda', they changed the oil and also suggests that i should remove the CAT as it was blocked with carbon and causing this issue. I did so and removed that and add 'Plates' instead. It costs me around 12000 with transmission oil.

    The problem disappeared at that time, now I got serious problems transmission is producing loud sound for first two gears, I don?t know how this problem started and i haven?t visited any mechanic for detail inspection, the transmission oil seems OK. They suggest me to install a new trans.
    So I suggest you to visit a proper mechanic, with all advanced devices. I think all these problems started due to bad fuel/oil and excessive source of carbon in the engine.

  12. #12
    PakWheeler Follow
    arcansaggi's Avatar
    Join Date
    Jul 2014
    Posts
    11
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Had similar problem

    I have the Passo 2006, and have the same problem last year, the car won?t pass speed of 40 due to O/D on/off, i visit a renowned mechanic in Islamabad, the blinking of O/D light was occasional and not showing at that time. He scanned the car for errors, which show no error. They checked the transmission oil which seemed 'Ganda', they changed the oil and also suggests that i should remove the CAT as it was blocked with carbon and causing this issue. I did so and removed that and add 'Plates' instead. It costs me around 12000 with transmission oil.

    The problem disappeared at that time, now I got serious problems transmission is producing loud sound for first two gears, I don?t know how this problem started and i haven?t visited any mechanic for detail inspection, the transmission oil seems OK. They suggest me to install a new trans.
    So I suggest you to visit a proper mechanic, with all advanced devices. I think all these problems started due to bad fuel/oil and excessive source of carbon in the engine.

  13. #13
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    your technician is not skilled enough, he can pull any pending transmission codes, he could even get a freeze frame for the cause of this problem.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  14. #14
    PakWheeler Follow
    arcansaggi's Avatar
    Join Date
    Jul 2014
    Posts
    11
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Xulfiqar can please suggest me a good workshop for the purpose in pindi, islamabad.

  15. #15
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    btw what ATF was used in it?

    what sort of noise? - is it the torque converter whine that occurs from 0-10 km/h or is it a loud gear type sound like you hear from worn out differentials?
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  16. #16
    PakWheeler Follow
    arcansaggi's Avatar
    Join Date
    Jul 2014
    Posts
    11
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It was silver tin, i dont remember the brand, i was not there when they put that in it.

    when diagnosing the problem the guy at workshop used a stethoscope kind of device to check for the voice, he told me the voice is coming out of the transmission, when checked it was like wheel/bearing kind of part rotating and touching the body on the way.

    what are the options do i have, transmission system can be repairable or not?

  17. #17
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    the transmission is serviceable. The problem is that you have an orphaned gray import and its spare parts were never imported into Pakistan. so the rebuild will go like this.

    tear down transmission, check for worn parts, if hard parts are worn down - you can salvage from some other box, replace all soft parts and repack the transmission according to the repair manual.

    The soft parts (clutches, O rings, seals, etc) will need to be special ordered and imported into Pakistan.

    the other option is to buy a junkyard transmission and install it - It may or may not work - because it is from a junkyard.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  18. #18
    PakWheeler Follow
    casper11's Avatar
    Join Date
    May 2014
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have 100% the same problem in 2009 passo

  19. #19
    PakWheeler Follow
    casper11's Avatar
    Join Date
    May 2014
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    please update your passo problem how have you taken out its solution?????

  20. #20
    PakWheeler Follow
    casper11's Avatar
    Join Date
    May 2014
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    plz share yr passo problem status
    My passo has same issue

+ Reply to Thread
Page 1 of 3 123 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •