Survey by Qualaroo
+ Reply to Thread
Page 3 of 3 FirstFirst 123
Results 41 to 56 of 56
Like Tree12Likes

Thread: Passo 2005 transmission problem O/D light blinking

  1. #1
    PakWheeler Follow
    yasirammaar's Avatar
    Join Date
    Feb 2012
    Location
    Karachi
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Exclamation Passo 2005 transmission problem O/D light blinking

    I have this problem with my passo 2005 that when im driving normally, O/D light starts blinking suddenly and then gear shifting issues start coming up. following are the problems im facing:

    a. It so happens that when the car accelerates it shifts from 1st gear to 3rd gear with a jump.
    b. If car is at idle and gear is shifted to D or to R; car takes a heavy jolt.
    c. when in 1st gear it takes quite an acceleration to move to higher gear that is usually 3rd gear i think.

    The thing is if i switch off ignition and wait, then restart the car, this problem vanishes and may appear after 1 hour or so. it even happens then one day O/D light problem comes, the next day it doesn't! ive asked numerous times on the forum but nobody seems to have an idea.

    Please experts advise me on this case

  2. #41
    PakWheeler Follow
    spark445's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    36
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    [QUOTE=haseebsattar798;4932257]I had the same issue with my passo..firstly i scanned my vehicle and it shows error U101 , the electrician said there is an issue inthe gear gilter so you have to change the gear oil and filter..but when i changed both the things, the problem still persists.then i have scanned again and the electrician clean all my sensors with the dashboard cleaner that are located at the door panel on the passenger side inside the car with the 7cf carburator cleaner..
    And it gets the problem done
    Do the same before going to change your oil or any other sensor
    Cheers !

    Dear, would u pls provide more details about sensors located at door panel. by that you mean underneath gloves compartment where electrical fuses/ panel are fitted.

  3. #42
    PakWheeler Follow
    shadab_lodhi's Avatar
    Join Date
    Feb 2012
    Location
    Rawalpindi
    Posts
    85
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    CVT was installed in all models after 2007. Your car is 2005. First pull up the transmission error codes, if any. You could try calibrating the transmission on Daihatsu software.

  4. #43
    PakWheeler Follow
    shadab_lodhi's Avatar
    Join Date
    Feb 2012
    Location
    Rawalpindi
    Posts
    85
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hi bro spark445, in your case the problem my lie in the following areas:
    - Faulty Transmission Control Module (TCM)
    - TCM harness is open or shorted to ground.
    - TCM circuit poor electrical connection.
    Check all the transmission connectors for corrosion, loose connections or broken wires. Clean them out with a good dry type contact cleaner or Carbon Tetra Chloride (CTC).



  5. #44
    PakWheeler Follow
    spark445's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    36
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Dear lodhi, Thanks i also suspect same after done with everything rest. My technician mohsin autos in khi also suggest this quite long ago but i didnt opt for it he asked to leave vehicle for a day or 2 to check cables and connections thoroughly. As per him its quite often happens with auto 3 cylinder rides as engine vibrate alot thanks umair 03008234771 vl update after surgery

  6. #45
    PakWheeler Follow
    shadab_lodhi's Avatar
    Join Date
    Feb 2012
    Location
    Rawalpindi
    Posts
    85
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro spark445, I think there could be one more reason for the check light blinking. That is, if the ecm detects any misfire. That's why I told you to get it properly scanned for the errors. Thanks.

  7. #46
    PakWheeler Follow
    spark445's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    36
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    so here is the deal, after wandering here and there without solution to this problem. I went to Toyota central khi last week to make the final attempt...spent 12k on every thing (maintainance +checkup + wirings + tunning + scanning + spark plugs) . every thing is fine as per them.....for o/d light blinking issue they said "we do not have solution for this"........well after this visit ...my car ran smoothly for a week without raising a single alert...then finally problem came back.. i m bemused now 03008234771

  8. #47
    PakWheeler Follow
    mazzazeem's Avatar
    Join Date
    Dec 2015
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hi ,
    i Am facing bit same OD/Light along with Engine Check light is blinking Since Car takes jerk from first Gear to 3rd i guesss you speed and Gear is not Smooth i have Recently change sparks plugs , Head Gasket , Oil, Oil Filter, Air Filter , Radiator Services , i also been Check it through obdi2 no error codes found but when i Restart the Ecu after removing the Cables from Battery terminal Error vanish and car is Running smooth but after 1 hour of running it appears again and Jerking like it was before Xulfiqar bhai do you have any solution for this?

    Regards
    MA

  9. #48
    PakWheeler Follow
    spark445's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    36
    Posts
    12
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Finally, one smart guy in khi figured out my passo issue....he suggested to replace ecu which shown over temprature status on scanner....we replace ecu card wjich cost me 5k.....after after trail , od light and check light vanished but car again shutoff after a little drive.....hence scan again and it pull up error code of fuel pump...we then replace fuel pump at cost of 2k.....pump came out was chocked and dead......
    Since then Alhamdulliah vehicle running fine.....
    Umair khan 03008234771

  10. #49
    Senior PakWheeler Follow
    umarmuslim's Avatar
    Join Date
    May 2008
    Location
    Lahore
    Age
    26
    Posts
    2,784
    Follows
    10
    Following
    0
    Mentioned
    165 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by spark445 View Post
    Finally, one smart guy in khi figured out my passo issue....he suggested to replace ecu which shown over temprature status on scanner....we replace ecu card wjich cost me 5k.....after after trail , od light and check light vanished but car again shutoff after a little drive.....hence scan again and it pull up error code of fuel pump...we then replace fuel pump at cost of 2k.....pump came out was chocked and dead......
    Since then Alhamdulliah vehicle running fine.....
    Umair khan 03008234771
    so both parts were at fault did u try putting the original ECU back and then giving it a try ?

    wassalaam
    Transparency & Trust @ WWW.MYCAR.PK , salaam.

  11. #50
    PakWheeler Follow
    mazzazeem's Avatar
    Join Date
    Dec 2015
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hi My car facing same as Car getting heatup in about 10-15 mins fan starts auto and than shut although the car is warm now when i drive the car it gives me check engine light and sometime its give me OD ON/off light .

    I Change the Engine , put the new radiator , New Spar Plugs, and Error code is not dedected on the Scanner Car takes Jerk while Driving and gets shut due to Heatup issues i guess
    Xulfiqar bhai or Spark 445 can you please Tell me what should i do to fix it? its passo 2006

  12. #51
    PakWheeler Follow
    mazzazeem's Avatar
    Join Date
    Dec 2015
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Passo O/D light

    Hi Did you find any solution for this?

  13. #52
    PakWheeler Follow
    mazzazeem's Avatar
    Join Date
    Dec 2015
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Can you let me know where i can visit you i have OD on/off light and check engine light is appearing on my Car i Recently put a new Engine with new Radiator and new plugs but Problem is Still there CAR AC. also trips down after a while

  14. #53
    PakWheeler Follow
    rkbladex's Avatar
    Join Date
    Nov 2014
    Location
    Karachi
    Posts
    189
    Follows
    0
    Following
    1
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by spark445 View Post
    Finally, one smart guy in khi figured out my passo issue....he suggested to replace ecu which shown over temprature status on scanner....we replace ecu card wjich cost me 5k.....after after trail , od light and check light vanished but car again shutoff after a little drive.....hence scan again and it pull up error code of fuel pump...we then replace fuel pump at cost of 2k.....pump came out was chocked and dead......
    Since then Alhamdulliah vehicle running fine.....
    Umair khan 03008234771
    where is the workshop located in Karachi?

    Can you share the address or location of his workshop?

    - RKBladeX
    If you found my response helpful!!. Don't forget to press like button

  15. #54
    PakWheeler Follow
    mazzazeem's Avatar
    Join Date
    Dec 2015
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hi,
    Guys i have changed the Fuel Pump which Fill with Dirty also Replaced it for RS 1000 along with Sensor another thing is there is called Vtec Sensor which is located around Cam shaft need to be Replaced after than Engine check light along with O/D light has Gone and car is Running smoothly Allahmduillah

  16. #55
    Newbie Follow
    resodikromoandy's Avatar
    Join Date
    Nov 2016
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Thumbs up air_import

    i have 100% the same problem in 2005 passo
    check d transmion control 100% work

  17. #56
    PakWheeler Follow
    mazzazeem's Avatar
    Join Date
    Dec 2015
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by resodikromoandy View Post
    i have 100% the same problem in 2005 passo
    check d transmion control 100% work

    Do mean it work with changing the Senor?

+ Reply to Thread
Page 3 of 3 FirstFirst 123

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •