Survey by Qualaroo
+ Reply to Thread
Results 1 to 13 of 13
Like Tree1Likes
  • 1 Post By c4capricorn

Thread: Passo Engine Vibration

  1. #1
    PakWheeler Follow
    krkhan's Avatar
    Join Date
    Jul 2015
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Passo Engine Vibration

    Dear Friends,

    I recently buy Toyota Passo 2010, it has lot of issues, after solving few its still give vibration, special around 40 to 60 km speed, it also give vibration on startup but when driving on 40 to 60 km speed it give wired kind of vibration and when give more accelerator vibration vanish but when speed reduces vibration came back and also give jerks and feels like engine is stoping like engine normally do in first gear. things which done so far are: cleaning of throttle body, spark plugs, engine oil change, air filter change, exhaust silencer cleaning, after doing this car pick has been increased but vibration is still there, please share you knowledge on this and i hope will find something solve it. Regards Khalid


  2. #2
    PakWheeler Follow
    blueazure's Avatar
    Join Date
    Jan 2012
    Location
    Lahore
    Posts
    369
    Follows
    0
    Following
    0
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    check engine mounts, ( where the engine is bolted to the chassis ) .

  3. #3
    PakWheeler Follow
    krkhan's Avatar
    Join Date
    Jul 2015
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Have checked that its ok

  4. #4
    Senior PakWheeler Follow
    c4capricorn's Avatar
    Join Date
    May 2006
    Location
    Karachi
    Age
    35
    Posts
    1,199
    Follows
    0
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Community Votes: 2
    for that "Special" vibrations during certain speeds, get your axle inners checked...they are likely the problem.
    Whenever a bird shits on my car, I eat a plate of scrambled eggs on my front porch just to let them know what I'm capable of...

  5. #5
    Senior PakWheeler Follow
    tintin1's Avatar
    Join Date
    Jan 2014
    Location
    Lahore
    Posts
    1,829
    Follows
    7
    Following
    2
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    7
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    5

    Default

    Quote Originally Posted by krkhan View Post
    Dear Friends,

    I recently buy Toyota Passo 2010, it has lot of issues, after solving few its still give vibration, special around 40 to 60 km speed, it also give vibration on startup but when driving on 40 to 60 km speed it give wired kind of vibration and when give more accelerator vibration vanish but when speed reduces vibration came back and also give jerks and feels like engine is stoping like engine normally do in first gear. things which done so far are: cleaning of throttle body, spark plugs, engine oil change, air filter change, exhaust silencer cleaning, after doing this car pick has been increased but vibration is still there, please share you knowledge on this and i hope will find something solve it. Regards Khalid
    Seems wheels are not balance.
    Do the wheel balancing from some good place and then feel if the vibrations are still there.

    which engine oil you are feeding?
    also have it check by some good electrician to make sure its current is ok.
    Be Addicted To Help Others.

  6. #6
    PakWheeler Follow
    krkhan's Avatar
    Join Date
    Jul 2015
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Wheel balancing done, but result is same, i also replaced fuel injectors but doesn't effort

  7. #7
    Senior PakWheeler Follow
    DrUsmanNawaz's Avatar
    Join Date
    Jul 2011
    Location
    Wah cantt
    Age
    34
    Posts
    3,928
    Follows
    19
    Following
    0
    Mentioned
    165 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Hmm thinking over it...

    Was vibration present in the car when u bought it from Day 1...?
    Keep Faith in Allah...

  8. #8
    PakWheeler Follow
    krkhan's Avatar
    Join Date
    Jul 2015
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    yes since i purchased

  9. #9
    PakWheeler Follow
    bilal_import_lover's Avatar
    Join Date
    Jun 2015
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Ac on or off??

  10. #10
    PakWheeler Follow
    krkhan's Avatar
    Join Date
    Jul 2015
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    both, even more when AC working

  11. #11
    Senior PakWheeler Follow
    tintin1's Avatar
    Join Date
    Jan 2014
    Location
    Lahore
    Posts
    1,829
    Follows
    7
    Following
    2
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    7
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    5

    Default

    Quote Originally Posted by krkhan View Post
    both, even more when AC working
    From which city you are ?
    Be Addicted To Help Others.

  12. #12
    PakWheeler Follow
    shaman.adil's Avatar
    Join Date
    Mar 2016
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Well I had the same problem. Checked out the sensor and the brake and accelerator pedals, then it worked fine


    Sent from my iPhone using PW Forums

  13. #13
    PakWheeler Follow
    perwez's Avatar
    Join Date
    May 2004
    Location
    Karachi
    Age
    58
    Posts
    306
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Dear Krkhan;

    Vibration is in almost all Passo. It is due to clogged Catalytic Converter. Go to any 3S Toyota Dealership and get your car scanned by computer. Get the Catalytic converter clean and you will be all fine. Please update about the progress.
    COP

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •