Survey by Qualaroo
+ Reply to Thread
Results 1 to 10 of 10

Thread: ABS, VSC, (!) and parking light problem in prius 2007

  1. #1
    PakWheeler Follow
    turbo47's Avatar
    Join Date
    Feb 2016
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default ABS, VSC, (!) and parking light problem in prius 2007

    When I start my prius 2007, sometimes the ABS, VSC, (!) and the red parking brake lights come ON (even when parking brake is not engaged) simultaneously along with the sound of a warning buzzer. This condition persists for an unspecified amount of time (sometimes for 3-5 seconds, sometimes for 10, 15 or may be 40-60 seconds). During this condition, the car otherwise functions well except that the brakes don't work. A day before, when I started the car after having parked it for about an hour and a half to have dinner, the ABS, VSC, (!) and the red parking lights came on along with the warning buzzer and did not go off even after waiting for a few minutes. Then when I put the car in D and started moving, the brakes didn't work as expected. I started idling at a speed of 15-30 km/h but in order to stop the car, full pressure needed to be applied on the brake paddle and even then the car would stop very slowly after covering quit a distance (for example, at 15 km/h it would stop after 20-30 meters approximately when brake paddle was fully pressed). This condition persisted for quite some time and the warning lights and the warning buzzer remained ON all the time. I traveled this way from F-7 to G-11. Then the warning lights and the buzzer went OFF suddenly by itself and the brakes and everything else worked perfectly well. It is still working well, except when starting the car the next morning the same condition persisted for a few seconds and then it was fine.

    I searched the web for the problem and found that a lot of people using prius have the same problem, some suggest replacing the stop light/brake light switch, others say that it is because of the 12v battery going old. Toyota capital in isb scanned it and did some tweaking but said that a 'pressure accumulator' may need replacement if the problem persists. This condition has not occured after getting it checked from Toyota except that the ABS, VSC, (!) and red parking lights stay on for 3-5 seconds alongwith the warning buzzer upon starting the car after parking it.

    Any help would be really appreciated.

  2. #2
    Senior PakWheeler Follow
    umarmuslim's Avatar
    Join Date
    May 2008
    Location
    Lahore
    Age
    26
    Posts
    2,789
    Follows
    10
    Following
    0
    Mentioned
    165 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by turbo47 View Post
    when i start my prius 2007, sometimes the abs, vsc, (!) and the red parking brake lights come on (even when parking brake is not engaged) simultaneously along with the sound of a warning buzzer. This condition persists for an unspecified amount of time (sometimes for 3-5 seconds, sometimes for 10, 15 or may be 40-60 seconds). During this condition, the car otherwise functions well except that the brakes don't work. A day before, when i started the car after having parked it for about an hour and a half to have dinner, the abs, vsc, (!) and the red parking lights came on along with the warning buzzer and did not go off even after waiting for a few minutes. Then when i put the car in d and started moving, the brakes didn't work as expected. I started idling at a speed of 15-30 km/h but in order to stop the car, full pressure needed to be applied on the brake paddle and even then the car would stop very slowly after covering quit a distance (for example, at 15 km/h it would stop after 20-30 meters approximately when brake paddle was fully pressed). This condition persisted for quite some time and the warning lights and the warning buzzer remained on all the time. I traveled this way from f-7 to g-11. Then the warning lights and the buzzer went off suddenly by itself and the brakes and everything else worked perfectly well. It is still working well, except when starting the car the next morning the same condition persisted for a few seconds and then it was fine.

    I searched the web for the problem and found that a lot of people using prius have the same problem, some suggest replacing the stop light/brake light switch, others say that it is because of the 12v battery going old. Toyota capital in isb scanned it and did some tweaking but said that a 'pressure accumulator' may need replacement if the problem persists. This condition has not occured after getting it checked from toyota except that the abs, vsc, (!) and red parking lights stay on for 3-5 seconds alongwith the warning buzzer upon starting the car after parking it.

    Any help would be really appreciated.
    most likely it is the hybrid inverter pump its gets freid every 2 years it costs pkr 9,000 to replace it with labour

    wassalaam
    Transparency & Trust @ WWW.MYCAR.PK , salaam.

  3. #3
    PakWheeler Follow
    turbo47's Avatar
    Join Date
    Feb 2016
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Which is a suitable place where I can get it replaced?

  4. #4
    PakWheeler Follow
    ahmedwasiq's Avatar
    Join Date
    Nov 2007
    Location
    Rawalpindi
    Age
    31
    Posts
    397
    Follows
    1
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Your ABS unit need to be replaced.


    Sent from my KIW-L21 using PW Forums mobile app

  5. #5
    Senior PakWheeler Follow
    umarmuslim's Avatar
    Join Date
    May 2008
    Location
    Lahore
    Age
    26
    Posts
    2,789
    Follows
    10
    Following
    0
    Mentioned
    165 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by turbo47 View Post
    which is a suitable place where i can get it replaced?
    which city are you in ?

    Quote Originally Posted by ahmedwasiq View Post
    your abs unit need to be replaced.


    Sent from my kiw-l21 using pw forums mobile app
    mostly the pump causes this with a/c not working

    but could also be the abs unit

    wassalaam
    Transparency & Trust @ WWW.MYCAR.PK , salaam.

  6. #6
    PakWheeler Follow
    turbo47's Avatar
    Join Date
    Feb 2016
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Islamabad or faisalabad or lahore. All these cities are accessible to me.

  7. #7
    Senior PakWheeler Follow
    umarmuslim's Avatar
    Join Date
    May 2008
    Location
    Lahore
    Age
    26
    Posts
    2,789
    Follows
    10
    Following
    0
    Mentioned
    165 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by turbo47 View Post
    Islamabad or faisalabad or lahore. All these cities are accessible to me.
    Jawaid Akhtar aka Denso or Zaheer in Lahore

    Wassalaam
    Transparency & Trust @ WWW.MYCAR.PK , salaam.

  8. #8
    PakWheeler Follow
    shadab_lodhi's Avatar
    Join Date
    Feb 2012
    Location
    Rawalpindi
    Posts
    85
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get the car be air bled with the help of a diagnostic computer, delete the codes and then check for further problems.

  9. #9
    PakWheeler Follow
    MuhammadMusa's Avatar
    Join Date
    Oct 2012
    Location
    Lahore
    Posts
    888
    Follows
    0
    Following
    0
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Ive gone through the same problem your ABS is worn out and needs to be replaced this is a very typical problem in this model

    Sent from my SM-G925F using PW Forums mobile app

  10. #10
    Senior PakWheeler Follow
    mwm749's Avatar
    Join Date
    Mar 2008
    Location
    Dubai
    Age
    59
    Posts
    1,160
    Follows
    1
    Following
    0
    Mentioned
    29 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Dear PW,

    Dont waste time and money. As said by Musa the ABS unit needs to be replaced.
    I had same problem with my car too, had to get the ABS replaced in end.
    Also understand that its very risky to drive the car in this condition.
    I Dont Drive Fast, I Fly Slowly....

  11. 01-11-2016, 11:31 AM

    Site Banned

    Reason
    spam

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •