Survey by Qualaroo
+ Reply to Thread
Results 1 to 17 of 17
Like Tree3Likes
  • 1 Post By omar4494
  • 1 Post By Haji__John
  • 1 Post By AamirMughal

Thread: Bought new GS 150

  1. #1
    PakWheeler Follow
    AamirMughal's Avatar
    Join Date
    Oct 2010
    Location
    Karachi
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Bought new GS 150

    Hi,

    Yesterday I bought a brand new GS-150 after getting tired of CG's vibratory ride but I am getting a problem. The engine is doing missing a lot when I increase the throttle (as if the bike is intaking air). When I was picking the bike up from the showroom, the guy there told me that it will do this for a while because it is "new and cold". But now I have driven it ~25Kms and the engine is still doing missing. Also, whenever I let go of the throttle, the RPM gets stuck where it was previously for 5-7 seconds, then slowly gets back to ~1.5k RPM.

    Is this normal behaviour or should I get it checked?

    Stay safe,

    Aamir


  2. #2
    Senior PakWheeler Follow
    omar4494's Avatar
    Join Date
    Aug 2005
    Location
    Lahore
    Posts
    1,255
    Follows
    1
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Not a normal behavior, go back to dealership and bang on there heads.

  3. #3
    PakWheeler Follow
    post911's Avatar
    Join Date
    Jul 2012
    Location
    Other
    Posts
    189
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Gs150 r very poorly build machines,
    As if the designer was told u will not get extra toppings on ur pie if u build it nice,
    Or
    And the gaskets all around the bike t made of dalda packing leftovers...

  4. #4
    PakWheeler Follow
    AamirMughal's Avatar
    Join Date
    Oct 2010
    Location
    Karachi
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by omar4494 View Post
    Not a normal behavior, go back to dealership and bang on there heads.
    Ok then, will get it checked out soon thanks. I hope its something small.

  5. #5
    Senior PakWheeler Follow
    hamikhan's Avatar
    Join Date
    Jun 2014
    Location
    Other
    Posts
    1,259
    Follows
    1
    Following
    0
    Mentioned
    37 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    First of all congrats for buying this beautiful machine Amir & second missing in new GS150 is a normal behavior when you suddenly accelerate it then it will do missing accelerate it gradually not suddenly & for RPM stucking problem check its accelerator wire i am also owner of this machine for any other suggestions you can ask me here
    Quote Originally Posted by AamirMughal View Post
    Hi,

    Yesterday I bought a brand new GS-150 after getting tired of CG's vibratory ride but I am getting a problem. The engine is doing missing a lot when I increase the throttle (as if the bike is intaking air). When I was picking the bike up from the showroom, the guy there told me that it will do this for a while because it is "new and cold". But now I have driven it ~25Kms and the engine is still doing missing. Also, whenever I let go of the throttle, the RPM gets stuck where it was previously for 5-7 seconds, then slowly gets back to ~1.5k RPM.

    Is this normal behaviour or should I get it checked?

    Stay safe,

    Aamir

  6. #6
    PakWheeler Follow
    abuzerkhan's Avatar
    Join Date
    Sep 2008
    Location
    Lahore
    Age
    32
    Posts
    342
    Follows
    0
    Following
    4
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    same was issue with my bike. bought it last month but now its fine after first tuning.

  7. #7
    PakWheeler Follow
    AamirMughal's Avatar
    Join Date
    Oct 2010
    Location
    Karachi
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Ok, so I noticed something today. After I ride the bike for 4-5 kilometres after cold startup, the missing is gone. But the RPM problem is still there.

    @hamikhan
    Thanks for the support.

  8. #8
    Senior PakWheeler Follow
    rozzzzz's Avatar
    Join Date
    Oct 2005
    Location
    Islamabad
    Posts
    21,925
    Follows
    12
    Following
    0
    Mentioned
    140 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    cold start but even with fresh tune up in 1 or km it goes fine ..........

    check it ...rpm issue does not look normal .... or check the acce cable ..it may not be properly fit

    btw congrats on the new bike ... good move .. as i have 1 cg in hand n its vibrate alot
    MOTOR MANIACS ... An automotive service and repair workshop
    https://www.facebook.com/pages/Motor-Maniacs/721830141231922

  9. #9
    PakWheeler Follow
    Haji__John's Avatar
    Join Date
    Dec 2011
    Location
    Rawalpindi
    Age
    25
    Posts
    293
    Follows
    1
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Check the choke. You probably left it on.
    "Imagination is more important than knowledge"

  10. #10
    PakWheeler Follow
    AamirMughal's Avatar
    Join Date
    Oct 2010
    Location
    Karachi
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Haji__John View Post
    Check the choke. You probably left it on.
    No its closed.

  11. #11
    PakWheeler Follow
    AamirMughal's Avatar
    Join Date
    Oct 2010
    Location
    Karachi
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    So it seems the missing has reduced significantly and I haven't encountered RPM stucking again.

    Anyways, when should I do the first tuning? Odo is at 85km. Also, which oil should I use?

  12. #12
    Senior PakWheeler Follow
    hamikhan's Avatar
    Join Date
    Jun 2014
    Location
    Other
    Posts
    1,259
    Follows
    1
    Following
    0
    Mentioned
    37 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Aamir dear enjoy this beautiful power machine GS has A right to be Loved it missing will be gone after First tuning you can go for first tuning after 1000KM but before first tuning Gradually increase bike speed change your bike first engine oil at 300KM keep using Suzuki genuine oil 10W40 till 3000 kilometers because it is A thin oil but you must change it on every 700KM drain interval because it does not last above 700KM after 3000KM use ZIC M5 20W40 blue color box & be sticked with it change it on after every 1000KM it is A Excellent engine oil for Lovely GS
    Quote Originally Posted by AamirMughal View Post
    So it seems the missing has reduced significantly and I haven't encountered RPM stucking again.

    Anyways, when should I do the first tuning? Odo is at 85km. Also, which oil should I use?

  13. #13
    PakWheeler Follow
    AamirMughal's Avatar
    Join Date
    Oct 2010
    Location
    Karachi
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @hamikhan
    Thanks but I've read on many threads here and from many others not to use the Suzuki oil.

    Also, is there any solution to the change the seat? It is way too hard and uncomfortable.

  14. #14
    Senior PakWheeler Follow
    hamikhan's Avatar
    Join Date
    Jun 2014
    Location
    Other
    Posts
    1,259
    Follows
    1
    Following
    0
    Mentioned
    37 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Basically Suzuki oil is A mineral oil better is that in break in period you are forced to be used any mineral oil it is good for yours bike,s engine health if you not like suzuki oil you can use zic M5 4T20W40 from first oil change & for seat it will be goes soft from time being

  15. #15
    PakWheeler Follow
    AamirMughal's Avatar
    Join Date
    Oct 2010
    Location
    Karachi
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @hamikhan
    I've ran the bike for ~320km now and its time to change the oil. But I have few questions

    1. From where can I get oil changed?

    2. Will it void the warranty if I get the oil changed before 1000 kms mentioned in the manual?

  16. #16
    PakWheeler Follow
    AamirMughal's Avatar
    Join Date
    Oct 2010
    Location
    Karachi
    Posts
    36
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Anyone?

  17. #17
    PakWheeler Follow
    rai007's Avatar
    Join Date
    Nov 2010
    Location
    Karachi
    Posts
    73
    Follows
    0
    Following
    0
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Post

    you can get it changed from anywhere. it's not gonna void your warranty. 2nd oil change at 650- 700 and third on 1000. change the oil filter on every oil change till then 1000km.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •