Survey by Qualaroo
+ Reply to Thread
Results 1 to 6 of 6

Thread: Suzuki GS 150 Missing/Stopping on Irregular intervals

  1. #1
    PakWheeler Follow
    bc003mzy's Avatar
    Join Date
    Aug 2006
    Location
    Karachi
    Age
    33
    Posts
    27
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Suzuki GS 150 Missing/Stopping on Irregular intervals

    Hi,
    I have GS 150 2012 Model. Since couple of weeks it suddenly start missing and gradually stops. After starting again runs fine but same behavior happens later on. So far i have done following things
    1. Plug checkup
    2. Oil Change
    3. Engine Tuning
    4. Carburetor Cleaning
    5. Petrol Tank Cap
    6. Petrol Quality

    Now mechanic is asking for Clutch Plates and Pressure plates change. Kindly advice if its fine or anything else can be checked. Thanks.


    Regards,
    Muhammad Zahid

  2. #2
    Senior PakWheeler Follow
    Shafin619's Avatar
    Join Date
    Sep 2012
    Location
    Karachi
    Age
    21
    Posts
    2,699
    Follows
    2
    Following
    0
    Mentioned
    95 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Check its current coil maybe bike is not getting proper current from current oil.

    Sent from my SM-J700H using Tapatalk
    4 wheels move the body 2 wheels move the soul

  3. #3
    PakWheeler Follow
    bc003mzy's Avatar
    Join Date
    Aug 2006
    Location
    Karachi
    Age
    33
    Posts
    27
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Shafin619: Thanks for the advice. I will check. But anything related to clutch/pressure plates ?

  4. #4
    Senior PakWheeler Follow
    Hassan1991's Avatar
    Join Date
    Mar 2013
    Location
    Lahore
    Age
    20
    Posts
    2,260
    Follows
    3
    Following
    0
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by bc003mzy View Post
    @Shafin619: Thanks for the advice. I will check. But anything related to clutch/pressure plates ?
    There's no connection of missing of a bike with clutch plates.
    The first step towards knowledge is to know that WE are IGNORANT

  5. #5
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,544
    Follows
    25
    Following
    0
    Mentioned
    349 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    You need to find a better mechanic if your mechanic is blaming clutch plates for missing

  6. #6
    PakWheeler Follow
    mehals's Avatar
    Join Date
    Feb 2014
    Posts
    14
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    AOA

    brother i have faced same issue last month and believe me you will be surprised when i will tell you the root cause of my bike missing and sudden stop.
    initially i was also focusing on ignition coil and i have replacement it with suzuki genuine NGK ignition coil, and found out that suzuki itself purchasing substandard ignition coil from some local supplier after that i have got honda 125 Deluxe ignition coil for Rs 1450 from makhdum.

    in my case the main culprit was battery terminal connection loose, because i have installed a maintenance free battery its contacts are a bit difficult to manage.
    i suggest you to kindly cross check the both ignition coil contacts and battery contacts and make sure they tightly fitted or replace them if required, my advise to you is don't use it in this condition as you might damage your engine, timing chain or connecting rod might get effected.

    hope this solve your issue.

    take care

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •