Survey by Qualaroo
+ Reply to Thread
Results 1 to 12 of 12

Thread: Vitz Bad fuel avearge .

  1. #1
    PakWheeler Follow
    saqib1's Avatar
    Join Date
    Aug 2008
    Age
    43
    Posts
    48
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz Bad fuel avearge .

    Dear pakwheelers !


    I am facing the problem of bad fuel average in my VITZ 2005 since many a days. It gives me just 8 with A.C in city and 10 without.


    I have already done the following series of actions to help improve the averaging but in vain.


    1) Replaced the engine oil with TMO invcluding oil filter.


    2) Changed the air filter with original Denso one.


    3) Cleaned the throttle body.


    4) Removed the Cat Converter


    5) Changed the plugs with Oroginal Denso iridium ones


    6) Reset the ECU afterwards


    The above events have just improved the acceleration but the problem of low fuel average still exists. There is no Check engine light that indicates that all scensers are working fine.


    In ur opinion what may be the real hidden cause of such low fuel efficiency? Which of the following works may surely prove to be the underlying cause of problem?


    a) ATF change. The veichle has done just 30000 km.


    b) MAF senscer cleaning.


    c) Fuel filter/pump replacement.


    OR ANY OTHER.......


    Please suggest as i am realy worried and anxious about.





    Thanx

  2. #2
    PakWheeler Follow
    saqib1's Avatar
    Join Date
    Aug 2008
    Age
    43
    Posts
    48
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Any one for help ?

  3. #3
    PakWheeler Follow
    razapower's Avatar
    Join Date
    Nov 2004
    Location
    Islamabad
    Age
    40
    Posts
    403
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    what is your tyre profile?

  4. #4
    Senior PakWheeler Follow
    waleed_khushi's Avatar
    Join Date
    Jul 2006
    Location
    Lahore
    Age
    26
    Posts
    10,401
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    am getting 12 with full ac on . nd the car is on stock tyres
    work is healthy activity so leave it for sick people

  5. #5
    Site Banned Follow
    exclusive_1's Avatar
    Join Date
    Apr 2009
    Location
    Sialkot
    Age
    46
    Posts
    269
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Could be ur fuel pump if not then may b its how u drive...........

  6. #6
    Senior PakWheeler Follow
    REDZDEVIL's Avatar
    Join Date
    Jul 2008
    Location
    Islamabad
    Age
    28
    Posts
    3,489
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    was facin da smae problem... bt sumhow ot got splved all by itself..!!

  7. #7
    Senior PakWheeler Follow
    iLLDuDe786's Avatar
    Join Date
    Feb 2009
    Location
    New York City
    Posts
    11,213
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    wow thats really bad...im getting 13km/l with normal AC in city......you should try to get your petrol from SHELL and mix a little bit of hi octane in itt......
    -

  8. #8
    PakWheeler Follow
    saqib1's Avatar
    Join Date
    Aug 2008
    Age
    43
    Posts
    48
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by razapower

    what is your tyre profile?




    My tyres are 165/70 R14 . Bridgestone B250 that were with the car when I purchased it. No rims n 28psi air pressure.

  9. #9
    Senior PakWheeler Follow
    kiani1's Avatar
    Join Date
    Jan 2005
    Location
    Rawalpindi
    Age
    27
    Posts
    3,238
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Pump up to 30Psi ! 28 is low I think.


    And check for bad injectors or Fuel pressure regulator. IF you can get to a tuning place with an O2 sensor, check if your car is running RICH.
    B2 Innovations - Events & Media Managers

    http://www.facebook.com/group.php?gid=129332754507

  10. #10
    PakWheeler Follow
    saqib1's Avatar
    Join Date
    Aug 2008
    Age
    43
    Posts
    48
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by kiani1



    Pump up to 30Psi ! 28 is low I think.


    And check for bad injectors or Fuel pressure regulator. IF you can get to a tuning place with an O2 sensor, check if your car is running RICH.



    @kiani1 Thanx 4 the advice.


    Can anyone guide me for a nice place where I can check for injecter or fuel pressure as Toyota people charges are quite high.

  11. #11
    Newbie Follow
    bigrarana's Avatar
    Join Date
    Jul 2009
    Location
    Karachi
    Age
    28
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by kiani1





    Pump up to 30Psi ! 28 is low I think.


    And check for bad injectors or Fuel pressure regulator. IF you can get to a tuning place with an O2 sensor, check if your car is running RICH.







    @kiani1 Thanx 4 the advice.


    Can anyone guide me for a nice place where I can check for injecter or fuel pressure as Toyota people charges are quite high.



    i am getting 13 to 14 with ac in city!!

  12. #12
    Senior PakWheeler Follow
    murtaza_murti's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    23
    Posts
    10,354
    Follows
    2
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Change your fuel pump
    - '06 Toyota Belta 1.0L X - '68 VW Beetle 1300 DP - '89 Nissan B12 E16

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •