Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: Vitz on CNG... can we avoid venturi?

  1. #1
    PakWheeler Follow
    hamad_ahsan's Avatar
    Join Date
    Dec 2005
    Location
    Islamabad
    Age
    32
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz on CNG... can we avoid venturi?

    i am facing missing issues with my vitz both on CNG & Petrol. when venturi is removed, it runs fine on petrol. as per mechanic, this is due to increased gap introduced between MAF sensor and throttle body by venturi...

    My question is can we avoid venturi in order to inject CNG into throttle body???

    a frnd of mine removed venturi from my car and injected CNG directly in throttle body through the opening for blow off valve thus disconnecting it... missing problem was solved by engine started backfiring... and i had burnt air filters...

    is there any other efficient way to get CNG operational without using this venturi??

    Bold and Dynamic... Second to None

  2. #2
    PakWheeler Follow
    123321123's Avatar
    Join Date
    Jun 2008
    Location
    Lahore
    Posts
    85
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    This is not venturi issue.

    i also had the same issue but the problem was found in the CNG wiring.
    The Voltage was dropping for one of the piston-coil, changing the wires solved the issue and Alhmadulilah its running fine from that day onwards.

    Go to some real CNG mechanic and ask him to analyse the issue. (CNG wiring is put using petrol wiring, original one, so such issue causes missing both on Petrol and Gas)

    i hope this would help.

  3. #3
    PakWheeler Follow
    hamad_ahsan's Avatar
    Join Date
    Dec 2005
    Location
    Islamabad
    Age
    32
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thanks bro... i got venturi removed... inserted a nozzle in throttle body and now air cleaner is back on place... but issue still there... i took mechanic and car to ata wali autos... we changed all the coils, MAF sensor, advancer emulator etc there but of no use... all wiring is ok... now it seems like problem is with timing chain or something more deep... i'll continue tomorrow... wish me luck
    Bold and Dynamic... Second to None

  4. #4
    PakWheeler Follow
    Spy3D's Avatar
    Join Date
    Nov 2007
    Location
    Karachi
    Age
    35
    Posts
    40
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I also had missing issue on my Vitz but only on petrol, was running fine on CNG. It turned out that by fuel-pump motor has gotten weak, so i got it replace.. costed me around 6k

  5. #5
    PakWheeler Follow
    hamad_ahsan's Avatar
    Join Date
    Dec 2005
    Location
    Islamabad
    Age
    32
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Issue Resolved

    after trying all possible solutions... finally i replaced complete Head with a kabli one... and everything is running perfectly fine now... repairing head was expected to cost nearly 15k... but i got this head swap in 10K only
    Bold and Dynamic... Second to None

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •