Survey by Qualaroo
+ Reply to Thread
Results 1 to 2 of 2

Thread: Vitz 2004-04 CNG Problem

  1. #1
    PakWheeler Follow
    Spy3D's Avatar
    Join Date
    Nov 2007
    Location
    Karachi
    Age
    35
    Posts
    40
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz 2004-04 CNG Problem

    AOA,

    I got 2003 Toyota Vitz auto-transmission.. since yesterday i am having a problem with it on CNG but perfectly fine on Patrol.

    The problem is that when in low speed i leave the accelerator, the car vibrates a little turns and turns off ( like acceleration is low )

    So what can be causing this ? I repeat car is perfectly fine on patrol and this is happening only when i leave the accelerator at low speed or idle on CNG

    Thank you
    - Yunus


  2. #2
    PakWheeler Follow
    shoodi's Avatar
    Join Date
    Nov 2006
    Location
    Rabwah
    Age
    36
    Posts
    318
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    CNG Settings .. Required .

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •