Survey by Qualaroo
+ Reply to Thread
Results 1 to 3 of 3

Thread: Engine Stall Problem - Vitz (Error Code P0505)

  1. #1
    PakWheeler Follow
    mrkhurshid's Avatar
    Join Date
    May 2008
    Location
    Karachi
    Age
    33
    Posts
    149
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I am facing a very annoying issue of Engine stall on idle position in my Vitz 2000 on both CNG and Petrol.

    I went to the mechanic to scan the ride using Scanner and got 'P0505 Idle COntrol System Malfunction' error. He wasn't qualified to get it fixed therefore I came back and tried searching online but unfortunately didn't find anything helpful.

    If you guys please help me out to get this fixed since it is very annoying and embarrassing specially on traffic signals.

    Thanks

    Riz

    http://www.flickr.com/rkhurshid

  2. #2
    Senior PakWheeler Follow
    Storm's Avatar
    Join Date
    Feb 2005
    Location
    Select City
    Posts
    40,235
    Follows
    9
    Following
    0
    Mentioned
    48 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    most likely the idle in the vitz is controlled by the air flow sensor. get the sensor cleaned and give it a try. if a cleaned one fails to fix it then maybe try replacing it.
    1. A car is only worth what someone is willing to pay for it, 2. Resale wont save your life in an accident, 3. Genius has limits, stupidity has none, 4. Never argue with an idiot, they will bring you down to their level & beat you with experience, 5. Growing old beats the alternative -- dying young! 6. انّا للہ و انّا الیہ راجعون

  3. #3
    PakWheeler Follow
    mrkhurshid's Avatar
    Join Date
    May 2008
    Location
    Karachi
    Age
    33
    Posts
    149
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes, this is what I get to know so far. DO you know any good mechanic here in khi? Though most of them look idiot to me because they don't know a **** about the error code and charge alot of money and claiming it's fixed.(duh!)

    I am thinking to clean the MAF and IACV sensor myself using some electric wire cleaning spray tomorrow. I hope that will fix the problem. (have a look at Pcv, Iacv, Maf And Throttle Body Cleaning Guide(pics Incl'd) - Toyota Matrix Owners Forum )

    One more thing which my mechanic told me today, he said that there is a need to open the head of the engine since 'Duboo' (may he is referring to Values) are jammed and this is the reason why my car is stalling and doing a backfire. Does this make any sense to you, at least not to me ?

    Cheers,

    Riz
    http://www.flickr.com/rkhurshid

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •