Survey by Qualaroo
+ Reply to Thread
Results 1 to 9 of 9

Thread: abs light comes on vitz 05

  1. #1
    PakWheeler Follow
    osk89's Avatar
    Join Date
    Jun 2009
    Location
    Lahore
    Age
    28
    Posts
    327
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default abs light comes on vitz 05

    hi guys i have a vitz 05 and sometimes it abs light comes on and abs stops working can some one help .? this happen very rarely. but when i turn the car off and start it again the abs works fine . what could be the problem

    Omar Khan

  2. #2
    Senior PakWheeler Follow
    irfansiddique's Avatar
    Join Date
    Oct 2008
    Location
    Karachi
    Age
    33
    Posts
    1,765
    Follows
    2
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check following things
    brake fluid,
    ABS sensors

  3. #3
    Senior PakWheeler Follow
    Owais_Yunus's Avatar
    Join Date
    Sep 2005
    Location
    Islamabad
    Age
    28
    Posts
    2,224
    Follows
    4
    Following
    0
    Mentioned
    60 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    You didnt get a third brake light installed recently did you? I installed a third brake light in vitz 99 once and for some odd reason, the abs light started showing up. When I disconnected the third brake light, the abs light stopped showing. Weird though

  4. #4
    PakWheeler Follow
    osk89's Avatar
    Join Date
    Jun 2009
    Location
    Lahore
    Age
    28
    Posts
    327
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @irfan
    the brake fluid is ful and the mechanics says the sensor is fine otherwise the abs light wouldn't turn off when you restart the car

    @owais
    no i didnt get the third brake light
    Omar Khan

  5. #5
    Senior PakWheeler Follow
    waleed80's Avatar
    Join Date
    May 2006
    Location
    Rawalpindi
    Age
    36
    Posts
    6,690
    Follows
    2
    Following
    0
    Mentioned
    36 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    m not an expert, but mite be due to some loose connections in the wiring which makes the ABS work...

  6. #6
    PakWheeler Follow
    adeelgujjar's Avatar
    Join Date
    Sep 2004
    Location
    Islamabad
    Age
    28
    Posts
    34
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    take the battery terminal off for a few seconds, it will reset the ecu. i had the similar problem in 99 vitz. hopefully it wont appear again

  7. #7
    PakWheeler Follow
    osk89's Avatar
    Join Date
    Jun 2009
    Location
    Lahore
    Age
    28
    Posts
    327
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @ waleed
    ok i will get the connections checked

    @ adeel
    I've already tried that it does'nt work
    Omar Khan

  8. #8
    Senior PakWheeler Follow
    raohamid's Avatar
    Join Date
    Mar 2009
    Location
    Select City
    Age
    37
    Posts
    2,176
    Follows
    2
    Following
    0
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Have the same problem in my Mitsubishi Shogun, just turns on some times for no reason, as soon as I restart the SUV, all is well. Please let me know if you find a solution.

    Rao.
    I will miss her, that RKR. She will always be the one that got away.
    But, life goes on. From RKR to MMC. 4x4 Engaged? Team Unimog, Pakistan

  9. #9
    PakWheeler Follow
    foxy_the_beast's Avatar
    Join Date
    Aug 2007
    Location
    Rawalpindi
    Age
    23
    Posts
    340
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    same thing happens with my 2000 vitz.but now i hav sold iy
    -DONT CUT ITS HANNI"S-

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •