Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: Vitz petrol problem

  1. #1
    PakWheeler Follow
    BASITNAMDAR's Avatar
    Join Date
    Mar 2009
    Location
    Karachi
    Age
    46
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz petrol problem

    When i start my vitz after a long rest i.e. after 7 8 hours the car doesnt accelerate on petrol immediately i.e. when i press the full accelerator car starts to shake no acceleration but when i leave the accelerator the car idle is quite normal this happens for first 5 10 minutes but after this car runs perfectly fine. Car is on CNG is it due to emulator setting or what??? Experts need ur help


  2. #2
    959
    959 is offline
    Senior PakWheeler Follow
    959's Avatar
    Join Date
    Jan 2007
    Location
    Karachi
    Age
    32
    Posts
    3,121
    Follows
    1
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Sir is the car running fine on CNG?
    Readers are Leaders.

  3. #3
    PakWheeler Follow
    BASITNAMDAR's Avatar
    Join Date
    Mar 2009
    Location
    Karachi
    Age
    46
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    yeah on cng it runs lika e charm

  4. #4
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,964
    Follows
    5
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    probably the throtle body has a lot of carbon in it by now, causing rough/cold ideling

    Or if u dont drive on petrol condtiions cud be worse, a dead fuel injector, low fuel presure from the fuel pump (a dirty fuel filter) etc.
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  5. #5
    Senior PakWheeler Follow
    murtazee's Avatar
    Join Date
    May 2009
    Location
    Lahore
    Age
    38
    Posts
    1,402
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by chinyoti View Post
    probably the throtle body has a lot of carbon in it by now, causing rough/cold ideling

    Or if u dont drive on petrol condtiions cud be worse, a dead fuel injector, low fuel presure from the fuel pump (a dirty fuel filter) etc.

    +1
    do run few kms ur car on petrol before filling ur CNG.
    The time you enjoy wasting is not wasted time.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •