Survey by Qualaroo
+ Reply to Thread
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By panicslayer

Thread: Vitz 99 problem

  1. #1
    PakWheeler Follow
    Unszak's Avatar
    Join Date
    Aug 2011
    Location
    Karachi
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Thumbs down Vitz 99 problem

    I have a vitz 99 but the problem is that there is no pick from 0-10 on cng at all while using a/c! On petrol it works fine. I have changed the advancer and wiring (landirenzo) and tuned my car from various places but no good. I got the valves replaced 4 months ago but I got that checked and they have no problem. The plugs air filter etc all checked. Most mechanics told me that this problem can't be solved as it is in every vitz.. If I could get some pro help please?!? And please reply with some surety


  2. #2
    jz
    jz is offline
    Senior PakWheeler Follow
    jz's Avatar
    Join Date
    Dec 2004
    Location
    Lahore
    Age
    2
    Posts
    26,106
    Follows
    5
    Following
    0
    Mentioned
    185 Post(s)
    Tagged
    12 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Unszak View Post
    I have a vitz 99 but the problem is that there is no pick from 0-10 on cng at all while using a/c! On petrol it works fine. I have changed the advancer and wiring (landirenzo) and tuned my car from various places but no good. I got the valves replaced 4 months ago but I got that checked and they have no problem. The plugs air filter etc all checked. Most mechanics told me that this problem can't be solved as it is in every vitz.. If I could get some pro help please?!? And please reply with some surety
    did u get the cng injector checked?that can be clogged?
    www.facebook.com/performancepartslahore

  3. #3
    PakWheeler Follow
    afatifa's Avatar
    Join Date
    Apr 2009
    Location
    Karachi
    Age
    28
    Posts
    829
    Follows
    1
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i wish your problem gets to some solution

  4. #4
    Senior PakWheeler Follow
    panicslayer's Avatar
    Join Date
    Nov 2008
    Location
    Islamabad
    Age
    35
    Posts
    10,044
    Follows
    2
    Following
    0
    Mentioned
    10 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It's common problem in Vitz with CNG. It cannot be solved as per my experience. It's better to turn off AC while starting from dead stop
    Suggestions required

  5. #5
    PakWheeler Follow
    hamzashafi's Avatar
    Join Date
    Jul 2010
    Location
    Karachi
    Posts
    632
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I think it's common.I hv sold my vitz just bcoz of this reason
    prAoud OwRnEr oF cORoLLa 2004

  6. #6
    PakWheeler Follow
    Unszak's Avatar
    Join Date
    Aug 2011
    Location
    Karachi
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Thumbs down

    If the cng injectors are clogged wouldn't it have an effect without a/c as well?? Without a/c car is perfect! Plz sumbody??

  7. #7
    fyq
    fyq is offline
    Senior PakWheeler Follow
    fyq's Avatar
    Join Date
    Jan 2008
    Location
    Islamabad
    Age
    31
    Posts
    2,320
    Follows
    1
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bro ! post picture of COMPLETE enginge bay... thn the solution will be told.
    let the music play

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •