Survey by Qualaroo
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 20 of 59
Like Tree13Likes

Thread: Toyota Vitz 2007 - vibration and whistling sound

  1. #1
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Toyota Vitz 2007 - vibration and whistling sound

    Hi,

    Since last two days when I start the Vitz in the mornings the car sort of vibrates/shudders for few seconds then is back to normal. This never happened before. It's like as if the engine shudders for a few secs then is back to normal. I cleaned the throttle body, spark plugs and replaced the air filter last month. What could be the problem?

    Also when I start to drive the car after its parked overnight or after work in the evenings I can hear a whistling sound which is similar to a bird chirping on the right side area. This does not happen everytime but on and off on several occasions and only for awhile but then disappears as I continue to drive the car. I can't figure out where this sound seems to come from??

    Would appreciate any suggestions help please.

    Thanks


  2. #2
    Senior PakWheeler Follow
    syed-shoaib's Avatar
    Join Date
    Apr 2010
    Location
    Islamabad
    Posts
    1,330
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    Hi,

    Since last two days when I start the Vitz in the mornings the car sort of vibrates/shudders for few seconds then is back to normal.
    Well Sorry I can't help you on it but commonly this problem occurs on carbon buildup on the butterfly. but you have already got your throttle body cleaned. Sir, the carbon buildup can be very fast due to bad fuel.

    Let's hope Allah sends some expert to help you.

    Sir, have you switched the fuel station from where you get you fuel? The new fuel may be causing problem.

    regards,
    http://shoaibtalib.wordpress.com/

  3. #3
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes I fill from several fuel stations such as Shell and Caltex, but mostly try and fill only from Caltex as much as possible. I also had the MAF sensor cleaned when he cleaned the throttle body.

    I think it could be the serpentine belt that is causing the whistling / chirping

  4. #4
    Senior PakWheeler Follow
    syed-shoaib's Avatar
    Join Date
    Apr 2010
    Location
    Islamabad
    Posts
    1,330
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    Yes I fill from several fuel stations such as Shell and Caltex, but mostly try and fill only from Caltex as much as possible. I also had the MAF sensor cleaned when he cleaned the throttle body.

    I think it could be the serpentine belt that is causing the whistling / chirping
    You mean the vibration of engine is due to this belt? How come? and if it's due to this belt why it fades away after few seconds?
    http://shoaibtalib.wordpress.com/

  5. #5
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    NO not vibration of engine but the whistling sound that is coming when I drive the car after startup

  6. #6
    Senior PakWheeler Follow
    syed-shoaib's Avatar
    Join Date
    Apr 2010
    Location
    Islamabad
    Posts
    1,330
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    NO not vibration of engine but the whistling sound that is coming when I drive the car after startup
    hmmmm. Bro, a whistling sound is also coming from my ride. When the engine becomes hot, I mean the COLD light turns off, a whistling sound starts coming. When I put my gear on "P" the sound stops. When I put it in "D" or "N" the sound keeps coming. Does that sound has to do something with the one in your ride?
    http://shoaibtalib.wordpress.com/

  7. #7
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No no it only comes like when i start the car after a long time...say for e.g. in the mornings and in the evenings after work. Like 7-8 hours gap.

    The sound is there for awhile and when accelerating and then after some times it stops. Its very faint.

  8. #8
    Senior PakWheeler Follow
    syed-shoaib's Avatar
    Join Date
    Apr 2010
    Location
    Islamabad
    Posts
    1,330
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    No no it only comes like when i start the car after a long time...say for e.g. in the mornings and in the evenings after work. Like 7-8 hours gap.

    The sound is there for awhile and when accelerating and then after some times it stops. Its very faint.
    So, lets compile things up:

    You have two problems.

    1) Engine vibration.
    2) whistling sound.

    and both problems happen when the engine is started while it is COLD and vanish in few minutes. right?
    http://shoaibtalib.wordpress.com/

  9. #9
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes and engine vibration happens if for e.g. I stop at a red light signal and press the brake then the car vibrates slightly

  10. #10
    Senior PakWheeler Follow
    dms664's Avatar
    Join Date
    Dec 2007
    Location
    Select City
    Age
    33
    Posts
    7,013
    Follows
    1
    Following
    1
    Mentioned
    90 Post(s)
    Tagged
    8 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i think your MAF sensor might needs cleaning.
    My dear ALLAH when I loose hope, help me to remember that Your love is greater than my disappointment and Your plans for my life are better than my Dreams.

  11. #11
    Senior PakWheeler Follow
    murtaza_murti's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    23
    Posts
    10,354
    Follows
    2
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The 1KR-FE comes with a MAP sensor not a MAF sensor.
    - '06 Toyota Belta 1.0L X - '68 VW Beetle 1300 DP - '89 Nissan B12 E16

  12. #12
    Senior PakWheeler Follow
    syed-shoaib's Avatar
    Join Date
    Apr 2010
    Location
    Islamabad
    Posts
    1,330
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    OK.

    Does pushing accelerator a bit, while starting in morning, solves the problem? I mean does the viberation goes away at once when you push the accelerator?
    http://shoaibtalib.wordpress.com/

  13. #13
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    No; like i said i dont feel i right away but later if I stop at a signal then only I feel the vibration and that too when I depress the brake pedal.

  14. #14
    Senior PakWheeler Follow
    syed-shoaib's Avatar
    Join Date
    Apr 2010
    Location
    Islamabad
    Posts
    1,330
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    No; like i said i dont feel i right away but later if I stop at a signal then only I feel the vibration and that too when I depress the brake pedal.
    Sir I would be at your place I would have done two things again.

    1) Throttle body clean.
    2) Recheck fuel intake system.
    3) Recheck my spark plugs (just a recheck. I know the are fine)

    As you have already got throttle body cleaned a month ago. Better recheck if your fuel intake system is properly installed. Sir, remember? You opened you air filter box to replace it? May be it is not fitted back properly? The engine has a good tendency to vibrate from some seconds if the air intake is not proper when it is cold. Secondly, throttle body can again become bad due to accumulation of carbon. Carbon can accumulate very quickly if the fuel is not good.

    That's all I have in my mind right now. Sorry I am not an expert

    regards,
    http://shoaibtalib.wordpress.com/

  15. #15
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks Shoaib,

    Will have to take out some time from work now and go check it out Don't know when that will be????

  16. #16
    Senior PakWheeler Follow
    syed-shoaib's Avatar
    Join Date
    Apr 2010
    Location
    Islamabad
    Posts
    1,330
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    Thanks Shoaib,

    Will have to take out some time from work now and go check it out Don't know when that will be????
    Many best of lucks brother.
    regards,
    http://shoaibtalib.wordpress.com/

  17. #17
    Senior PakWheeler Follow
    murtaza_murti's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    23
    Posts
    10,354
    Follows
    2
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @Tyrone_40, this usually happens when your spark plugs need cleaning. But you said you've done that already.
    - '06 Toyota Belta 1.0L X - '68 VW Beetle 1300 DP - '89 Nissan B12 E16

  18. #18
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by murtaza_murti View Post
    @Tyrone_40, this usually happens when your spark plugs need cleaning. But you said you've done that already.
    Yes now i'm thinking of changing the spark plugs and also replacing the serpentine belt to see if the whistling sound disappears. Time constraints are there though

  19. #19
    PakWheeler Follow
    salash's Avatar
    Join Date
    May 2005
    Location
    Rawalpindi
    Age
    51
    Posts
    300
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Well in my vitz the whistling sound was coming from the rear silencer box spring bolts which had gone dry , so went to the silencer shop and got the three sling bolts oiled and the sound was absolutely gone. It is very common fault in this model , so get the bolts dipped in oil and I'm sure atleast the whistling sound issue will be solved inshallah.

  20. #20
    Senior PakWheeler Follow
    syed-shoaib's Avatar
    Join Date
    Apr 2010
    Location
    Islamabad
    Posts
    1,330
    Follows
    1
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by salash View Post
    Well in my vitz the whistling sound was coming from the rear silencer box spring bolts which had gone dry , so went to the silencer shop and got the three sling bolts oiled and the sound was absolutely gone. It is very common fault in this model , so get the bolts dipped in oil and I'm sure atleast the whistling sound issue will be solved inshallah.
    another excellent piece of information. Much appreciated !!!

    JazakAllah.

    many regards,
    http://shoaibtalib.wordpress.com/

+ Reply to Thread
Page 1 of 3 123 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •