Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 26
Like Tree4Likes

Thread: Vitz fuel bars - Is it normal?

  1. #1
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz fuel bars - Is it normal?

    Hi,

    I noticed something strange happening in my fuel level indicator on my Vitz 2007/08 model. Once I have filled 1,000 rupees of fuel there are about 4 bars displayed on the fuel level indicator. After about 45-50 kms it goes down by two bars instead of 1 bar. Then after about another 60 kms it goes down by 1 bar and the final bar starts blinking. I have noticed this ever since I got my car.

    What I want to ask is why does it go down by 2 bars instead of 1 bar after 45/50 kms as in my case?

    Any ideas?


  2. #2
    Senior PakWheeler Follow
    murtaza_murti's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    23
    Posts
    10,354
    Follows
    2
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    In about 1000rs worth of petrol the Vitz I had use to give me 120-150Kms. If you're getting a total of 120Kms + in 1000rs worth of petrol then don't worry about it.

    A 1000rs of petrol gives you almost 10 liters. Now if you divide 150 by 10, you'll get 15. Which means you're getting 15 kilometers in one liter.

    But remember the reserve has about 2-3 liters of fuel in it.
    - '06 Toyota Belta 1.0L X - '68 VW Beetle 1300 DP - '89 Nissan B12 E16

  3. #3
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by murtaza_murti View Post
    In about 1000rs worth of petrol the Vitz I had use to give me 120-150Kms. If you're getting a total of 120Kms + in 1000rs worth of petrol then don't worry about it.
    I'm getting about 110 max which I think is less. Air filter changed (Thai one), cleaned throttle body and engine oil in Feb and serviced all 4 brakes and replaced spark plugs in March.

  4. #4
    Senior PakWheeler Follow
    murtaza_murti's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    23
    Posts
    10,354
    Follows
    2
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    I'm getting about 110 max which I think is less. Air filter changed (Thai one), cleaned throttle body and engine oil in Feb and serviced all 4 brakes and replaced spark plugs in March.
    Replace the fuel filter.
    - '06 Toyota Belta 1.0L X - '68 VW Beetle 1300 DP - '89 Nissan B12 E16

  5. #5
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ahamid View Post
    Brief stuttering is the trade mark of 1KR-FE engine. Live with it...

    To replace / clean fuel filter, you will have to open the fuel pump (located under rear seat). So be sure to get it done from someone who knows Vitz well. Fuel pump costs around 40k.
    Thanks for the advice . Are u sure about the stuttering sound....it never happened before...just happens for a few secs after starting the engine and then the engine runs normally. Its like as if its struggling to start and getting choked. Could be the fuel filter as mentioned above.

  6. #6
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ahamid View Post
    Oil change...which one did you put and what quantity? Did the workshop guy drained the dirty oil completely? Did you change oil filter?

    In how much time does the engine cool sign goes off when you start the car after a long break?

    Get your wheel alignment and camber checked from a reputed shop.
    Zic A+ and yes the mechanic opened the bolt below and drained it also changed the oil filter.

    No the sign goes off quickly after about say 2-3 mins

  7. #7
    PakWheeler Follow
    ahamid's Avatar
    Join Date
    Jun 2011
    Location
    Rawalpindi
    Posts
    125
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    Zic A+ and yes the mechanic opened the bolt below and drained it also changed the oil filter.

    No the sign goes off quickly after about say 2-3 mins
    What quantity did you put? It is 3.2 L for 1000cc Vitz. This is just a check; has got nothing to do with mileage.

    To gain more mileage, check the tire inflation pressure. It should be 30/32 psi as per manual. Also get tire alignment and camber verified. This is really a fuel eater.

    Stuttering usually happens with 1000cc vitz, primarily due to low octane number of fuel available in Pakistan and also when AC switch / other electronics is already turned ON prior to engine starting. Does your car start in half 'sulf', or does it go 'chuu chuu chuuu chuu huurrrrrr' and then starts?

  8. #8
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ahamid View Post
    What quantity did you put? It is 3.2 L for 1000cc Vitz. This is just a check; has got nothing to do with mileage.

    To gain more mileage, check the tire inflation pressure. It should be 30/32 psi as per manual. Also get tire alignment and camber verified. This is really a fuel eater.

    Stuttering usually happens with 1000cc vitz, primarily due to low octane number of fuel available in Pakistan and also when AC switch / other electronics is already turned ON prior to engine starting. Does your car start in half 'sulf', or does it go 'chuu chuu chuuu chuu huurrrrrr' and then starts?
    Yes I put in about 3 L

    I keep tire pressure at about 30 psi and check every month. Will definitely get the alignment and camber checked.

    I use Caltex petrol and ensure that the AC switch and other electronics are off when I start the car. Yes it starts in half self and after a brief nano second goes liike chuu chuuu chuu and is back to normal. It seems like as if something is choking or its struggling to maintain but then like I said after a few secs is back to normal running.

    Oh and it only happens when car is parked overnight or after a long time standing say about 8-10 hours.

  9. #9
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by murtaza_murti View Post
    Replace the fuel filter.
    Thanks for the advice. Will that improve mileage considerably? That could also be the problem of brief stuttering after switching on the ignition. Battery was checked and seems fine.

  10. #10
    PakWheeler Follow
    ahamid's Avatar
    Join Date
    Jun 2011
    Location
    Rawalpindi
    Posts
    125
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    Thanks for the advice. Will that improve mileage considerably? That could also be the problem of brief stuttering after switching on the ignition. Battery was checked and seems fine.
    Brief stuttering is the trade mark of 1KR-FE engine. Live with it...

    To replace / clean fuel filter, you will have to open the fuel pump (located under rear seat). So be sure to get it done from someone who knows Vitz well. Fuel pump costs around 40k.

  11. #11
    PakWheeler Follow
    ahamid's Avatar
    Join Date
    Jun 2011
    Location
    Rawalpindi
    Posts
    125
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    I'm getting about 110 max which I think is less. Air filter changed (Thai one), cleaned throttle body and engine oil in Feb and serviced all 4 brakes and replaced spark plugs in March.
    Oil change...which one did you put and what quantity? Did the workshop guy drained the dirty oil completely? Did you change oil filter?

    In how much time does the engine cool sign goes off when you start the car after a long break?

    Get your wheel alignment and camber checked from a reputed shop.

  12. #12
    PakWheeler Follow
    ahamid's Avatar
    Join Date
    Jun 2011
    Location
    Rawalpindi
    Posts
    125
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    Yes I put in about 3 L

    I keep tire pressure at about 30 psi and check every month. Will definitely get the alignment and camber checked.

    I use Caltex petrol and ensure that the AC switch and other electronics are off when I start the car. Yes it starts in half self and after a brief nano second goes liike chuu chuuu chuu and is back to normal. It seems like as if something is choking or its struggling to maintain but then like I said after a few secs is back to normal running.

    Oh and it only happens when car is parked overnight or after a long time standing say about 8-10 hours.
    The same happened with me. Infact, my car started to die down suddenly in low rpm ('D' with brake pedal pressed). It turned out that the fuel filter was choked. Put a full tank load of fresh petrol now and observe any improvement.

  13. #13
    Senior PakWheeler Follow
    murtaza_murti's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    23
    Posts
    10,354
    Follows
    2
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    Thanks for the advice. Will that improve mileage considerably? That could also be the problem of brief stuttering after switching on the ignition. Battery was checked and seems fine.
    It will, because you have already replaced the air filter, spark plugs and cleaned the throttle body.

    How long do you leave the car on the 'ON' position when you start it up overnight?

    What I do is keep the car running until the green cool engine icon goes away, so that the engine can warm up properly.
    - '06 Toyota Belta 1.0L X - '68 VW Beetle 1300 DP - '89 Nissan B12 E16

  14. #14
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,734
    Follows
    16
    Following
    0
    Mentioned
    488 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Beside Anything....Check For Your O2 Sensor And MAF Sensor...If You Are Getting Low Mileage...

    Also Make Sure Fuel You Are Filling With Is Good...Fill From Best In Town And Check Results......Driving Style Also Effect Mileage Alot
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  15. #15
    PakWheeler Follow
    ahamid's Avatar
    Join Date
    Jun 2011
    Location
    Rawalpindi
    Posts
    125
    Follows
    1
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by murtaza_murti View Post
    It will, because you have already replaced the air filter, spark plugs and cleaned the throttle body.

    How long do you leave the car on the 'ON' position when you start it up overnight?

    What I do is keep the car running until the green cool engine icon goes away, so that the engine can warm up properly.
    Vitz manual says you can drive the car until the cool sign goes away. But be careful not to over exert or over burden the engine in that time.

    Remember, the fuel average you are getting if you keep the car parked until cool sign goes away is ZERO.

  16. #16
    Senior PakWheeler Follow
    HAshims's Avatar
    Join Date
    Aug 2004
    Location
    Lahore
    Age
    25
    Posts
    4,885
    Follows
    2
    Following
    0
    Mentioned
    39 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    upper bars will vanish more quickly compared to lower bars
    Honda Civic 99 EK Hatch / Honda Integra 92 DA Coupe
    RIP Adil( @AridSoul)

  17. #17
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by murtaza_murti View Post
    It will, because you have already replaced the air filter, spark plugs and cleaned the throttle body.

    How long do you leave the car on the 'ON' position when you start it up overnight?

    What I do is keep the car running until the green cool engine icon goes away, so that the engine can warm up properly.
    Hardly half a min max maybe even less and then I start driving coz I heard you dont need to warm up these cars as compared to the older cars.

    Also I switch on the AC while the green cool light is on? Is that ok?

  18. #18
    Senior PakWheeler Follow
    aantherax's Avatar
    Join Date
    May 2006
    Location
    Karachi
    Age
    33
    Posts
    3,032
    Follows
    1
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have a 2004 vitz (1SZ - FE) first i was pissed at its average it was giving me 11km / liter, but later on i found out that it was due to PSO's bad quality petrol ... i switched to caltex and did nothing same driving style same route same tire pressure and the average jumped upto 15km / liter
    ~ Be a responsible citizen and always drive safely ~

  19. #19
    Senior PakWheeler Follow
    aantherax's Avatar
    Join Date
    May 2006
    Location
    Karachi
    Age
    33
    Posts
    3,032
    Follows
    1
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tyrone_40 View Post
    Hi,

    I noticed something strange happening in my fuel level indicator on my Vitz 2007/08 model. Once I have filled 1,000 rupees of fuel there are about 4 bars displayed on the fuel level indicator. After about 45-50 kms it goes down by two bars instead of 1 bar. Then after about another 60 kms it goes down by 1 bar and the final bar starts blinking. I have noticed this ever since I got my car.

    What I want to ask is why does it go down by 2 bars instead of 1 bar after 45/50 kms as in my case?

    Any ideas?
    its normal usually the upper bars remains lit for a longer period ... get your fuel tank full then you'll know what I am trying to say ...
    ~ Be a responsible citizen and always drive safely ~

  20. #20
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by SER_GTR View Post
    Beside Anything....Check For Your O2 Sensor And MAF Sensor...If You Are Getting Low Mileage...

    Also Make Sure Fuel You Are Filling With Is Good...Fill From Best In Town And Check Results......Driving Style Also Effect Mileage Alot
    MAF sensor was cleaned when cleaning throttle body. Not sure about O2 sensor.

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •