Survey by Qualaroo
+ Reply to Thread
Results 1 to 7 of 7

Thread: Toyota Vitz Petrol Problem for few minutes after starting

  1. #1
    PakWheeler Follow
    awais-idrees's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Posts
    108
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Toyota Vitz Petrol Problem for few minutes after starting

    Hey guys, I have toyota vitz model 1999 1000cc.
    It on CNG and i do drive on petrol sometimes and you must know that these cars always starts on petrol and than convert to CNG automatically after sometime, so it was going ok since last 2 months, in last 2 months I've experienced strange problem i.e. whenever i start my car it gives strange sound like it was going to off automatically and when i try to give manual race it doesn't pick it and vibrates and gives a sound like it was going to shutt down and sometimes it does shutt down when i try to give race to give the engine the power to get smooth. It only happens a few minutes and afterwords it runs smoothly.
    I've get it checked by mechanic and he said its fuel filter needs to be replaced and i got it replaced but still the problem was there, than again i get to the mechanic and he said i need to change the fuel motor as it gets weak and than i replaced the fuel motor but still the problem is there.
    Can anyone please help me out???
    This only happens on petrol and for very few minutes after i start the car and very rarely happens while driving.
    It nevers happens on CNG.
    Please guys help me out or tell me about a mechanic who can fix it well.
    You can also contact me on my number 0321-4055485
    please i need sincere advice
    Thanks in advance

  2. #2
    PakWheeler Follow
    awais-idrees's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Posts
    108
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by awais-idrees View Post
    Hey guys, I have toyota vitz model 1999 1000cc.
    It on CNG and i do drive on petrol sometimes and you must know that these cars always starts on petrol and than convert to CNG automatically after sometime, so it was going ok since last 2 months, in last 2 months I've experienced strange problem i.e. whenever i start my car it gives strange sound like it was going to off automatically and when i try to give manual race it doesn't pick it and vibrates and gives a sound like it was going to shutt down and sometimes it does shutt down when i try to give race to give the engine the power to get smooth. It only happens a few minutes and afterwords it runs smoothly.
    I've get it checked by mechanic and he said its fuel filter needs to be replaced and i got it replaced but still the problem was there, than again i get to the mechanic and he said i need to change the fuel motor as it gets weak and than i replaced the fuel motor but still the problem is there.
    Can anyone please help me out???
    This only happens on petrol and for very few minutes after i start the car and very rarely happens while driving.
    It nevers happens on CNG.
    Please guys help me out or tell me about a mechanic who can fix it well.
    You can also contact me on my number 0321-4055485
    please i need sincere advice
    Thanks in advance
    Help me with this guys please...

  3. #3
    PakWheeler Follow
    awais-idrees's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Posts
    108
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by awais-idrees View Post
    Hey guys, I have toyota vitz model 1999 1000cc.
    It on CNG and i do drive on petrol sometimes and you must know that these cars always starts on petrol and than convert to CNG automatically after sometime, so it was going ok since last 2 months, in last 2 months I've experienced strange problem i.e. whenever i start my car it gives strange sound like it was going to off automatically and when i try to give manual race it doesn't pick it and vibrates and gives a sound like it was going to shutt down and sometimes it does shutt down when i try to give race to give the engine the power to get smooth. It only happens a few minutes and afterwords it runs smoothly.
    I've get it checked by mechanic and he said its fuel filter needs to be replaced and i got it replaced but still the problem was there, than again i get to the mechanic and he said i need to change the fuel motor as it gets weak and than i replaced the fuel motor but still the problem is there.
    Can anyone please help me out???
    This only happens on petrol and for very few minutes after i start the car and very rarely happens while driving.
    It nevers happens on CNG.
    Please guys help me out or tell me about a mechanic who can fix it well.
    You can also contact me on my number 0321-4055485
    please i need sincere advice
    Thanks in advance

    Can't anyone reply to this thread???

  4. #4
    PakWheeler Follow
    noormuhammad001's Avatar
    Join Date
    Dec 2011
    Location
    Karachi
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Facing exactly same problem!!! Doesn't any one have a solution for this?

  5. #5
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get the fuel rail & injector cleaned.
    Never loose hope in life,every step gives u something.

  6. #6
    PakWheeler Follow
    ngen's Avatar
    Join Date
    Oct 2008
    Location
    Islamabad
    Age
    38
    Posts
    166
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get your CNG advancer / Emulator checked ... if you have changed both the fuel filter and the pump then it must be the CNG system which is creating the fault.

  7. #7
    PakWheeler Follow
    5555's Avatar
    Join Date
    May 2009
    Location
    Lahore
    Age
    25
    Posts
    688
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    first of all unplug your battery for about 5 min then replug the battery terminal then check if car is ok

+ Reply to Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •