Survey by Qualaroo
+ Reply to Thread
Page 4 of 4 FirstFirst ... 234
Results 61 to 71 of 71
Like Tree11Likes

Thread: Toyota Vitz 2006 problem

  1. #1
    PakWheeler Follow
    obaid.u.khalid's Avatar
    Join Date
    Oct 2012
    Location
    Islamabad
    Posts
    21
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Toyota Vitz 2006 problem

    I have toyota vitz model 2006, there are a few things and issues that I need advice on.

    I bought this car on 26K mileage and now it is around 46K mileage. From the start the engine always gave knocking sound, which was quite high in the beginning, but on recommendation of Toyota motors I used Caltex petrol which reduced the knocking alot, it still knocks but only sometimes. So first I need to know how I can get rid of this knocking sound.

    My second problem is that when I went to murree and on steep roads, the knocking was loud and my car gave out black smoke from the exhaust pipe. I also saw that the engine oil had reduced after about 3K Km. I use ZIC A+ as engine oil. I get the oil changed at around 4K to 5K. I have shown the car to a few mechanics and they say that the piston rings might be weak and I need to get them replaced.

    Also the check engine light comes on sometimes, but it goes away again, do you think this could be an electrical fault?
    Can anyone give me some expert suggestions on this and also give answer to my questions below.

    1) Where do you recommend that I can get 100% genuine parts for vitz in Islamabad/Rawalpindi besides the toyota dealership.
    2) Does anyone know a good vitz engine mechanic in islamabad/pindi
    3) Where can I get computer/scanner checking of my vitz besides the toyota dealership?

    Expert suggestions are welcome.


  2. #61
    Senior PakWheeler Follow
    Naweed's Avatar
    Join Date
    Jul 2008
    Location
    Karachi
    Age
    50
    Posts
    3,469
    Follows
    12
    Following
    0
    Mentioned
    122 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Zubair530 View Post
    Assalam o Alaikum, Can you please give more details about the electrician, where can I find him.

    Today I was ripped off by Toyota Islamabad Motors, they snabbed 1250 Rs just cleaning the plugs and the carburator :s

    Now the car seems to have increased idle RPMs and gives some jerks type when the car starts moving (i.e. when gear is changed)...

    And not to mention the knocking has always been here, i have tried hi octane also...

    For the CAT Removal, toyota asked for 4K, i got it removed for 1K....
    I didn't read any previous posts of your and am assuming you have a vitz .. so firstly your car doesn't have carburettor .. if u intended to mention throttle body then the 1250/- charges with 3s tag seems appropriate

    your increased idle RPM is due to CAT removal unless the exhaust pressure is chocked as by a CAT originally, this issue will remain as such
    the knocking thing is most likely due to clogged fuel injector(s) .. take second opinion an then get it done
    "You have not lived today until you have done something for someone who can never repay you."

  3. #62
    Senior PakWheeler Follow
    Zubair530's Avatar
    Join Date
    Jul 2006
    Location
    Islamabad
    Age
    35
    Posts
    2,088
    Follows
    1
    Following
    0
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have belta and since both belta and vitz have same engines, i didn't mentioned that.

    It is not the throttle body (i think), it is just the place where the black plastic box of the air filter is inserted/attached to the throttle body/injector...
    Signature Location...

  4. #63
    PakWheeler Follow
    slixasplit's Avatar
    Join Date
    May 2011
    Location
    Islamabad
    Age
    27
    Posts
    27
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @capsat bro.ive changed the fuel pump's motor..the (gouuuunnnnn) sound was the motor's noise. now this problem has been solved..
    But still the one problem is there.
    The car takes a long time to start especially when i try to start it after a long idle (6hrs or so).
    there is no sch problem of air lock.Wo tou puranay diesel engines ka issue hota tha.

  5. #64
    PakWheeler Follow
    atta1111's Avatar
    Join Date
    Sep 2008
    Location
    Rawalpindi
    Age
    26
    Posts
    675
    Follows
    0
    Following
    0
    Mentioned
    52 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by obaid.u.khalid View Post
    I have toyota vitz model 2006, there are a few things and issues that I need advice on.

    I bought this car on 26K mileage and now it is around 46K mileage. From the start the engine always gave knocking sound, which was quite high in the beginning, but on recommendation of Toyota motors I used Caltex petrol which reduced the knocking alot, it still knocks but only sometimes. So first I need to know how I can get rid of this knocking sound.

    My second problem is that when I went to murree and on steep roads, the knocking was loud and my car gave out black smoke from the exhaust pipe. I also saw that the engine oil had reduced after about 3K Km. I use ZIC A+ as engine oil. I get the oil changed at around 4K to 5K. I have shown the car to a few mechanics and they say that the piston rings might be weak and I need to get them replaced.

    Also the check engine light comes on sometimes, but it goes away again, do you think this could be an electrical fault?
    Can anyone give me some expert suggestions on this and also give answer to my questions below.

    1) Where do you recommend that I can get 100% genuine parts for vitz in Islamabad/Rawalpindi besides the toyota dealership.
    2) Does anyone know a good vitz engine mechanic in islamabad/pindi
    3) Where can I get computer/scanner checking of my vitz besides the toyota dealership?

    Expert suggestions are welcome.
    has your problem be solved or not...

  6. #65
    PakWheeler Follow
    alcholic_eyes's Avatar
    Join Date
    Nov 2012
    Location
    Lahore
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Salam Guys

    i have 2010 vitz , the problem is when the car drives uptp 30 to 40 km and switch on the light or ac mean put load , it starts vibrating eventho i have cleaned its throttle ,clean the spark plug , change the engine oil,air filter and oil filter. still now the problem is there even scaned had also been done

    now can anybody here can help me in this matter ?

  7. #66
    PakWheeler Follow
    atta1111's Avatar
    Join Date
    Sep 2008
    Location
    Rawalpindi
    Age
    26
    Posts
    675
    Follows
    0
    Following
    0
    Mentioned
    52 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by alcholic_eyes View Post
    Salam Guys

    i have 2010 vitz , the problem is when the car drives uptp 30 to 40 km and switch on the light or ac mean put load , it starts vibrating eventho i have cleaned its throttle ,clean the spark plug , change the engine oil,air filter and oil filter. still now the problem is there even scaned had also been done

    now can anybody here can help me in this matter ?
    The throttle body need's relearning calibration. Calibrate the throttle motor and your problem will be solved.. Get it Calibrated by Techstream or toyota Diagnosis Tool.

  8. #67
    PakWheeler Follow
    alcholic_eyes's Avatar
    Join Date
    Nov 2012
    Location
    Lahore
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have done calibrated but no effect on the car still when all things are on again car start vibrating

  9. #68
    PakWheeler Follow
    atta1111's Avatar
    Join Date
    Sep 2008
    Location
    Rawalpindi
    Age
    26
    Posts
    675
    Follows
    0
    Following
    0
    Mentioned
    52 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by alcholic_eyes View Post
    i have done calibrated but no effect on the car still when all things are on again car start vibrating
    ok then you had to see the live reading's in the techstream when you switch on the light's see if the elec load switch get's on or it stays off see it and tell me than.

  10. #69
    PakWheeler Follow
    alcholic_eyes's Avatar
    Join Date
    Nov 2012
    Location
    Lahore
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i actually didnt focused on the rpm but it increases or decreases the rpm when the light is turned on or off and even ame did with the ac on and off .

  11. #70
    PakWheeler Follow
    alcholic_eyes's Avatar
    Join Date
    Nov 2012
    Location
    Lahore
    Posts
    45
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have checked from various good mechanics in lahore but all said this is normal

  12. #71
    PakWheeler Follow
    farooqrifai's Avatar
    Join Date
    Feb 2005
    Location
    Islamabad
    Age
    36
    Posts
    15
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Problem can be caused by various issue:

    First your car needs proper tuning and require automatic gear filter cleaning/replacement + Transmission Oil change.

    If issue not resolved by previous actions than u need to check the fuel pump pressure and also need to check the fuel injectors.

    and if still it doesn't solve the issue than u need to get your engine head overall i.e., Valves + cam and tappit inspection/cleaning is required. I would recommend you to go to Best Autos in Rawalpindi. It is located in National Market. on Alhannan Road. They have all the facilities

+ Reply to Thread
Page 4 of 4 FirstFirst ... 234

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •