Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 25
Like Tree2Likes

Thread: Need urgent help regarding Vitz

  1. #1
    PakWheeler Follow
    logitech's Avatar
    Join Date
    Jul 2007
    Location
    Islamabad
    Age
    37
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Need urgent help regarding Vitz

    A-O-A,


    An urgent query to all Vitz 1.3L AT 2SZ-FE (2WD) Owners. I recently bought a 2007 Toyota Vitz 1.3L AT 2SZ-FE (2WD) and took it to my mechanic for changing lubricants and tunning and brakes. I got my engine flushed with Liqui Moly Engine Flush used Havoline Formula Oil with Original Toyota Oil filter and air filter. Got my CC checked and the first one was choked so changed with a special dholki prepared for vitz to maintain the pick, performance & sound. Car drive is awesome but i got only one problem. Once car is all warmed up and with a little bit of push on accelerator i hear a Grinding Whirring noise from the engine. The RPM would be around 1100 at that time but once i push it more it gets fine like on around 2000 RPM or maybe the engine becomes a little noisy on 2000RPM making that sound invinsible. i got it checked from different places and spent money on Timing Chain along with Timing Tensoner replacement and got the Water Pump changed as well but the sound is till there. Today my mechanic tried changing the generator and compressor but of no use the sound is still there.


    Please let me know if anyone of you having same car is facing same issue and how to resolve it.

    -

  2. #2
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,597
    Follows
    31
    Following
    6
    Mentioned
    1018 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    seems like - air con compressor bearing need replacement.

    - some one in Islamabad tried to RIP off my other car engine rebuilt last year about 22000km old only and while i was on phone got the sound overheard with aircon & without aircon .. hehehhehehe out of my terrible experience I suggested aircon compressor bearing change net Rs. 2500.00 and the growling is gone.

    the sound you are worried about is it with aircon or without air con ? -
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  3. #3
    PakWheeler Follow
    logitech's Avatar
    Join Date
    Jul 2007
    Location
    Islamabad
    Age
    37
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yesterday my mechanic changed both generator and compressor as well but sound was still there though both things bought were taken off a kabli vitz 2Sz engine since after replacing them the sound didn't went away so I returned them. Funny thing is that once you take of the engine belt the sound goes away.
    -

  4. #4
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,597
    Follows
    31
    Following
    6
    Mentioned
    1018 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    how about checking the idler (bearing) pully
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  5. #5
    PakWheeler Follow
    logitech's Avatar
    Join Date
    Jul 2007
    Location
    Islamabad
    Age
    37
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Ok got the ideler pully changed as well but sound is still there :-(
    Quote Originally Posted by capsat View Post
    how about checking the idler (bearing) pully
    -

  6. #6
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Get the water body & power steering pump checked.
    Never loose hope in life,every step gives u something.

  7. #7
    PakWheeler Follow
    logitech's Avatar
    Join Date
    Jul 2007
    Location
    Islamabad
    Age
    37
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Water body already changed and this car is with electric power steering so I believe no pump.
    Quote Originally Posted by argtr65 View Post
    Get the water body & power steering pump checked.
    -

  8. #8
    PakWheeler Follow
    rehanRRR's Avatar
    Join Date
    Dec 2011
    Location
    Sialkot
    Posts
    30
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    its common in vitz bro...get ur all pulleys checked on right side of engine...maybe that would help...

  9. #9
    PakWheeler Follow
    logitech's Avatar
    Join Date
    Jul 2007
    Location
    Islamabad
    Age
    37
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Got everything replaced but sound is still there now what
    -

  10. #10
    PakWheeler Follow
    rehanRRR's Avatar
    Join Date
    Dec 2011
    Location
    Sialkot
    Posts
    30
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    does sound come while ur car is stationary or its only when ur driving..??

  11. #11
    PakWheeler Follow
    rehanRRR's Avatar
    Join Date
    Dec 2011
    Location
    Sialkot
    Posts
    30
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i guess its compressor clutch...now u replaced compressor with kabli vitz...nd sound still there....swap gli compressor and new se saloon cluth plate...

  12. #12
    Senior PakWheeler Follow
    Proverbial_Slang's Avatar
    Join Date
    May 2005
    Location
    Lahore
    Posts
    3,906
    Follows
    0
    Following
    0
    Mentioned
    29 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Everyone is suggesting to check various bearings based on the OP's description of a "growling whirring" sound. If it was a bearing, it would have made that sound even at idle.

    My guess is the new muffler which is making just a tad bit more sound upon hard acceleration.
    Death is not the greatest loss in life. The greatest loss is what dies inside us while we live.

  13. #13
    Senior PakWheeler Follow
    asad1's Avatar
    Join Date
    Aug 2005
    Location
    Karachi
    Age
    30
    Posts
    2,707
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    1KR engine is lil noisy engine

  14. #14
    Senior PakWheeler Follow
    Naweed's Avatar
    Join Date
    Jul 2008
    Location
    Karachi
    Age
    50
    Posts
    3,469
    Follows
    12
    Following
    0
    Mentioned
    122 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    some workshops have a vehicular stethoscope to pin point source of an irregular sound .. even a stick can be used to perform this function (if anyone knows how) .. go to any such workshop and you'll get the answer

    Need urgent help regarding Vitz -1083035
    "You have not lived today until you have done something for someone who can never repay you."

  15. #15
    PakWheeler Follow
    pace4u's Avatar
    Join Date
    Mar 2012
    Location
    Faisalabad
    Posts
    3
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    A.O.A i have same problem in my 2sz-fe engine ..
    so please let me know how you find the problem as soon as possible
    best regards

  16. #16
    PakWheeler Follow
    rajaatta's Avatar
    Join Date
    Apr 2014
    Posts
    682
    Follows
    4
    Following
    12
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    contact RT they will help you in pointing out the problem without any charge's..

  17. #17
    PakWheeler Follow
    cheema123's Avatar
    Join Date
    Jun 2013
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    AoA I have vitz 2011 model imported in 2014 can any one have expired about the petrol average??? And when I change the plugs


    Sent from my iPhone using PW Forums

  18. #18
    PakWheeler Follow
    qaziaqeel's Avatar
    Join Date
    May 2012
    Location
    Islamabad
    Posts
    18
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Guys,

    Any further update on this. Hope u have resolved this matter. Kindly guide me same i am facing thanks

  19. #19
    PakWheeler Follow
    enZo1's Avatar
    Join Date
    Jun 2012
    Location
    Islamabad
    Posts
    123
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Got a vitz 2009 2sz-fe. Facing the same issue. No mechanic uptill now isnt sure about what the issue or sound is. Any updates on this matter?


    Sent from my iPhone using PW Forums
    Nobody remembers the guy who finished second but the guy who finished second.

  20. #20
    Senior PakWheeler Follow
    tintin1's Avatar
    Join Date
    Jan 2014
    Location
    Lahore
    Posts
    1,842
    Follows
    8
    Following
    2
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    7
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    5

    Default

    Quote Originally Posted by enZo1 View Post
    Got a vitz 2009 2sz-fe. Facing the same issue. No mechanic uptill now isnt sure about what the issue or sound is. Any updates on this matter?


    Sent from my iPhone using PW Forums
    What Engine oil you are using?
    Gear oil changed or not? Is it CVT or AT ?
    Be Addicted To Help Others.

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •