Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 25 of 25
Like Tree2Likes

Thread: Need urgent help regarding Vitz

  1. #1
    PakWheeler Follow
    logitech's Avatar
    Join Date
    Jul 2007
    Location
    Islamabad
    Age
    37
    Posts
    82
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Need urgent help regarding Vitz

    A-O-A,


    An urgent query to all Vitz 1.3L AT 2SZ-FE (2WD) Owners. I recently bought a 2007 Toyota Vitz 1.3L AT 2SZ-FE (2WD) and took it to my mechanic for changing lubricants and tunning and brakes. I got my engine flushed with Liqui Moly Engine Flush used Havoline Formula Oil with Original Toyota Oil filter and air filter. Got my CC checked and the first one was choked so changed with a special dholki prepared for vitz to maintain the pick, performance & sound. Car drive is awesome but i got only one problem. Once car is all warmed up and with a little bit of push on accelerator i hear a Grinding Whirring noise from the engine. The RPM would be around 1100 at that time but once i push it more it gets fine like on around 2000 RPM or maybe the engine becomes a little noisy on 2000RPM making that sound invinsible. i got it checked from different places and spent money on Timing Chain along with Timing Tensoner replacement and got the Water Pump changed as well but the sound is till there. Today my mechanic tried changing the generator and compressor but of no use the sound is still there.


    Please let me know if anyone of you having same car is facing same issue and how to resolve it.

    -

  2. #21
    PakWheeler Follow
    enZo1's Avatar
    Join Date
    Jun 2012
    Location
    Islamabad
    Posts
    123
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tintin1 View Post
    What Engine oil you are using?
    Gear oil changed or not? Is it CVT or AT ?
    Im using petron 20w-50
    And recently changed transmission oil toyota cvtf tc.


    Sent from my iPhone using PW Forums
    Nobody remembers the guy who finished second but the guy who finished second.

  3. #22
    Senior PakWheeler Follow
    tintin1's Avatar
    Join Date
    Jan 2014
    Location
    Lahore
    Posts
    1,835
    Follows
    7
    Following
    2
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    7
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    5

    Default

    Quote Originally Posted by enZo1 View Post
    Im using petron 20w-50
    And recently changed transmission oil toyota cvtf tc.


    Sent from my iPhone using PW Forums
    If its CVT model, then the choice of your gear oil is perfect.
    But 20w-50 engine oil is too heavy. Feed it 5w-30 SN grade to get the best results and fuel economy also.
    Be Addicted To Help Others.

  4. #23
    PakWheeler Follow
    enZo1's Avatar
    Join Date
    Jun 2012
    Location
    Islamabad
    Posts
    123
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by tintin1 View Post
    If its CVT model, then the choice of your gear oil is perfect.
    But 20w-50 engine oil is too heavy. Feed it 5w-30 SN grade to get the best results and fuel economy also.
    But the grinding sound?
    Whats the solution for that?


    Sent from my iPhone using PW Forums
    Nobody remembers the guy who finished second but the guy who finished second.

  5. #24
    Senior PakWheeler Follow
    tintin1's Avatar
    Join Date
    Jan 2014
    Location
    Lahore
    Posts
    1,835
    Follows
    7
    Following
    2
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    7
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    5

    Default

    Quote Originally Posted by enZo1 View Post
    But the grinding sound?
    Whats the solution for that?


    Sent from my iPhone using PW Forums
    The reason for asking this question was that you are feeding 20w-50 engine oil which is normally old graded oil. Perhaps your engine doesn’t need it. It needs new grade oil like SM or SN. And when you are feeding it SH, SG, then engine may not feel good for that. Anyway, that was just a possibility.

    Some car engines genuinely produce sounds which is little more than normal. Like 1KR-FE, when you drive it over 100 KM/h, the engine sounds become very high. But it comes to normal when reduce the speed. So it maybe the case with 2SZ-FE.

    Start engine, open bonnet and push the accelerator. Does it gives the same grinding sound or not ? If no, then chances are that its not engine’s fault.

    Sometimes wheel bearings gives the similar sounds when driving. So diagnosing the problem will be 50% solution itself.
    Be Addicted To Help Others.

  6. #25
    PakWheeler Follow
    AwaisGhouri's Avatar
    Join Date
    May 2013
    Location
    Lahore
    Age
    38
    Posts
    92
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    hi seniors

    i am facing exaclty same problem in vitz 2007 1300cc
    changed exactly same things as logitech (thread strarter)

    gear oil
    plugs
    compressor
    water body
    generator

    but that grinding sounds still there @logitech u have found any solution?
    Grey hairs sign of Age not Wisdom

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •