Survey by Qualaroo
+ Reply to Thread
Page 593 of 605 FirstFirst ... 93493543583591592593594595603 ... LastLast
Results 11,841 to 11,860 of 12089
Like Tree1580Likes

Thread: Toyota Vitz Owners/Fan Club

  1. #1
    PakWheeler Follow
    obz3ed's Avatar
    Join Date
    Jun 2005
    Location
    Dubai
    Age
    40
    Posts
    72
    Follows
    4
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Toyota Vitz Owners/Fan Club

    The purpose of this post is to gauge the interest in forming a Toyota Vitz Owners Club in different cities of Pakistan. As we all know that Vitz has become quite popular in the last year or so. More and more people are buying it or are interested to know more about it. The purpose of the club would be to share technical / operational information regarding the car. As well as help fellow members with different issues regarding the everyday running of the car. There would be regular meets and get together as well as cruises. The criteria to join the club would be to own a Vitz and a desire to help and share information with fellow members. I myself am based in Karachi, so I can take the lead in taking off this project here. Other can do the similar thing in their respective cities. If there is enough interest, a formal charter / by-laws would be issued with club rules and regulation as well as its mission statement. The club would operate under the same rules & conditions as other international car clubs. To take this project off the ground, I believe 10 people in each city would be the minimum requirement. If anyone from Karachi is interested in being a part of this club, please email me at danyal1@hotmail.com. Pakwheelers from other cities can share their email addresses under this post if they are willing to take the lead for their respective cities. I hope to this see become a success someday and a model for other to follow. LETS MAKE IT HAPPEN GUYS!!!
    Redundancy: A Politician with an airbag in his car

  2. #11841
    PakWheeler Follow
    mdaniyal's Avatar
    Join Date
    May 2016
    Posts
    24
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by Nabeel_Ali View Post
    Use hi octane 3-4 times and drive till reserve light turns on.

    Sent from my SM-N920C using Tapatalk
    Thanks Nabeel_Ali for your expert opinion, i noticed during the scanner was connected that the idle RPM was around 700-750 and it has to be same like that as per mechanic.
    Does it be like that.?

  3. #11842
    Senior PakWheeler Follow
    Nabeel_Ali's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    24
    Posts
    3,509
    Follows
    2
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by mdaniyal View Post
    Thanks Nabeel_Ali for your expert opinion, i noticed during the scanner was connected that the idle RPM was around 700-750 and it has to be same like that as per mechanic.
    Does it be like that.?
    Yes it will stay there initially and after a while it will touch 1k or go to 1.1k max. This is normal nothing to worry about.
    After owning 2nd and 3rd Gen vitz I can say that most of these vibrations disappear after continuous usage of hi octane.

    Sent from my SM-N920C using Tapatalk

  4. #11843
    PakWheeler Follow
    xlahorex's Avatar
    Join Date
    Jun 2015
    Posts
    14
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    have Vitz 2010 registered 2014. An issue is rising now a days. AC on kerkay car ko run ker Kay stop kernay Kay bad ager accelerate dubaion to gair ka engine band ho jata hay .gari acceleration dubanay per Bhari feel hoti hay or engine band hojata hay .It seams car does not picking the AC load.but on the other hand it runs fine even with on AC.only problem when it stops at red light with AC on.any idea or any one facing this problem .

  5. #11844
    Senior PakWheeler Follow
    Nabeel_Ali's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    24
    Posts
    3,509
    Follows
    2
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by xlahorex View Post
    have Vitz 2010 registered 2014. An issue is rising now a days. AC on kerkay car ko run ker Kay stop kernay Kay bad ager accelerate dubaion to gair ka engine band ho jata hay .gari acceleration dubanay per Bhari feel hoti hay or engine band hojata hay .It seams car does not picking the AC load.but on the other hand it runs fine even with on AC.only problem when it stops at red light with AC on.any idea or any one facing this problem .
    If in Lahore then go too cool sun Ac on temple road. It's definitely an issue with compressor.

    Sent from my SM-N920C using Tapatalk

  6. #11845
    PakWheeler Follow
    changwani54's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    370
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Got some maintenance work done on my Vitz 2012 last week.
    Starting with CVT oil change.
    For gear oil aka CVT oil change plz try to read a forum on CVT oil change for Toyota Belta Vitz Passo etc and try to find @Xulfiqar bhai's posts in that forum.
    Either you can go for opening the chamber approach or draining it via drain hole approach.
    I went for changing oil via drain hole approach. Allen key which our common mechanics call "L key" is used to open it. After opening that nut or screw, same Allen key is used to remove the tube that is inside the chamber. Here is the tricky part, most of the mechanics including ones at 3S do know how to take that tube out but they prefer not to, as changing the oil via that bolt doesn't pay well. Usually they try convincing you that opening the chamber is must. Tell the retards that engineers who made the car are way better than them and they didn't put the drain hole and inside tube just to check oil level.
    To be sure exact amount of fluid that comes out, ask the oil guy to collect it and measure the quantity of drained oil. Put back same amount of oil.
    On the other hand if that's not feasible then after draining the oil put back the plastic tube into the nut hole. Do not put the screw or nut back in its place, just the tube. Put the oil via nut hole in upper part of chamber (don't remember which one is it but oil guys usually know it). When oil starts dripping from the hole, wait for it to stop. Start the car and put it in D. Again pour oil till it starts dripping again, it will roughly take 200 to 300 ml of additional oil. Alternatively you can put the screw back after the oil had initially started dripping and add roughly 200 to 250 ml of extra oil. That's it.
    No need of anything else. Car will take back total of 2 to 2.5 L of CVT oil, nearly exactly the amount that was drained.
    P.S. Plz don't be confused when u find someone saying it takes total of 6 or 7L of CVT oil, that's only done when you build the transmission from zero. You can't drain the whole oil, just 2 to 2.5 L of those 6 or 7 L are drained and that's what u put back in.
    Also opening the chamber technique would require roughly 3.5 to 3.8 L of oil.

  7. #11846
    PakWheeler Follow
    changwani54's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    370
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Coming to the throttle and plugs part.
    1. I got throttle cleaned from 3S. Rs.1500 charges and 400 for the spray that they used. Do not ask them that you want tuning of the car. After cleaning the throttle body they would bring a laptop and check it for u. If u specify that u want tuning too, they would ask extra 1000 or 1500 for just attaching that laptop :-P
    2. Get the original Denso iridium plugs SK20HR11. 3 plugs required. Do not buy from 3S, they are rip offs. Asked Rs 2k for a single plug, while I got cent percent same for 900 from Elahi Autos Montgomery Road.

  8. #11847
    PakWheeler Follow
    changwani54's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    370
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Finally the brakes.
    1. Front Discs.
    I went through the whole forum. One of the members suggested that Toyota IQ and Toyota Vitz KSP-130 (2011 onwards) have same OEM front brake discs. Asin Advics P/N 04465-74020 was mentioned. Got them from Montgomery Road, but when original front discs were opened by mechanic it was totally different from the P/N 04465-74020. I took the original ones, got into Rikshaw and went to Montgomery Road again. Returned those brake discs and this time I started looking for brake discs which were 100% percent same as the original ones that I had taken with me now. Finally I got them for Rs.4800 from Elahi Autos Montgomery Road. OEM P/N 04465-52180. Plz remember that my car had genuine brake discs from Japan and I matched them with above mentioned part number properly and bought only after they were 100 percent matched.
    2. For rear brake pads, it was a bit difficult. I took original ones with me and went to Fine Autos, Kamal Autos, Amir Autos and one or two others. I could find only 98 to 99% matching brake shoes but not 100%. Finally I got those 98-99% matching brake shoes from Elahi Autos. Don't remember the part number, box was thrown away by the mechanic before I could note the part number.
    However I have put original front brake discs, and rear brake pads in my cupboard for matching them when I need to replace them again.
    P.S. I got this Vitz directly from the importer last year with verifiable auction sheet having 30k on the odo grade 4 and it had all the stock equipment, so yes its brake discs and brake pads were all original before replacement. Now the car is 57k driven and brakes were not giving me any issue, but I replaced them for the sake my mental satisfaction.

  9. #11848
    PakWheeler Follow
    m_umairr's Avatar
    Join Date
    Sep 2011
    Location
    Islamabad
    Posts
    168
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    5
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Nabeel_Ali View Post
    Use hi octane 3-4 times and drive till reserve light turns on.

    Sent from my SM-N920C using Tapatalk
    My car has been taking long selfs and car feels damn heavy with vibration.
    Engine seems to decrease the oil.
    Any guidance?


    Sent from my iPhone using PW Forums

  10. #11849
    Senior PakWheeler Follow
    Nabeel_Ali's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    24
    Posts
    3,509
    Follows
    2
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by m_umairr View Post
    My car has been taking long selfs and car feels damn heavy with vibration.
    Engine seems to decrease the oil.
    Any guidance?


    Sent from my iPhone using PW Forums
    Which oil are you using?

    Sent from my SM-N920C using Tapatalk

  11. #11850
    PakWheeler Follow
    imrananr's Avatar
    Join Date
    Jun 2014
    Posts
    849
    Follows
    0
    Following
    5
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by Nabeel_Ali View Post
    Which oil are you using?

    Sent from my SM-N920C using Tapatalk
    I hope it's not the 0W20 group.
    Don't leave a highway for a byway....

  12. #11851
    PakWheeler Follow
    m_umairr's Avatar
    Join Date
    Sep 2011
    Location
    Islamabad
    Posts
    168
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    5
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Nabeel_Ali View Post
    Which oil are you using?

    Sent from my SM-N920C using Tapatalk
    I was using Zic A 10W-40, yesterday i went for oil change and half liter oil was missing.
    I poured Shell 5w-30 this time as recommended by my mechanic.

  13. #11852
    PakWheeler Follow
    m_umairr's Avatar
    Join Date
    Sep 2011
    Location
    Islamabad
    Posts
    168
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    5
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by imrananr View Post
    I hope it's not the 0W20 group.
    no way

  14. #11853
    Senior PakWheeler Follow
    Nabeel_Ali's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    24
    Posts
    3,509
    Follows
    2
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by m_umairr View Post
    I was using Zic A 10W-40, yesterday i went for oil change and half liter oil was missing.
    I poured Shell 5w-30 this time as recommended by my mechanic.
    Both are fine.

    And did you notice the burning smell of petrol much more then normal on cold start?

    Sent from my SM-N920C using Tapatalk

  15. #11854
    PakWheeler Follow
    nkhannk's Avatar
    Join Date
    Jan 2006
    Location
    Islamabad
    Age
    38
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Oh kher. Congrats younger brother. Finally your thread is here👍


    Sent from my iPhone using PW Forums

  16. #11855
    PakWheeler Follow
    m_umairr's Avatar
    Join Date
    Sep 2011
    Location
    Islamabad
    Posts
    168
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    5
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Nabeel_Ali View Post
    Both are fine.

    And did you notice the burning smell of petrol much more then normal on cold start?

    Sent from my SM-N920C using Tapatalk
    Yeah, I am having burning smell of pterol when I start car in the morning parked for almost 8-9 hours more than normal.
    What does it indicate?

  17. #11856
    Senior PakWheeler Follow
    Nabeel_Ali's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    24
    Posts
    3,509
    Follows
    2
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by m_umairr View Post
    Yeah, I am having burning smell of pterol when I start car in the morning parked for almost 8-9 hours more than normal.
    What does it indicate?
    You definitely need to change your petrol pump. This usually happens due to extremely dirty fuel. I have experienced this myself.

    Top up the tank with hi octane and use some engine cleaners.

    Sent from my SM-N920C using Tapatalk

  18. #11857
    PakWheeler Follow
    mastspidy's Avatar
    Join Date
    Sep 2013
    Location
    Lahore
    Age
    28
    Posts
    193
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by changwani54 View Post
    Got some maintenance work done on my Vitz 2012 last week.
    Starting with CVT oil change.
    For gear oil aka CVT oil change plz try to read a forum on CVT oil change for Toyota Belta Vitz Passo etc and try to find @Xulfiqar bhai's posts in that forum.
    Either you can go for opening the chamber approach or draining it via drain hole approach.
    I went for changing oil via drain hole approach. Allen key which our common mechanics call "L key" is used to open it. After opening that nut or screw, same Allen key is used to remove the tube that is inside the chamber. Here is the tricky part, most of the mechanics including ones at 3S do know how to take that tube out but they prefer not to, as changing the oil via that bolt doesn't pay well. Usually they try convincing you that opening the chamber is must. Tell the retards that engineers who made the car are way better than them and they didn't put the drain hole and inside tube just to check oil level.
    To be sure exact amount of fluid that comes out, ask the oil guy to collect it and measure the quantity of drained oil. Put back same amount of oil.
    On the other hand if that's not feasible then after draining the oil put back the plastic tube into the nut hole. Do not put the screw or nut back in its place, just the tube. Put the oil via nut hole in upper part of chamber (don't remember which one is it but oil guys usually know it). When oil starts dripping from the hole, wait for it to stop. Start the car and put it in D. Again pour oil till it starts dripping again, it will roughly take 200 to 300 ml of additional oil. Alternatively you can put the screw back after the oil had initially started dripping and add roughly 200 to 250 ml of extra oil. That's it.
    No need of anything else. Car will take back total of 2 to 2.5 L of CVT oil, nearly exactly the amount that was drained.
    P.S. Plz don't be confused when u find someone saying it takes total of 6 or 7L of CVT oil, that's only done when you build the transmission from zero. You can't drain the whole oil, just 2 to 2.5 L of those 6 or 7 L are drained and that's what u put back in.
    Also opening the chamber technique would require roughly 3.5 to 3.8 L of oil.

    Thanks for the details. It will be very helpful for others.

    Can you please mention the workshop name from where you done this ?

  19. #11858
    PakWheeler Follow
    changwani54's Avatar
    Join Date
    Jun 2005
    Location
    Lahore
    Age
    34
    Posts
    370
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mastspidy View Post
    Thanks for the details. It will be very helpful for others.

    Can you please mention the workshop name from where you done this ?
    As I had read all the detail of CVT oil change before going for a change so I supervised the whole process myself satnding right there. It was done from AY Lubes Shop which is on Zarrar Shaheed Road, Guldasht Town Lahore. A guy named Ejaz there knows how to do it, though initially he did try to suggest opening chamber technique which I rejected right away.
    Plz do also note that mechanics at 3S also know this but usually their high ups want them to open the chamber as that thing pays them a lot. I did read someone getting CVT oil change from Toyota Cantt Motors via same drain hole.

  20. #11859
    PakWheeler Follow
    muzammil100's Avatar
    Join Date
    May 2015
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have this problem in my vitz model year 2011, as attached in the picture. It is showing three signs on the dashboard the cold sign which is blinking, the check engine sign and power steering. The steering wheel has become very tough and the fan is also not working. I have showed this problem to 3 mechanics on tariq road near chase up but they couldnt figure out the problem as they were also not able to connect to the ecu for error codes. All of them recommended me to get the wiring checked by opening the dashboard and also one of them asked me to change the card for which he will charge RS20,000. I think its some other issue. I have showed it to toyota central motors they are also asking me to open the dashboard for which they will charge around 20 000. can anyone suggest me what could be the issue or recommend me some electrician or mechanic who can solve this problem. or should I give it to toyota???


    Toyota Vitz OwnersFan Club -1712620

  21. #11860
    Senior PakWheeler Follow
    racerali's Avatar
    Join Date
    Nov 2010
    Location
    Islamabad
    Posts
    1,063
    Follows
    2
    Following
    2
    Mentioned
    138 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    3
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by muzammil100 View Post
    I have this problem in my vitz model year 2011, as attached in the picture. It is showing three signs on the dashboard the cold sign which is blinking, the check engine sign and power steering. The steering wheel has become very tough and the fan is also not working. I have showed this problem to 3 mechanics on tariq road near chase up but they couldnt figure out the problem as they were also not able to connect to the ecu for error codes. All of them recommended me to get the wiring checked by opening the dashboard and also one of them asked me to change the card for which he will charge RS20,000. I think its some other issue. I have showed it to toyota central motors they are also asking me to open the dashboard for which they will charge around 20 000. can anyone suggest me what could be the issue or recommend me some electrician or mechanic who can solve this problem. or should I give it to toyota???


    Toyota Vitz OwnersFan Club -1712620
    Bro you can attach any Elm 327 device

    My friend Has vitz 2013 and cheap elm 327 can do good in your case

    sensor data ,error code
    The cars we drive say a lot about us

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •