Survey by Qualaroo
+ Reply to Thread
Results 1 to 8 of 8

Thread: Vitz 2004 sudden brake issue

  1. #1
    PakWheeler Follow
    quaidian's Avatar
    Join Date
    Oct 2006
    Location
    Lahore
    Age
    38
    Posts
    329
    Follows
    3
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz brake issue - soft/light pedal with shoop shoop sound

    For last couple of weeks I am having a problem in my Vitz 2004 running only on petrol. The brake works fine most of the time but sometimes while driving when I press the brake pedal, it feels very light and brake doesn't respond timely like it does normally and naturally my foot presses the pedal little more and then suddenly it feels the wheels are jammed and car halts for a while and as a result I almost fall on steering. As soon as I lift my foot from pedal car resumes it motion as normal. This unusual braking hurts as it shakes your body badly for a while and a couple of times because of sudden stalling of car, the motorcycle hit car from back. I need to know what's wrong with brake system, why does it behaves abnormally sometime, any idea how to fix it?

    The frequency of happening of the said issue is increasing with passing of each day and some times the issue happens continuously for some time.

    Another thing is when I press brake pedal it gives "shoop shoop" sound not sure what does mean.

  2. #2
    PakWheeler Follow
    Engineer1's Avatar
    Join Date
    Dec 2009
    Location
    Islamabad
    Age
    32
    Posts
    640
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check brake disks, brake leathers and Drumss,, may be it need to be polished and brake leather also needs a change...
    Drive Hard or stay Home............

  3. #3
    PakWheeler Follow
    asimgujjar's Avatar
    Join Date
    Jan 2008
    Location
    Islamabad
    Age
    29
    Posts
    707
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Are u aware of ABS ????
    Why depreciation factor is not applicable to Pakistani corolla ????

  4. #4
    PakWheeler Follow
    quaidian's Avatar
    Join Date
    Oct 2006
    Location
    Lahore
    Age
    38
    Posts
    329
    Follows
    3
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    of course I am aware of ABS :-) and I am driving the same car for almost a year and felt the mentioned problem just from last two weeks - do you mean this is normal ABS behavior, not at all :-(
    * The difference between genius and stupidity is that genius has its limits *

  5. #5
    PakWheeler Follow
    shariqak1's Avatar
    Join Date
    Nov 2006
    Location
    Karachi
    Posts
    983
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It looks like related to ur car's ABS sensors! Try cleaning the area may be some mud on sensors is making difficulty in proper braking. Experts will guide you better.
    Speed costs money. How fast do you want to go?

  6. #6
    PakWheeler Follow
    quaidian's Avatar
    Join Date
    Oct 2006
    Location
    Lahore
    Age
    38
    Posts
    329
    Follows
    3
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    There is also shoop shoop sound when I press brake pedal, does it give any idea od problem, is this related to brake booster or a sensor issue?
    * The difference between genius and stupidity is that genius has its limits *

  7. #7
    PakWheeler Follow
    quaidian's Avatar
    Join Date
    Oct 2006
    Location
    Lahore
    Age
    38
    Posts
    329
    Follows
    3
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    There is also shoop shoop sound from pedal when I press brake pedal, does it give any idea od problem, is this related to brake booster or a sensor issue?
    * The difference between genius and stupidity is that genius has its limits *

  8. #8
    Senior PakWheeler Follow
    Ehsan4808's Avatar
    Join Date
    Sep 2007
    Location
    Lahore
    Age
    34
    Posts
    1,811
    Follows
    7
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bad Brake servo might be the reason

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •