Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 23

Thread: Vitz Power Steering Issue [Urgent Help Required]

  1. #1
    PakWheeler Follow
    wasilrkhan's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    28
    Posts
    545
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Unhappy Vitz Power Steering Issue [Urgent Help Required]

    Salam

    A friends Toyota Vitz model 2009, 2012 import is having power steering issue. The power steering turns off(steering becomes hard) sometimes when he comes to a stop at a traffic signal, then when he gives the engine some revs it again starts working.
    His car got washed first time from inside the bonet(without his knowledge maybe by brother) from a service station. There is also some water in the left side front light.
    What could be the issue and possible fix for this issue

    Waiting For replies

    EDIT:
    Just noticed something , the problem only occurs when the steering is put into full lock on either side.
    locked it 5-6 times to check and the same thing happened again and again.
    What now


    Regards
    Wasil
    Never give up, never back down, Always give a 110 percent,

  2. #2
    PakWheeler Follow
    wasilrkhan's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    28
    Posts
    545
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bump.....anyone
    Never give up, never back down, Always give a 110 percent,

  3. #3
    PakWheeler Follow
    wasilrkhan's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    28
    Posts
    545
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    23 Views and no replies , come on guys
    Never give up, never back down, Always give a 110 percent,

  4. #4
    PakWheeler Follow
    YasirAkram's Avatar
    Join Date
    Jan 2013
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by wasilrkhan View Post
    Salam

    A friends Toyota Vitz model 2009, 2012 import is having power steering issue. The power steering turns off(steering becomes hard) sometimes when he comes to a stop at a traffic signal, then when he gives the engine some revs it again starts working.
    His car got washed first time from inside the bonet(without his knowledge maybe by brother) from a service station. There is also some water in the left side front light.
    What could be the issue and possible fix for this issue

    Waiting For replies

    Regards
    Wasil
    more details plz

  5. #5
    PakWheeler Follow
    wasilrkhan's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    28
    Posts
    545
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bump...
    Never give up, never back down, Always give a 110 percent,

  6. #6
    PakWheeler Follow
    alikhan7's Avatar
    Join Date
    Mar 2005
    Location
    Multan
    Age
    33
    Posts
    744
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Seems EPS malfunctioning ask him to reset ECU

  7. #7
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,736
    Follows
    16
    Following
    0
    Mentioned
    489 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Sounds Like Some BUG With EPS.....Reset The EPS System....!!

    Might Need Scanner Attached To Do It....!!
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  8. #8
    PakWheeler Follow
    wasilrkhan's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    28
    Posts
    545
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by SER_GTR View Post
    Sounds Like Some BUG With EPS.....Reset The EPS System....!!

    Might Need Scanner Attached To Do It....!!
    Quote Originally Posted by SER_GTR View Post
    Sounds Like Some BUG With EPS.....Reset The EPS System....!!

    Might Need Scanner Attached To Do It....!!
    Could this be because of under bonet water service
    Never give up, never back down, Always give a 110 percent,

  9. #9
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,736
    Follows
    16
    Following
    0
    Mentioned
    489 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    The EPS Usually Lies Underneath Cabin ...

    Did You Feel It After Water Service???

    Water Can Get On Wrong Places Sometimes Causing It But It Can Also Be EPS System Running Into LIMP Mode....
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  10. #10
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,736
    Follows
    16
    Following
    0
    Mentioned
    489 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    @Xulfiqar can answer it better...
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  11. #11
    Senior PakWheeler Follow
    autophile's Avatar
    Join Date
    Sep 2004
    Location
    Islamabad
    Posts
    13,578
    Follows
    20
    Following
    6
    Mentioned
    405 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Please post your problem in Vitz owners or fans thread
    Be polite on the road. Always give way to others, particularly ambulances and pedestrians.

  12. #12
    PakWheeler Follow
    wasilrkhan's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    28
    Posts
    545
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by SER_GTR View Post
    The EPS Usually Lies Underneath Cabin ...

    Did You Feel It After Water Service???

    Water Can Get On Wrong Places Sometimes Causing It But It Can Also Be EPS System Running Into LIMP Mode....
    Yes , before washing it was fine.
    What is LIMP Mode and how to fix it
    And how to reset the EPS
    Never give up, never back down, Always give a 110 percent,

  13. #13
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,400
    Follows
    131
    Following
    0
    Mentioned
    3989 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    to reset the Toyota EPS - you need to connect it to a Toyota Tech Stream unit, there is no manual way of resetting it reliably. Your issue more sounds like the torque sensor in the rack is malfunctioning. It can go bad if its flooded with water.

    Any Toyota shop can reset it for you.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  14. #14
    PakWheeler Follow
    wasilrkhan's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    28
    Posts
    545
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Just noticed something , the problem only occurs when the steering is put into full lock on either side.
    locked it 5-6 times to check and the same thing happened again and again.
    What now
    Never give up, never back down, Always give a 110 percent,

  15. #15
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,400
    Follows
    131
    Following
    0
    Mentioned
    3989 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    do not spin the wheel quick to get it from lock to lock - the steering motor overheats and the system will shut down to prevent the motor from burning out.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  16. #16
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,736
    Follows
    16
    Following
    0
    Mentioned
    489 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    EPS Need To Be Treated Nicely.....If You Overexcite It Too Much...It Will Enter Into Limp Mode Considering There Must Be Some Serious

    Issues With Car Alignment...Safety Precautions.....Its Not Hydraulic So Be Careful Using It.....The Rack And Motor Is NO Cheap....So As Its Replacement
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  17. #17
    PakWheeler Follow
    wasilrkhan's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    28
    Posts
    545
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Xulfiqar View Post
    do not spin the wheel quick to get it from lock to lock - the steering motor overheats and the system will shut down to prevent the motor from burning out.
    didnt do it quick , just at normal spinning pace , and once at a slower pace too to check but the same result
    Never give up, never back down, Always give a 110 percent,

  18. #18
    PakWheeler Follow
    YasirAkram's Avatar
    Join Date
    Jan 2013
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    its turn on whn driving for 1 to 2 sec and dissappear.... there is no error in ECU. Electrian says it mite b ABS sensor issue. is it possible???

  19. #19
    PakWheeler Follow
    wasilrkhan's Avatar
    Join Date
    Dec 2007
    Location
    Lahore
    Age
    28
    Posts
    545
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by YasirAkram View Post
    its turn on whn driving for 1 to 2 sec and dissappear.... there is no error in ECU. Electrian says it mite b ABS sensor issue. is it possible???
    The issue is with his car
    Never give up, never back down, Always give a 110 percent,

  20. #20
    PakWheeler Follow
    RUSTY's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    28
    Posts
    110
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    salam brother i got the same prob and i was really worried but my problem was that one terminal of battery was loose so whenever the connection with the battery goes off it becomes hard so kindly chk it as well

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •