Survey by Qualaroo
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 20 of 46
Like Tree4Likes

Thread: Vitz 2005 Vibrating & Knocking

  1. #1
    Newbie Follow
    Asim200276's Avatar
    Join Date
    Apr 2013
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz 2005 Vibrating & Knocking

    I have Vitz 2005, Now adays I am facing problem that when I stop and was in D that car was vibrating. Also when I was on my AC then some time engine was off. Can anybuddy advice me about these problems or give me any good mechanic tel no. to fix thi problem.

    Asim


  2. #2
    PakWheeler Follow
    aftab87's Avatar
    Join Date
    Jul 2010
    Location
    Mombasa
    Age
    29
    Posts
    23
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Remove the Throttle Body and clean off the carbon inside especially on the butterfly with any carbon cleaner or with petrol. Let me know if your problem is solved

  3. #3
    Senior PakWheeler Follow
    Hesab_Magsi's Avatar
    Join Date
    Aug 2010
    Location
    Quetta
    Age
    26
    Posts
    1,739
    Follows
    0
    Following
    0
    Mentioned
    31 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    This used to happen with my vitz aswell,had to sell it off

  4. #4
    Senior PakWheeler Follow
    Docjunaid's Avatar
    Join Date
    Mar 2012
    Location
    Sadiqabad
    Posts
    2,046
    Follows
    4
    Following
    0
    Mentioned
    48 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Kindly look up VITZ OWNERS/FAN CLUB on pakwheels
    This issue is discussed in detail there
    In short as mentioned start with throttle body cleaning, get plugs checked, use almost all the fuel u hv in the ride & get it filled @ some good pump preferably hi octane 30% & supreme 70% or simply quality fuel
    These steps hv solved most ppl's problems
    Glory Glory Manchester United

  5. #5
    PakWheeler Follow
    aftab87's Avatar
    Join Date
    Jul 2010
    Location
    Mombasa
    Age
    29
    Posts
    23
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Well said@Docjunaid

  6. #6
    PakWheeler Follow
    uzeemujeeb's Avatar
    Join Date
    Dec 2008
    Location
    Karachi
    Posts
    381
    Follows
    1
    Following
    5
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    also check engine oil & oil filter

  7. #7
    PakWheeler Follow
    amjads98's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Age
    41
    Posts
    102
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have vitz 07 and 1000cc. And having the same vibration issue when stand still in gear D. i have done everything. throttle body clean and then changed, battery changed, alternator changed, transmission oil, oil filter, air filter. clean the iridium plugs, clean the fuel filter clean, foundation rubber changed. but problem is still there. use hi octane 70 % and normal petrol 30%. what can be the cause now. already spend lot of money. But vibration is still there. anyone can help me pleaseeeeeeeeeeeeeeeeeeeee

    although pick is fine, no other mechanical issue but mileage in full tank is 300 km which is very bad

  8. #8
    Senior PakWheeler Follow
    asad1's Avatar
    Join Date
    Aug 2005
    Location
    Karachi
    Age
    30
    Posts
    2,707
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    knocking issue is with all vitz above 2005 due to bad quality petrol use hi octane after throttle body service
    @ amjad check ur car oil pump k whether it is circulating oil perfectly as this happened in my relatives passo but it was making weird sound as well and have u checked the by diagnostic equipment ? we can just rectify the problem by it

  9. #9
    PakWheeler Follow
    amjads98's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Age
    41
    Posts
    102
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks Asad for suggestion. checked/verified through computer scanner, everything is perfectly okey. i will definitely show the oil pump too. But don't think that it will be the problem.

  10. #10
    PakWheeler Follow
    haris457's Avatar
    Join Date
    Jan 2006
    Location
    Rawalpindi
    Age
    35
    Posts
    616
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Asim200276 View Post
    I have Vitz 2005, Now adays I am facing problem that when I stop and was in D that car was vibrating. Also when I was on my AC then some time engine was off. Can anybuddy advice me about these problems or give me any good mechanic tel no. to fix thi problem.

    Asim
    bro same problem i faced after getting air filter changed.the problem which was there that that housing for air filter wasnt properly seated and it was taking air,got it fixed myself and now everything is fine

  11. 04-06-2013, 02:57 PM
    jz

    Senior PakWheeler

    Reason
    off topic

  12. 04-06-2013, 03:06 PM

    Senior PakWheeler

    Reason
    off topic

  13. #11
    PakWheeler Follow
    amjads98's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Age
    41
    Posts
    102
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i think i know what is causing the problem with my car, but don't know how to solve it. My car voltage is 12.7 when ignition on. it should be around 13.5v to 14v. Already showed alternator to different electricians, they just told me that it is working fine. But i was not satisfied so decided to change my alternator. after changing the alternator with the kabli one, same output i am getting. Now i am thinking maybe the kabli alternator/generator is also faulty. yeah in the mean while i managed to installed raizin voltage stabilizer but no difference. I have installed new battery AGS ns 60 too. i am totally confused. please help. Thanks in advance.

  14. #12
    PakWheeler Follow
    amjads98's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Age
    41
    Posts
    102
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    so i have changed the alternator again, and the voltage problem resolved. now my car on idle is giving 13.9 and on push the paddle it reaches 14.2. But vibration problem is still there. Now i am planning to change the iridium plugs and fuel injector clean. Any suggestion.

  15. #13
    Senior PakWheeler Follow
    ajjubravo's Avatar
    Join Date
    Aug 2005
    Location
    Islamabad
    Posts
    1,040
    Follows
    1
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    You have to clean the wall body of your car's transmission located inside the transmission chamber!
    It have 4 springs in it which gets carbon deposited on them and hence car starts to vibrate in D or R!
    Get it cleaned from a good mechainic your problem will be solved!
    Throttle Body Do Not make this type of issues in a vitz but bad throttle body gives bad economy and poor throttle response!


    Sent from my HTC One X using PW Forums mobile app
    Mod Edit: Commercial selling is not allowed!

  16. #14
    PakWheeler Follow
    amjads98's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Age
    41
    Posts
    102
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have changed the CVT transmission oil last month. do i still need to clean the chamber too? as the mechanic open the chamber, drain the oil and clean the chamber cap and fix it with silicon. I am hoping we are on the same page.

  17. #15
    Senior PakWheeler Follow
    ajjubravo's Avatar
    Join Date
    Aug 2005
    Location
    Islamabad
    Posts
    1,040
    Follows
    1
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    You need to clean the wall body mate located above the transmission filter!

    Sent from my HTC One X using PW Forums mobile app
    Mod Edit: Commercial selling is not allowed!

  18. #16
    PakWheeler Follow
    amjads98's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Age
    41
    Posts
    102
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Cleaning the wall body changed nothing. Same vibration I am having. Another thing when I bought the car the housing of heater pipes were removed from the throtle body. May it cause the problem? Exuast system checked and airintake box check no leakage found. May be electric wiring of the car damage. I have changed the iridium plugs too recently and the oem. Original oil filter and air filter placed this month. Shifted to shell blue box oil hx7 20w 30. So much fedup with this vibration. Anyone with suggestions. Really need your expertise in that.

  19. #17
    PakWheeler Follow
    Ali_Mujtba's Avatar
    Join Date
    Apr 2012
    Location
    Faisalabad
    Posts
    198
    Follows
    0
    Following
    1
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have the solution, 90% chances it will work,
    Adjust the gap between accelerating paddle and the plastic type thingy which works as stopper above the paddle, with some foam tape.you can easily do it yourself or give this hint to some workshop man, he can do it for you.
    Adjust the gap such that your required engine RPMs are achieved.
    Total time = 10 min. Total cost = Rs.10

  20. #18
    PakWheeler Follow
    amjads98's Avatar
    Join Date
    Jun 2009
    Location
    Rawalpindi
    Age
    41
    Posts
    102
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks Ali bhai for suggestion. I will try to explain this to mechanic. I bought vitz 4 months back and first time when I went for general check up and throttle tuning they showed me that first owner placed a piece of paper in acceleration paddle to have increased rpm but that is risky because brakes will not work properly especially when engine is cold and running in high rpm. Is that true? I am having vibration problem when engine is hot. In cold engine no vibration at all. One thing more a little vibration start even in parking and nutral gear when I close or open the window or press horn. Can it be possible leakage in wiring between ecu or battery or alternator or may be any fuse fualty.
    If no other solution and no risk envolve then I will place foam tape as I am traveling with my little baby and family.
    Ali bhai have you done this before? Thanks again.

  21. #19
    PakWheeler Follow
    Ali_Mujtba's Avatar
    Join Date
    Apr 2012
    Location
    Faisalabad
    Posts
    198
    Follows
    0
    Following
    1
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bro, i have also same model 2005~06 vitz. i had suffered alot for this problem too, in my vitz the problem was so severe that its engine used to shut off, problem nature was almost similar to yours. than 1 day mechanic showed me this thing, the foam tape placed in paddle by previous owner had torn off, so the problem was rising.
    For your other reservation,it is total risk free as far as i have tested it, have run it for about a year now. i myself have become expert in this now,hahaha..whenever after 3,4 months old tape is torn, i myself fix it and adjust the RPMS.
    Moreover when i didnt knew this problem, i got checked each and every fuse, but problem had not vanished. ALHAMDU LILLAH now i m in peace.
    When engine is cold and on high RPMs, just be conscious for 1st 1 min, thats all.

  22. #20
    Senior PakWheeler Follow
    wasay_ahmed's Avatar
    Join Date
    Nov 2006
    Location
    Lahore
    Age
    29
    Posts
    4,960
    Follows
    3
    Following
    0
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Use Hioctane fuel thts the only cure or get a Unichip or some fuel management system.They will adjust AFR mixture asper local normal fuel quality.All these JDMs are designed for hioctane
    DIY The Best Workshop on the Holy Planet!
    Every thing changes,Its only the "change" which never changes.

+ Reply to Thread
Page 1 of 3 123 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •