Survey by Qualaroo
+ Reply to Thread
Results 1 to 8 of 8

Thread: Vitz 2008 brake broblem

  1. #1
    PakWheeler Follow
    ozzeyy's Avatar
    Join Date
    May 2010
    Location
    Islamabad
    Age
    27
    Posts
    78
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz 2008 brake broblem

    hi PWS

    I am having a brake problem in my vitz when i press brake paddle at half level it gives a 'TAK' sound and at the second immediate press there is no sound but after 2 to 3 minutes it again gives the same sound.

    Suggestions Please..

    Thank you

  2. #2
    PakWheeler Follow
    mag88's Avatar
    Join Date
    Jun 2008
    Location
    Karachi
    Age
    36
    Posts
    166
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    get brakes inpected (and serviced if neccesary). Flush the brake fluid and bleed air out.

  3. #3
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    It could be related to a weak or loose suspension part,get it checked properly.
    Never loose hope in life,every step gives u something.

  4. #4
    Senior PakWheeler Follow
    huzaifa.haroon's Avatar
    Join Date
    Aug 2012
    Location
    Islamabad
    Posts
    5,001
    Follows
    10
    Following
    1
    Mentioned
    225 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    0

    Default

    Quote Originally Posted by ozzeyy View Post
    hi PWS

    I am having a brake problem in my vitz when i press brake paddle at half level it gives a 'TAK' sound and at the second immediate press there is no sound but after 2 to 3 minutes it again gives the same sound.

    Suggestions Please..

    Thank you
    Is that a A.B.S sound ?
    Always respect your parents

  5. #5
    Senior PakWheeler Follow
    ibadaslam872's Avatar
    Join Date
    Feb 2009
    Location
    Lahore
    Age
    18
    Posts
    6,107
    Follows
    0
    Following
    5
    Mentioned
    49 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    It's the Bush which is attached to the 'Chimta'. Get it checked. The bush is probably broken.

    Sent from my GT-S5660 using PW Forums mobile app
    Under the Coconut tree

  6. #6
    PakWheeler Follow
    ozzeyy's Avatar
    Join Date
    May 2010
    Location
    Islamabad
    Age
    27
    Posts
    78
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mag88 View Post
    get brakes inpected (and serviced if neccesary). Flush the brake fluid and bleed air out.
    thankx buddy..
    BTW what are the requirements for servicing brakes?

  7. #7
    PakWheeler Follow
    ozzeyy's Avatar
    Join Date
    May 2010
    Location
    Islamabad
    Age
    27
    Posts
    78
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by huzaifa.haroon View Post
    Is that a A.B.S sound ?
    Thanks bddy.

    no its not ABS sound..
    brake is working properly but that tak sound is irritating

  8. #8
    Senior PakWheeler Follow
    vagabondpiper's Avatar
    Join Date
    Jun 2010
    Location
    Islamabad
    Age
    34
    Posts
    1,327
    Follows
    1
    Following
    0
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    do get engine mountings checked
    No one cares for Toyota more then Toyota

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •