Survey by Qualaroo
+ Reply to Thread
Results 1 to 11 of 11

Thread: Toyota Vitz 2002 black smoke issue

  1. #1
    PakWheeler Follow
    ahmedwasiq's Avatar
    Join Date
    Nov 2007
    Location
    Rawalpindi
    Age
    31
    Posts
    397
    Follows
    1
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Toyota Vitz 2002 black smoke issue

    Dear Experts

    Please help me ; I have a vitz 2002 model facing an issue of black smoke & bad fuel average.
    Cleaned the throttle body and changed the airfiltes but vein.
    Please advice what to do??

  2. #2
    PakWheeler Follow
    ali_bin_farman's Avatar
    Join Date
    Dec 2012
    Location
    Islamabad
    Posts
    763
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Your rings might be worn out!

    GT-I9100 CyanogenMod

  3. #3
    PakWheeler Follow
    haider.ranjha's Avatar
    Join Date
    May 2014
    Location
    Lahore
    Age
    27
    Posts
    2
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    black smoke is the sign of excessive petrol burning .thats y ur fuel average is disturbed.
    in carby cars we need to adjust air to fuel ratio for this purpose.dont know about efi cars.

  4. #4
    PakWheeler Follow
    ahmedwasiq's Avatar
    Join Date
    Nov 2007
    Location
    Rawalpindi
    Age
    31
    Posts
    397
    Follows
    1
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    In that case Ali the colour of the smoke is white as it's a petrol car

  5. #5
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    did you ever connect it to a proper scan unit?
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  6. #6
    PakWheeler Follow
    ahmedwasiq's Avatar
    Join Date
    Nov 2007
    Location
    Rawalpindi
    Age
    31
    Posts
    397
    Follows
    1
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes
    But no fault code

  7. #7
    Senior PakWheeler Follow
    umarkhan1's Avatar
    Join Date
    Nov 2010
    Location
    Sargodha
    Posts
    2,312
    Follows
    6
    Following
    8
    Mentioned
    51 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by ahmedwasiq View Post
    Yes
    But no fault code
    share the live readings here
    Just Do It Your Self!!!!!

  8. #8
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,402
    Follows
    131
    Following
    0
    Mentioned
    3990 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by ahmedwasiq View Post
    Yes
    But no fault code

    there is more to scan. Fault codes are just marker flags.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  9. #9
    PakWheeler Follow
    shafiaamer's Avatar
    Join Date
    Sep 2004
    Location
    Rajanpur
    Age
    37
    Posts
    57
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Clearly car is consuming extra fuel

  10. #10
    Senior PakWheeler Follow
    aamirq's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    31
    Posts
    1,726
    Follows
    0
    Following
    1
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    maybe the plugs are worn out! cud be choked injectors too! or a choked fuel filter!
    "The world ain't all sunshine and rainbows. It's a very ruff, mean place, and no matter how tuff you think you are, it will always bring you to your knees and keep you there permanently if you let it.You or nobody ain't never gonna hit as hard as life, but it ain't about how hard you hit, it's about how hard you can get hit and keep moving forward, how much you can take and keep moving forward. If you know what you're worth, go out and get what you're worth, but you gotta be willing to take the hit."
    - Sylvester Stallone

  11. #11
    Senior PakWheeler Follow
    asad1's Avatar
    Join Date
    Aug 2005
    Location
    Karachi
    Age
    30
    Posts
    2,707
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Fuel average is disturbed right after CAT removal or if ur O2 sensor is not functioning well

    Sent from my GT-I9105 using PW Forums mobile app

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •