Survey by Qualaroo
+ Reply to Thread
Results 1 to 15 of 15

Thread: 2006 Toyota Vitz engine vibration

  1. #1
    PakWheeler Follow
    toohoking's Avatar
    Join Date
    May 2015
    Location
    Auckland
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Smile 2006 Toyota Vitz engine vibration

    Hi, I am owning a vitz (1.0L Automatic petrol) with a mileage of 103,XXX KMs. I bought it in last July and had no clue about its mantainance history. About 2 month ago, the engine started shaking when idle. But when the speed comes over 40km/h, it turns out to be OK. Besides, the vibration becomes more serious when the wipers are working. Can anybody give me a suggestion to fix this problem?

    PS: I come from China, hope my poor English not make you confused. I googled such problem seeking for a solution and found this awesome forum. I've read a few threads in this forum discribing the same issue and bulid a fuzzy clue that possible reasons may be from engine mount, throttle body or MAF. Which one is applicable to my scenario? I hope this thread could help others with the same problem. Cheers!


  2. #2
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,592
    Follows
    31
    Following
    6
    Mentioned
    1017 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    @toohoking welcome to PAKWHEELS, there is another chinese-mangol-punjabi respectable administrator among us @ VCHENG he can help you too to translate mandarin, mangolian, cantonese to english

    anyway mate you have worded your problem in english very well, please stay with us. following are likely causes of such problem tagged are other PRO solvers @syncview, @rustam54 @argtr65 @SER_GTR @Xulfiqar

    I suggest inspection of :

    1. engine mounts
    2. bad ground between frame & generator / battery ground pole to frame & body [ wiper motor takes load too ]
    3. transmission mounts

    TB & MF malfunction will cause bad fuel consumption & loss of power, - am sure others will also offer their input -

    BTW a/t need fluid & fluid filter change every 75000 kms, if there is no history available, Please change now,



    Quote Originally Posted by toohoking View Post
    Hi, I am owning a vitz (1.0L Automatic petrol) with a mileage of 103,XXX KMs. I bought it in last July and had no clue about its mantainance history. About 2 month ago, the engine started shaking when idle. But when the speed comes over 40km/h, it turns out to be OK. Besides, the vibration becomes more serious when the wipers are working. Can anybody give me a suggestion to fix this problem?

    PS: I come from China, hope my poor English not make you confused. I googled such problem seeking for a solution and found this awesome forum. I've read a few threads in this forum discribing the same issue and bulid a fuzzy clue that possible reasons may be from engine mount, throttle body or MAF. Which one is applicable to my scenario? I hope this thread could help others with the same problem. Cheers!
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  3. #3
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,735
    Follows
    16
    Following
    0
    Mentioned
    488 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Welcome To Our Pakistani Forums ...We Welcomes CHinese Friend

    Mention Your Vitz Model For More Understanding

    Anyways Get Your Engine Mounts Checked And Ground Checked...They Seems Broken As Vibration Can Be Felt Due To That Also

    Also Make Sure There Are No Lame Connections Done...Wiring...That Might DIsturb Electrical System And Cause Engine To Act Lame..

    For Rough Poor Idle....Get You Throttle Body Cleaned And CHeck Your Idle Air Valve..That Might Be Jamnned Causing Rough Idle So As Dirty Throttle Body
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  4. #4
    Senior PakWheeler Follow
    MADDYBOY's Avatar
    Join Date
    Jun 2006
    Location
    Lahore
    Posts
    1,069
    Follows
    1
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by SER_GTR View Post
    Welcome To Our Pakistani Forums ...We Welcomes CHinese Friend

    Mention Your Vitz Model For More Understanding

    Anyways Get Your Engine Mounts Checked And Ground Checked...They Seems Broken As Vibration Can Be Felt Due To That Also

    Also Make Sure There Are No Lame Connections Done...Wiring...That Might DIsturb Electrical System And Cause Engine To Act Lame..

    For Rough Poor Idle....Get You Throttle Body Cleaned And CHeck Your Idle Air Valve..That Might Be Jamnned Causing Rough Idle So As Dirty Throttle Body
    where idle air valve is located ?
    -

  5. #5
    PakWheeler Follow
    toohoking's Avatar
    Join Date
    May 2015
    Location
    Auckland
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks so much, my friend. I will check with the mechanician and keep this thread updated.

  6. #6
    PakWheeler Follow
    toohoking's Avatar
    Join Date
    May 2015
    Location
    Auckland
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The model is DBA-KSP90. Thanks for your input, my friend.

  7. #7
    PakWheeler Follow
    ecu_designer's Avatar
    Join Date
    Nov 2013
    Location
    Islamabad
    Posts
    255
    Follows
    0
    Following
    0
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by SER_GTR View Post
    For Rough Poor Idle....Get You Throttle Body Cleaned And CHeck Your Idle Air Valve..That Might Be Jamnned Causing Rough Idle So As Dirty Throttle Body
    Vitz 1.0L CVT 1KR-FE has no Idle Air Valve, its equipped with ETCS. I hope cleaning the throttle body will resolve the rough idle problem.

  8. #8
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @toohoking,

    1- Check and replace spark plugs.
    2- Clean / replace air filter.
    3- Clean throttle body & as well as check butterfly valve for worn out,replace throttle body in case of worn butterfly valve.
    4- Check vacuum pipes for proper connection.
    5- Make sure all electrical wiring connecter firmly connected on there specific location.
    Never loose hope in life,every step gives u something.

  9. #9
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,735
    Follows
    16
    Following
    0
    Mentioned
    488 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by ecu_designer View Post
    Vitz 1.0L CVT 1KR-FE has no Idle Air Valve, its equipped with ETCS. I hope cleaning the throttle body will resolve the rough idle problem.
    I Thought He Got One With 1SZ-FED...Didn't Notice 2006

    In 1KR. Idle Is Usually Solved By Cleaning Throttle Body....Much Common In These Motors...Butterfly Usually Get Stuck With Moisture Dust Deposit And Cause Unstable Idle
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  10. #10
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,735
    Follows
    16
    Following
    0
    Mentioned
    488 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by MADDYBOY View Post
    where idle air valve is located ?
    In 1KR Can Be Resolved By Clean T.B

    In 1SZ...Its Located Somewhere On Right Side Below Your Intake Manifold
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  11. #11
    Senior PakWheeler Follow
    MADDYBOY's Avatar
    Join Date
    Jun 2006
    Location
    Lahore
    Posts
    1,069
    Follows
    1
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by SER_GTR View Post
    In 1KR Can Be Resolved By Clean T.B

    In 1SZ...Its Located Somewhere On Right Side Below Your Intake Manifold

    1KR = 1.0
    if i am not wrong
    can you share the pic as i am not getting what you are trying to make me understand if possible
    -

  12. #12
    PakWheeler Follow
    ecu_designer's Avatar
    Join Date
    Nov 2013
    Location
    Islamabad
    Posts
    255
    Follows
    0
    Following
    0
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by MADDYBOY View Post
    1KR = 1.0
    if i am not wrong
    can you share the pic as i am not getting what you are trying to make me understand if possible
    Vitz Variants (XP90 2005 to 2010)
    1KR-FE I3 ==> 1.0L CVT 2WD (ETCS)
    2SZ-FE I4 ==> 1.3L CVT 2WD (ETCS)
    2NZ-FE I4 ==> 1.3L AT/MT 4WD
    1NZ-FE I4 ==> 1.5L AT/MT

  13. #13
    Senior PakWheeler Follow
    MADDYBOY's Avatar
    Join Date
    Jun 2006
    Location
    Lahore
    Posts
    1,069
    Follows
    1
    Following
    0
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    exactly
    i am asking where idle air valve is located with reference with pic
    -

  14. #14
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,735
    Follows
    16
    Following
    0
    Mentioned
    488 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Quote Originally Posted by MADDYBOY View Post
    1KR = 1.0
    if i am not wrong
    can you share the pic as i am not getting what you are trying to make me understand if possible
    1SZ Comes In 1999-2004 Whereas 1KR Comes 2005-2010

    Both 1.0L...

    1KR Don't Have It...
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  15. #15
    PakWheeler Follow
    toohoking's Avatar
    Join Date
    May 2015
    Location
    Auckland
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes, I think my model should be 1KR-FE I3. Thansk ecu_designer.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •