Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27
Like Tree3Likes

Thread: Vitz 99 Break issue on AC

  1. #1
    PakWheeler Follow
    malizahid's Avatar
    Join Date
    Jun 2009
    Location
    Karachi
    Age
    31
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz 99 Break issue on AC

    Salam ,

    I have vitz 99 with CNG installed . Recently i am getting 2 major issues in my car .

    1.RPM gets too low specially on AC and car engine gets off almost on every signal .frequency in petrol is low and on cng its always .
    2.Breaks almost doesnt work on AC with petrol and cng both . This happens specially when the car is running at a low speed .

    I have checked couple of mechanics but dont get any satisfactory answer . There is one famous Guddu mechanic in tariq road who is saying its due to engine weakining and if you change only the engine assembly this will be solved .
    He serviced throttle body and also changed choke sensor to adjust the RPM . Also tappets are checked and they are not tight .

    Another mechanic from toyota motors is on a suggestion that it is nothing with the engine , there is something electrical fault

    Please give your experience only those who have faced similar problem and also how this was solved .

    Also if anyone knows some expert mechanic to fix this . Kindly provide his address and contact no .

    Waiting for your answers anxiously .


  2. #21
    PakWheeler Follow
    malizahid's Avatar
    Join Date
    Jun 2009
    Location
    Karachi
    Age
    31
    Posts
    6
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    have never recorded mileage though . do you know any mechanic who can rebuild in 15k ? or even 22k with assembly fitting ?

  3. #22
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Quote Originally Posted by malizahid View Post
    have never recorded mileage though . do you know any mechanic who can rebuild in 15k ? or even 22k with assembly fitting ?
    Don't go for engine rebuilt or assembly change without compression test what would you if your problem didn't go away after rebuilt or swap ? The weak engine doesnt make sense in your case

  4. #23
    Senior PakWheeler Follow
    kkoool's Avatar
    Join Date
    Apr 2005
    Location
    Islamabad
    Age
    35
    Posts
    1,661
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    check the air intake box for any leaks after the air filter and TB, probably the ventury of cng or injector of cng is causing wrong MAF reading, engine weakness has nothing to do with brake servo operation until the lines are having a leak, replace the NRV just before the servo as its a cheap think, 200-300rs
    if not there is a chance that the brake servo diaphragm is punctured. try replacing it, its also very cheap.
    lastly open the hood of a 2.0d saloon and look for a brake vaccumm reservoir tank, get a same thing for your vitz and enjoy
    AE 86

  5. #24
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    Editted

  6. #25
    PakWheeler Follow
    sirdneo's Avatar
    Join Date
    May 2013
    Posts
    84
    Follows
    0
    Following
    1
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by malizahid View Post
    Thanks for your reply . I have already serviced throttle body and have replaced choke sensor , dont know about MAF sensor . As far as breaks are concerned , even on petrol and on ac breaks gets hard and doesnt work . More interestingly breaks get more hard when i am driving slowly on ac . When the speed is fast , breaks do work and they get little hard but not as good as without ac .

    Any suggestions ? still its because of low RPM breaks does not work ?
    When u press brake a hydraulic system is activated and like the car ac it has a vacuum device to increase acceleration, seems like the vacuum pump or its pipes are causing the problem. Because your issue is on both CNG and Petrol.

    Ask mechanic to check for all vacume leaks, generally they test vacume leaks by spraying water on pipes comming in/out of engine(when water is on the pipes, it acts as a temproray glue and your vaccume leaks are filled temproraryly, ya phir ustad agar charsi ho to phir cigreate pee ky uska dhoowa pipes main dalty hy taky jaha sy vacume leak ho waha py sy smoke bahir aaye.

  7. #26
    Senior PakWheeler Follow
    saboor73's Avatar
    Join Date
    Oct 2013
    Location
    Karachi
    Posts
    10,553
    Follows
    25
    Following
    0
    Mentioned
    351 Post(s)
    Tagged
    14 Thread(s)
    Problems Posted
    0
    Problems Solved
    6
    Best Answers
    2
    Good Answers
    25

    Default

    right from vitz service Vitz 99 Break issue on AC -1623225Vitz 99 Break issue on AC -1623221

  8. #27
    PakWheeler Follow
    rizwan14321's Avatar
    Join Date
    Aug 2015
    Posts
    4
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @malizahid:

    Bhai I am from Rawalpindi. Mein ne Parson Vitz99 li hai islamabad se. It has also the same problem with AC on slow speed (Traffic Signals) that break is much hard & when i Turn Off the AC it goes Fine. Please any solution you got for that ? I will be very thankful if you provide me your Mobile Number so i call you.

    Regards

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •