Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: Vitz having Acceleration problems please help :((

  1. #1
    PakWheeler Follow
    anzar007's Avatar
    Join Date
    Sep 2015
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz having Acceleration problems please help :((

    I have a vitz '99 model 1sz-fe (1000cc 4 cyl.)
    4pin Bosch performance plugs added, exhaust with 1.5inch pipe, CAT removed..
    6 months back when i bought it it did 0-100 in about 17-18 seconds..
    but 2-3 months ago the car had an accident and since then the car is not having proper pickup
    it does now 0-100 in about 24-25 seconds... one of the hook of airfilter is broken so i wanted to know does it affects acceleration of car because the air filter box shakes when accelerating.. secondly, since i bought the car the 3rd, 4th, 5th gears dont have proper acceleration .. for example if we consider speed of 60-80.. in 2nd gear this speed is covered in 5 seconds.. but if i do it in 3rd gear then it takes about 8-10 seconds.. and at high speeds like after 120.. the 4th and 5th gears are useless.. only in 3rd gear i can do more than 120.. and the last major problem that comes when i suddenly give full acceleration in 1st or 2nd gear i hear tak-tik sounds from right side tyre.. like 2 metal plates hitting each other.. and also at high speeds the car if not smooth like at speed of 100 if i give accleration the car shakes.. if i press clutch then its smooth..
    maybe i asked some foolish things but the solution to these problems would be highly appreciated..
    please help me restoring back the lost acceleration of my car..

    and also i want to know a stock 1sz-fe vitz 1000cc 4cyl.. properly maintained does 0-100 in how much time ??
    Thanks in Advance!

  2. #2
    PakWheeler Follow
    anzar007's Avatar
    Join Date
    Sep 2015
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i also hear these metal plates hitting each other sounds when at speed of 30-40 i put 3rd or 4th gear.. and when suddenly at this speed i release the clutch i hear this tik sound..

  3. #3
    PakWheeler Follow
    anzar007's Avatar
    Join Date
    Sep 2015
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    some mechanic said the valves have problem .. cylinders are missing so valves need to be replaced ! estimated cost with labour and all 18,000rs!
    is he right ?
    Anyone please tell me is he right or what?

  4. #4
    PakWheeler Follow
    humayun.chughtai.7's Avatar
    Join Date
    Nov 2013
    Location
    Multan
    Age
    20
    Posts
    630
    Follows
    2
    Following
    2
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    3

    Default

    Simply go to bilal gunj lahore or shoba bazar peshawar and get your car swapped with a kabuli half assembly and you are good to go... You can trade of by giving them your old assembly and extra 15000 rs.


    Sent from my iPhone using PW Forums

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •