Survey by Qualaroo
+ Reply to Thread
Results 1 to 13 of 13

Thread: Heavy steering problem in Vitz (2005)

  1. #1
    PakWheeler Follow
    AlienX's Avatar
    Join Date
    May 2012
    Location
    Rawalpindi
    Posts
    76
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Heavy steering problem in Vitz (2005)

    @Xulfiqar @rajaatta

    My Vitz (2005) Steering was normal, and required very little force to steer and corner the vehicle. But now it feels heavy, and requires some force to turn and steer the car. Much like manual steering.

    First, here is before this issue appeared.

    • ABS wasn't working and car sometimes skid when breaking in emergency.
    • After finding the problem, the front right sensor and bearing were replaced.
    • ABS problem solved.


    After that the car was good. But I noticed the heaviness in steering, as if there is too much load on car.

    • Had the wheel alignment corrected. No change in steering feel.
    • All four breaks serviced, no change in steering feels
    • Tire pressure are correct.


    Over all, the car is functioning normally, with no warning light etc. When I start the car, the steering is good and there is power to fully rotate it easily. But after driving for about 10 meters, it feels like steering wheel has become manual and need force to steer and corner which is very tiring. It doesn't stick and comes back with a kick instead of softly rotating to center.

    Only one thing which stands out from everything is electrician unplugged the main electrical hub which is situated under battery stand. My guess is some loose connection is causing the EPS motor to shut off after a while.


  2. #2
    PakWheeler Follow
    AlienX's Avatar
    Join Date
    May 2012
    Location
    Rawalpindi
    Posts
    76
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Heavy steering problem in Vitz (2005)

    Found the service manuals for Vitz 2007. There is a section on heavy steering and possible causes.

    So far, I have been to three different workshops and none of them touched even single one of causes mentioned in service manual. This tells the extent of knowledge of local workshops (mostly) is guess work.

    Sent from my iPad using Tapatalk

  3. #3
    PakWheeler Follow
    Mubashir4's Avatar
    Join Date
    Oct 2011
    Location
    Quetta
    Posts
    27
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    2
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I Think Vitz didnt have Power Steering Fluid, if it has then once check the Fluid, if it doesn't work then check the EPS Electronic Power Steering System.

  4. #4
    PakWheeler Follow
    AlienX's Avatar
    Join Date
    May 2012
    Location
    Rawalpindi
    Posts
    76
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by Mubashir4 View Post
    I Think Vitz didnt have Power Steering Fluid, if it has then once check the Fluid, if it doesn't work then check the EPS Electronic Power Steering System.
    Yes it has EPS. Had the zero point calibration, torque speed sensor, and voltages checked on my way back today. It has improved so far but still in learning mode. So will see if it returns to normal in a day or two. Otherwise I'll go to toyota dealership.

  5. #5
    Senior PakWheeler Follow
    SER_GTR's Avatar
    Join Date
    Nov 2005
    Location
    Karachi
    Age
    30
    Posts
    9,737
    Follows
    16
    Following
    0
    Mentioned
    489 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    3

    Default

    Put It On Scanners Like AUTEL
    TOYOTA Sprinter 86- AE80 DOHC 20v'D TOYOTA Corolla 98- AE101 4AFE 16v

  6. #6
    PakWheeler Follow
    AlienX's Avatar
    Join Date
    May 2012
    Location
    Rawalpindi
    Posts
    76
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The problem was rectified after zero point calibration. Must be some glitch.

    Secondly car was pulling. So I let it go free in neutral and after about 200m it got free and better ever since.

  7. #7
    PakWheeler Follow
    edrahool's Avatar
    Join Date
    Feb 2008
    Location
    Rawalpindi
    Age
    32
    Posts
    466
    Follows
    0
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by AlienX View Post
    Yes it has EPS. Had the zero point calibration, torque speed sensor, and voltages checked on my way back today. It has improved so far but still in learning mode. So will see if it returns to normal in a day or two. Otherwise I'll go to toyota dealership.
    From where you have get these checked and done ?

  8. #8
    PakWheeler Follow
    edrahool's Avatar
    Join Date
    Feb 2008
    Location
    Rawalpindi
    Age
    32
    Posts
    466
    Follows
    0
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I want to get my power steering checked for my passo.

    I also feel it is heavy some times.

  9. #9
    PakWheeler Follow
    AlienX's Avatar
    Join Date
    May 2012
    Location
    Rawalpindi
    Posts
    76
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by edrahool View Post
    I want to get my power steering checked for my passo.

    I also feel it is heavy some times.
    I had it checked from saddar. There is a workshop in front of kamran Market. Beside hotel entrance, go straight and you will enter a workshop. Ask for Shahzaib Electrition.

  10. #10
    PakWheeler Follow
    edrahool's Avatar
    Join Date
    Feb 2008
    Location
    Rawalpindi
    Age
    32
    Posts
    466
    Follows
    0
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by AlienX View Post
    I had it checked from saddar. There is a workshop in front of kamran Market. Beside hotel entrance, go straight and you will enter a workshop. Ask for Shahzaib Electrition.
    Ok thanks how much charges did they take?

  11. #11
    PakWheeler Follow
    AlienX's Avatar
    Join Date
    May 2012
    Location
    Rawalpindi
    Posts
    76
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by edrahool View Post
    Ok thanks how much charges did they take?
    Yar get your problem solved. Don't worry about charges. They do not over-charge, that's for sure.

  12. #12
    PakWheeler Follow
    edrahool's Avatar
    Join Date
    Feb 2008
    Location
    Rawalpindi
    Age
    32
    Posts
    466
    Follows
    0
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by AlienX View Post
    Yar get your problem solved. Don't worry about charges. They do not over-charge, that's for sure.
    Ok thanks

  13. #13
    Senior PakWheeler Follow
    tintin1's Avatar
    Join Date
    Jan 2014
    Location
    Lahore
    Posts
    1,842
    Follows
    8
    Following
    2
    Mentioned
    61 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    7
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    5

    Default

    If its steering rack has electric motor, then perhaps its connection is lost or some bad fuse.
    An experienced electrician can check and confirm this.
    Be Addicted To Help Others.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •