Survey by Qualaroo
+ Reply to Thread
Results 1 to 20 of 20

Thread: Vitz Radiator Fan Not Working

  1. #1
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Vitz Radiator Fan Not Working

    Last night, I was driving my vitz with "AC" and all of a sudden it stopped in the middle of the road and refused to start again (was not taking the 'self' at all, though all electricals were working fine, ruling out any battery issue). I checked the radiator water and it was half empty; so refilled it and waited for 1-2 mins and the car started again without any problem.One problem I did notice prior to car getting stopped ( though ignored it) was that ac compressor was turning off frequently especially when car was moving at slower speed.
    After refilling, I then continued my drive on ac and after 10-15 mins, overheat (red light) started blinking.I switched off the ac and overheat light disappeared immediately. I then took the car back to home (8-9 kms away from that point) without ac and the overheat light did not appear again.I checked the radiator water and it was almost 400 ml less.

    I then tried to figure out the root cause and apparently radiator fan is not working at all This could be loose Electrician connection, faulty fuse or faulty thermostat valve.
    Couldn't find any auto Electrician due to eid, so crossing my figures about the cause of this problem.Can someone throw light on the following :

    1).Any expert opinions about the cause of fan not working?

    2), Any chances that my engine or head gaskit got damaged due to this car overheat?

    3) Any other damage that it might have caused?


  2. #2
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Any expert opinions???

    Sent from my C6603 using PW Forums mobile app

  3. #3
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,962
    Follows
    5
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    Could be anything.

    Thermostat
    Bad fuse
    Bad motor

    Is the fan working with a/c ?

    Since vitz uses 1 fan for both.

    Ps: just a advice when ever your car overheats the ac is bound to get off. When ever this happens be sure to check the red light.

    Since vitz doesn't has a gauge. Eyesight hardly goes to see through red light blinking
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  4. #4
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by chinyoti View Post
    Could be anything.

    Thermostat
    Bad fuse
    Bad motor

    Is the fan working with a/c ?

    Since vitz uses 1 fan for both.

    Ps: just a advice when ever your car overheats the ac is bound to get off. When ever this happens be sure to check the red light.

    Since vitz doesn't has a gauge. Eyesight hardly goes to see through red light blinking
    Any comments on point 2 and 3?

    Sent from my C6603 using PW Forums mobile app

  5. #5
    Senior PakWheeler Follow
    chinyoti's Avatar
    Join Date
    Sep 2005
    Location
    Karachi
    Age
    27
    Posts
    11,962
    Follows
    5
    Following
    0
    Mentioned
    108 Post(s)
    Tagged
    5 Thread(s)
    Problems Posted
    2
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by vitz_2006 View Post
    Any comments on point 2 and 3?

    Sent from my C6603 using PW Forums mobile app
    Since you said the car turned off. Their are chances that the gasket got blown. But few chances it didn't happen. Can't tell anything without inspection
    Get over the fact that Xli lacks power windows, Its an Xli because it lacks thoose features or else it would be a Gli or an Altis if had all the goodies.

  6. #6
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I will get it checked tomorrow, however, for worst case scenario:
    1). How much does head gaskit cost (new and Kabli)?

    2). Is it a routine job for mechanics or does it require great skill?

    3).Does head gaskit go a long way, as I have read a few posts suggesting that head gaskit replacement is not very successful in vitz?

    Sent from my C6603 using PW Forums mobile app

  7. #7
    Senior PakWheeler Follow
    kkoool's Avatar
    Join Date
    Apr 2005
    Location
    Islamabad
    Age
    35
    Posts
    1,661
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    For a vitz none, I repeat none, will be able to install a new gaskit with 0 errors.
    Thats one high compression engine and our mechanics dont even know anything about repairing it.



    Sent from my SM-A710F using Tapatalk
    AE 86

  8. #8
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by kkoool View Post
    For a vitz none, I repeat none, will be able to install a new gaskit with 0 errors.
    Thats one high compression engine and our mechanics dont even know anything about repairing it.



    Sent from my SM-A710F using Tapatalk
    Not even toyota dealership guys?
    If not. what's the solution then in case head gaskit needs replacement?

    Sent from my C6603 using PW Forums mobile app

  9. #9
    Senior PakWheeler Follow
    kkoool's Avatar
    Join Date
    Apr 2005
    Location
    Islamabad
    Age
    35
    Posts
    1,661
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    First you need to rectify the issue.
    Is your radiator choked as well or not.?
    Did you perform compression test?
    Any colored smoke from exhaust ?
    Is your car the notorious(in terms of repair) but great performing 2SZ or a 1KR ?



    Sent from my SM-A710F using Tapatalk
    AE 86

  10. #10
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Compression test done last month with all dry values above 230.Wet values were also fine No blue smoke.Engine water decarbonization done last month without any issues
    As of today, no repair has been done (except routine maintenance) with 110k on the meter

    Sent from my C6603 using PW Forums mobile app

  11. #11
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Radiator service never done, so I guess it needs some attention?

    Sent from my C6603 using PW Forums mobile app

  12. #12
    Senior PakWheeler Follow
    kkoool's Avatar
    Join Date
    Apr 2005
    Location
    Islamabad
    Age
    35
    Posts
    1,661
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Quote Originally Posted by vitz_2006 View Post
    Radiator service never done, so I guess it needs some attention?

    Sent from my C6603 using PW Forums mobile app
    And that is the answer to your problems if you had been running regular water in radiator. Also change the radiator cap if you see any wear on it.

    Sent from my SM-A710F using Tapatalk
    AE 86

  13. #13
    PakWheeler Follow
    arsalannn's Avatar
    Join Date
    Aug 2006
    Location
    Karachi
    Age
    28
    Posts
    387
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    fill radiator and start your engine.. if there are bubbles in the water, you have a blown gasket. that's the easiest and most typical way to find out a blown gasket.

    Sent from my SAMSUNG-SM-G850A using PW Forums mobile app
    yes!!!

  14. #14
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I use toyota long life coolant and the car got overheated due to problem with radiator fan.
    My original question actually was(which is still somewhat unanswered) "whether this one time overheat and car turning off issue (because of overheat) could have caused any damage to my car engine etc.... apart from possible damage to head gaskit?"

    Sent from my C6603 using PW Forums mobile app

  15. #15
    PakWheeler Follow
    waleed96's Avatar
    Join Date
    May 2014
    Location
    Karachi
    Age
    20
    Posts
    334
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    1
    Good Answers
    2

    Default

    Quote Originally Posted by vitz_2006 View Post
    I use toyota long life coolant and the car got overheated due to problem with radiator fan.
    My original question actually was(which is still somewhat unanswered) "whether this one time overheat and car turning off issue (because of overheat) could have caused any damage to my car engine etc.... apart from possible damage to head gaskit?"

    Sent from my C6603 using PW Forums mobile app
    Your water pump/body could leak. (Check for coolant leaking underneath the car and check for coolant level reduction.)

    Cracked engine head.
    Symptoms: Loss of power, coolant level reduction. (Check your oil cap if there is milky/chocolaty goey substance under it.) Reference picture attached.
    Attached Images Attached Images  

  16. #16
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Culprit was faulty radiator fan motor.Got it replaced with a 'Kabli' one as New genuine was for 4800/-.

    Also got radiator serviced and head gaskit checked. Head gaskit is apparently fine as per mechanic(will get it checked once again)
    So far everything working fine.
    Any precautions to be taken?
    Any 'self checks' to ensure head gaskit is fine?

    Sent from my C6603 using PW Forums mobile app

  17. #17
    Senior PakWheeler Follow
    Scorpion1983's Avatar
    Join Date
    May 2009
    Location
    Islamabad
    Age
    33
    Posts
    1,018
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The engine shutdown was for prevention of overheat and damage. So your gasket should be fine. Per me experience these cars shutdown when overheat is noticed. Don't worry.
    Lucky guy.... Allah is the gratest.....Seat belt saves life...

  18. #18
    PakWheeler Follow
    arsalannn's Avatar
    Join Date
    Aug 2006
    Location
    Karachi
    Age
    28
    Posts
    387
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by vitz_2006 View Post
    Culprit was faulty radiator fan motor.Got it replaced with a 'Kabli' one as New genuine was for 4800/-.

    Also got radiator serviced and head gaskit checked. Head gaskit is apparently fine as per mechanic(will get it checked once again)
    So far everything working fine.
    Any precautions to be taken?
    Any 'self checks' to ensure head gaskit is fine?

    Sent from my C6603 using PW Forums mobile app
    open radiator cap and start your engine.. if there are bubbles in the water, you have a blown gasket. that's the easiest and most typical way to find out a blown gasket.

    Sent from my SAMSUNG-SM-G850A using PW Forums mobile app
    yes!!!

  19. #19
    PakWheeler Follow
    vitz_2006's Avatar
    Join Date
    Jul 2012
    Location
    Lahore
    Posts
    108
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by arsalannn View Post
    open radiator cap and start your engine.. if there are bubbles in the water, you have a blown gasket. that's the easiest and most typical way to find out a blown gasket.

    Sent from my SAMSUNG-SM-G850A using PW Forums mobile app
    And what the other key symptoms of blown head gas besides bubbles?

    Sent from my C6603 using PW Forums mobile app

  20. #20
    PakWheeler Follow
    arsalannn's Avatar
    Join Date
    Aug 2006
    Location
    Karachi
    Age
    28
    Posts
    387
    Follows
    0
    Following
    0
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by vitz_2006 View Post
    And what the other key symptoms of blown head gas besides bubbles?

    Sent from my C6603 using PW Forums mobile app
    this is the only symptom i guess.. i had an alto with a blown gasket.. when my mechanic initially told me that its blown. i went to several other mechanics to be sure.. all checked the same way..

    Sent from my SAMSUNG-SM-G850A using PW Forums mobile app
    yes!!!

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •