Survey by Qualaroo
+ Reply to Thread
Page 3 of 3 FirstFirst 123
Results 41 to 52 of 52
Like Tree2Likes

Thread: ELM OBD2 Portable device compatibility with vitz 2008

  1. #1
    PakWheeler Follow
    deathstroke51432's Avatar
    Join Date
    Apr 2016
    Location
    N/A
    Age
    25
    Posts
    20
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default ELM OBD2 Portable device compatibility with vitz 2008

    I bought one ELM OBD2 Portable device and tried to use it using Torque pro app. What I dont understand is that it gives the problem of " unable to connect to ECU". So I want to ask, does it work with vitz 2008 and if yes, any help would be appreciated and will be grateful
    Regards

    Sent from my D6633 using PW Forums mobile app

  2. #41
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by rkbladex View Post
    Is it possible to adjust idle RPM from 730 to 800 range? I also notice when i engage gear to D or R my battery voltage has been drop from around 13.7 to 12.2 voltage. How can i do reset to the factory settings?

    - RKBladeX
    did you try the idle learn procedure ? (use the search on this forum)

    does the battery voltage stay at 12.2 when driving the car ?

  3. #42
    PakWheeler Follow
    rkbladex's Avatar
    Join Date
    Nov 2014
    Location
    Karachi
    Posts
    189
    Follows
    0
    Following
    1
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by spiderman-17 View Post
    did you try the idle learn procedure ? (use the search on this forum)

    does the battery voltage stay at 12.2 when driving the car ?
    Nope. I didn't try the idle learn procedure. Are you referring following procedure?

    ELM OBD2 Portable device compatibility with vitz 2008 -1727641

    I didn't notice during driving a car. Will check today.

    - RKBladeX
    If you found my response helpful!!. Don't forget to press like button

  4. #43
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by rkbladex View Post
    Nope. I didn't try the idle learn procedure. Are you referring following procedure?

    ELM OBD2 Portable device compatibility with vitz 2008 -1727641

    I didn't notice during driving a car. Will check today.

    - RKBladeX
    Yes, disconnect the battery for 2 or more minutes first

  5. #44
    PakWheeler Follow
    rkbladex's Avatar
    Join Date
    Nov 2014
    Location
    Karachi
    Posts
    189
    Follows
    0
    Following
    1
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by rkbladex View Post
    Nope. I didn't try the idle learn procedure. Are you referring following procedure?

    ELM OBD2 Portable device compatibility with vitz 2008 -1727641

    I didn't notice during driving a car. Will check today.

    - RKBladeX
    Quote Originally Posted by spiderman-17 View Post
    Yes, disconnect the battery for 2 or more minutes first
    Yesterday when i am going from office to my Home my car battery is dead and unable to start a self this is the first time happened in my car so when i connect OBD2 with torque pro it shows 9.6V when key is on position so i search electrician in nearby place at my office and jump start the car and idle for few secs and battery person says your battery is weak i don't know how much true is that. During driving voltage don't stay on 12.2 volts it change from 13.2 to 13.8 in gear D and R. I don't do idle relearn procedure will do it on weekend. One question is it possible RPM fluctuate due to weak battery?

    - RKBladeX
    If you found my response helpful!!. Don't forget to press like button

  6. #45
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by rkbladex View Post
    Yesterday when i am going from office to my Home my car battery is dead and unable to start a self this is the first time happened in my car so when i connect OBD2 with torque pro it shows 9.6V when key is on position so i search electrician in nearby place at my office and jump start the car and idle for few secs and battery person says your battery is weak i don't know how much true is that. During driving voltage don't stay on 12.2 volts it change from 13.2 to 13.8 in gear D and R. I don't do idle relearn procedure will do it on weekend. One question is it possible RPM fluctuate due to weak battery?

    - RKBladeX
    If your obd adapter is left connected to the car while you are away it will drain your battery if obd adapter dont have sleep mode. It could be the adapter draining the battery.

    Yes a weak battery will fluctuate idle the 13+ volts you see when driving is coming from alternator

    A car electrician can test the battery while engine is off with an appropiate discharge amp meter

  7. #46
    PakWheeler Follow
    mfarhansabir's Avatar
    Join Date
    Sep 2012
    Location
    Lahore
    Posts
    843
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Double Post. See below.

  8. #47
    PakWheeler Follow
    mfarhansabir's Avatar
    Join Date
    Sep 2012
    Location
    Lahore
    Posts
    843
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by rkbladex View Post
    I found 2 extended PIDs when searching on internet on other forum. I hope it will also work on Toyota Vitz 1KR-FE Engine. Sharing on pw so other members can also get benfits from. Note: Please do it on your own risk.

    Reference: OFFICIAL Torque Android app PID/Misc Thread - Scion FR-S Forum | Subaru BRZ Forum | Toyota 86 GT 86 Forum | AS1 Forum - FT86CLUB

    Oil Temperature PID credit to andreyiv:

    OBD2 Mode and PID: 2101
    Minimum Value: -40
    Maximum Value: 215 (this is just the maximum that this location can support, which does not mean the sensor can read that high)
    Scale factor: x1
    Unit type: C
    Equation: AC-40 (no space between A and C; "AC" is the location within the response)
    OBD Header: 7E0 (Auto also works, but seems to take longer)
    PID setup for VERY accurate fuel remaining credit to developer:

    Fuel Remain Originally Posted by developer
    It seems to be much more accurate than the default fuel percentage that is in Torque.
    PID: 2129
    Long name: Fuel Remain (or whatever you want)
    Short name: Fuel Remain (or whatever you want)
    Minimum Value: 0.0
    Maximum Value: 100.0
    scale: x1
    Unit: Gal
    Equation: ((A*13.2)/100)
    OBD Header: 7c0

    If you want the fuel remaining in Liters:
    Unit: L
    Equation: ((A*50)/100)


    - RKBladeX

    i have tried the fuel remaining PID in Vitz 09 1KR-FE but it doens't seem to work. the rest of PIDs given by you (battery voltage, rpm, vehicle speed, coolant temperature) below work like a charm.

  9. #48
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by mfarhansabir View Post
    i have tried the fuel remaining PID in Vitz 09 1KR-FE but it doens't seem to work. the rest of PIDs given by you (battery voltage, rpm, vehicle speed, coolant temperature) below work like a charm.
    I believe it was me that posted the pids that worked like a charm (battery voltage, rpm, vehicle speed, coolant temperature) + 2 others

    but I may be wrong!!

  10. #49
    PakWheeler Follow
    rkbladex's Avatar
    Join Date
    Nov 2014
    Location
    Karachi
    Posts
    189
    Follows
    0
    Following
    1
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by mfarhansabir View Post
    i have tried the fuel remaining PID in Vitz 09 1KR-FE but it doens't seem to work. the rest of PIDs given by you (battery voltage, rpm, vehicle speed, coolant temperature) below work like a charm.
    It is @spiderman-17 who gave the pids of Toyota Vitz 2009. Thanks to him. He share the pids in PW Forum so other members can benefits from including me.

    - RKBladeX
    If you found my response helpful!!. Don't forget to press like button

  11. #50
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    @rkbladex

    please delete the two pids you posted (they are not for the vitz)

  12. #51
    PakWheeler Follow
    mfarhansabir's Avatar
    Join Date
    Sep 2012
    Location
    Lahore
    Posts
    843
    Follows
    0
    Following
    0
    Mentioned
    11 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by spiderman-17 View Post
    I believe it was me that posted the pids that worked like a charm (battery voltage, rpm, vehicle speed, coolant temperature) + 2 others

    but I may be wrong!!
    Spiderman-17 really sorry about that. Indeed you posted those. Forgot to mention you. However i hope that you'll look over my mistake and keep posting good stuff for our guidance



    Sent from my LG-D858HK using Tapatalk

  13. #52
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by mfarhansabir View Post
    Spiderman-17 really sorry about that. Indeed you posted those. Forgot to mention you. However i hope that you'll look over my mistake and keep posting good stuff for our guidance



    Sent from my LG-D858HK using Tapatalk

+ Reply to Thread
Page 3 of 3 FirstFirst 123

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •