Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By mdaniyal

Thread: Vitz 2013 Self start issue

  1. #1
    PakWheeler Follow
    mdaniyal's Avatar
    Join Date
    May 2016
    Posts
    24
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default Vitz 2013 Self start issue

    A month ago i buy Vitz 2013. car was parked for 13 days and never started during this time.
    Today i try to start the car but didn't engaged the self, somehow i manage to arrange the alternate battery and car was started...so i kept started 2 hours.
    Later on after 1 hour i try to start again but the face same issue as before and again didn't pick the self.
    Please let me know that i have to replace the battery or is it battery charging issue.

    Your expert opinion is awaited

  2. #2
    Senior PakWheeler Follow
    us000's Avatar
    Join Date
    Aug 2006
    Location
    Islamabad
    Age
    28
    Posts
    1,519
    Follows
    4
    Following
    0
    Mentioned
    73 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    1
    Good Answers
    1

    Default

    most probably it is the battery issue,

    some electronics in the car stay ON all the time, (consumes very less power)
    but if your battery was old, and car was consuming some amount of energy for 13 days, so battery might gone completely dead.

    if the battery is liquid based, then check the water level.
    and if you dont have any idea about batteries, then goto some battery shop and get your battery checked.
    jiyo aur jeenay do

  3. #3
    Senior PakWheeler Follow
    DUDE007's Avatar
    Join Date
    Oct 2011
    Location
    Lahore
    Posts
    2,033
    Follows
    0
    Following
    2
    Mentioned
    104 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Check crank voltage. It shouldn't go below 10.5 volts.

    Check gravity of cells when battery is charged.

    Btw does the car crank slower on every progressive turn when started after 1 hour?

    Enviado desde mi GT-I9500 usando Tapatalk

  4. #4
    PakWheeler Follow
    mdaniyal's Avatar
    Join Date
    May 2016
    Posts
    24
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    I call an electrician who checked every possible cause, that might be happening of battery discharging. But didn't find anything abnormal in generator voltage nor short-circuit. So he said that the battery is dead and need to be replace.
    Finally i go for AGS.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •