Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: Whistle sound when AC on

  1. #1
    PakWheeler Follow
    qasimi3882's Avatar
    Join Date
    Oct 2013
    Location
    Lahore
    Age
    30
    Posts
    29
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Whistle sound when AC on

    When ever I turned on AC in my vitz 1000cc 2007, and then accelrate there is whistle sound.

    One more thing today I struck in thunderstorm,2 things happended

    -some water leaked on my foot (driver side)
    - battery light on and some strange sound from car front, after some time sound and light also goes off


  2. #2
    Senior PakWheeler Follow
    ahmed2396's Avatar
    Join Date
    Dec 2011
    Age
    36
    Posts
    2,330
    Follows
    5
    Following
    1
    Mentioned
    55 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    2
    Good Answers
    7

    Default

    That shows your AC system is low on refrigerant get it topped up


    Sent from my iPhone 6s using PW Forums
    Your ego is writing cheques, your body can't cash.

  3. #3
    PakWheeler Follow
    FaatehRehman's Avatar
    Join Date
    Apr 2010
    Location
    Rawalpindi
    Age
    25
    Posts
    222
    Follows
    0
    Following
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    4
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    2

    Default

    With engine running and AC on, put some drops on water on the belt; if the whistling noise subsides then there is a problem with your belt. Either the belt is weak or tensioner needs adjustment. Mud on the belt or pulleys is also a cuase of this noise.

    You can apply grease to temporarily rectify the issue.

    If the noise does not subsides then it is probably the bearing of your AC compressor.

  4. #4
    PakWheeler Follow
    m_umairr's Avatar
    Join Date
    Sep 2011
    Location
    Islamabad
    Posts
    168
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    5
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Belt is loose through AC pulley, tighten it a bit and also grease it a little.. will go away..
    I had same issue.. it's resolved now!

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •