Survey by Qualaroo
+ Reply to Thread
Results 1 to 4 of 4

Thread: 2013 vitz burning smell.

  1. #1
    PakWheeler Follow
    sanaan.zia's Avatar
    Join Date
    Aug 2012
    Location
    Peshawar
    Posts
    129
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default 2013 vitz burning smell.

    hey guys aoa.
    my brother owns a 2013 vitz and since he bought it i.e a few months back whenever we accelerate heavily it starts to smell like something is burning once the cvt is is action, i read about this in a few places, it said that this might be due to old cvt oil and the cvt oil should be changed after 40000kms ,since we bought the car at 45000kms I decided to change the oil, once we got the old oil out the mechanic said it was clean but I still changed it because I really hated this problem (the mechanic told me this smell is not related to the cvt oil),after the oil change I was very happy that theres no longer going to be that smell , I put the car under heavy acceleration and for a while I actually thought the smell has disappeared but right at that time the smell had started again, can you guys please help me what the cause of this can be as its very annoying and might be causing some serious damage to the car. thanks in advance(Y)
    w115 1jzgte non vvti

  2. #2
    PakWheeler Follow
    usmanhaider's Avatar
    Join Date
    May 2005
    Location
    Lahore
    Age
    30
    Posts
    71
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have the exact same issue in my car, vitz 2010

  3. #3
    Senior PakWheeler Follow
    kkoool's Avatar
    Join Date
    Apr 2005
    Location
    Islamabad
    Age
    35
    Posts
    1,661
    Follows
    2
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1

    Default

    Looks like your transmission is overheating and causing the components near it to generate the smell.
    Which oil did u use, CVT or CVT TC ?
    And BTW 1000cc is obnoxious for burning gearboxes. Drive easy

    Sent from my HTC D628h using PW Forums mobile app
    AE 86

  4. #4
    PakWheeler Follow
    sanaan.zia's Avatar
    Join Date
    Aug 2012
    Location
    Peshawar
    Posts
    129
    Follows
    0
    Following
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I used Toyotas cvt oil that every one had been recommending on pakwheels,and its not about driving hard the thing is when the car is loaded it wont gain speed so you need to press on the throttle haha
    w115 1jzgte non vvti

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •