Survey by Qualaroo
+ Reply to Thread
Results 1 to 20 of 20

Thread: Knocking sound

  1. #1
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Knocking sound

    Asalam o Alekum
    A new sound of knocking appears in my vitz 2nd generation with 1 kr 1000cc engine
    Sound starts obove 30 kmph speed as gear is shifted to bigger one.. (Auto Transmission) sound is like driving slow on higher gears.
    But it is disappeared if I accelerate more or reduce the acceleration.
    There is no knocking sound if I drive car on S gear.
    I have tried mixture of hobc or 100% hobc but no effect.
    Kindly guide me what should I check.


  2. #2
    PakWheeler Follow
    rajaatta's Avatar
    Join Date
    Apr 2014
    Posts
    682
    Follows
    4
    Following
    12
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by walls View Post
    Asalam o Alekum
    A new sound of knocking appears in my vitz 2nd generation with 1 kr 1000cc engine
    Sound starts obove 30 kmph speed as gear is shifted to bigger one.. (Auto Transmission) sound is like driving slow on higher gears.
    But it is disappeared if I accelerate more or reduce the acceleration.
    There is no knocking sound if I drive car on S gear.
    I have tried mixture of hobc or 100% hobc but no effect.
    Kindly guide me what should I check.
    W/salam.
    Time to change the oxyhen sensor with a brand new one. And also get the intake manifold and intake ports serviced and you are good to go. Don't waste your time on hit and try methods thats your only solution.

  3. #3
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Oh thats the reason
    Few days back I notice smell from silencer like un burn fuel..
    It was also related to this problem?
    And what it will cost?
    Servicing the sensor may resolve the problem?

  4. #4
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    But there is no engine check light indication so far..

  5. #5
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I removed the top sensor and bottom sensor switch out.. no check engine light appear.. car drive was so powerful but with same knocking..
    Then I switched both sensor again.. Knocking sound is reduced. Not disappear yet.. will get it checked from some good mechanics for sensor replace or service

  6. #6
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by walls View Post
    I removed the top sensor and bottom sensor switch out.. no check engine light appear.. car drive was so powerful but with same knocking..
    Then I switched both sensor again.. Knocking sound is reduced. Not disappear yet.. will get it checked from some good mechanics for sensor replace or service
    Hi,

    Does both of your top and bottom o2 sensors have 3 wires?

  7. #7
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Top sensor having 4 wires and bottom sensor switch having 2 wires

  8. #8
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Update.
    Today O2 sensor checked through meter and found ok.

  9. #9
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by walls View Post
    Update.
    Today O2 sensor checked through meter and found ok.
    What were the readings? Were they flactuting between 0.1v to 0.9v? If so, it was correct

  10. #10
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Name:  1477161682471.jpg
Views: 73
Size:  39.1 KB

    Cold engine reading

  11. #11
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    On car start reading was increased about 86
    And on car engine switched off reading was near 42.

    Sent from my GT-I9192 using PW Forums mobile app

  12. #12
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I have also made video of this checking process.. but video upload nahi ho pa rahi

    Sent from my GT-I9192 using PW Forums mobile app

  13. #13
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by walls View Post
    On car start reading was increased about 86
    And on car engine switched off reading was near 42.

    Sent from my GT-I9192 using PW Forums mobile app
    What are 86 and 42 ?

    To know if an o2 is doing its job correcly (because it is a crucial sensor for the engine performance) you should connect it to an obd scanner

    A good pre cat o2 should vary fast between 0.1v and 0.9v whilst driving in normal conditions

  14. #14
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Name:  1477166117743.jpg
Views: 63
Size:  39.1 KB

    Readings were like this as shown in picture
    I will get it scanned on Monday

    Reading on obd scanner must be as you have mentioned?

  15. #15
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by walls View Post
    Reading on obd scanner must be as you have mentioned?
    Yes, vary the engine RPM between idle and 2500rpm simulating like driving the car normally

    The post cat o2 shold be stable between 0.4v and 0.9v indicating the cat is working correcly,

    If it varies up and down like the pre cat, that means the cat is not doing its job

    Engine must be hot or you wont get any readings from post cat o2 because it is not heated (2 wire)

  16. #16
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by spiderman-17 View Post
    Yes, vary the engine RPM between idle and 2500rpm simulating like driving the car normally

    The post cat o2 shold be stable between 0.4v and 0.7v indicating the cat is working correcly,

    If it varies up and down like the pre cat, that means the cat is not doing its job

    Engine must be hot or you wont get any readings from post cat o2 because it is not heated (2 wire)
    Ok
    Will update the readings after obd scan. O2 sensor also shows catlytic convertor performance?

  17. #17
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by walls View Post
    Ok
    O2 sensor also shows catlytic convertor performance?
    Sure, thats why there is the post cat o2 in your car, if both the o2 sensors read the same reading (both going up and down) , that means the cat is doing nothing

    Also the cat needs to be very hot to do its job, that why it has a metal cover around him (to keep it very hot)

    If the catalytic converter is functioning correctly there will be very few oxygen content in the exaust as carbon monoxide and carbon dioxide is catalyzed in the converter.

  18. #18
    Senior PakWheeler Follow
    DUDE007's Avatar
    Join Date
    Oct 2011
    Location
    Lahore
    Posts
    2,034
    Follows
    0
    Following
    2
    Mentioned
    104 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @spiderman-17 is there an EGR valve in vitz? Can you please share it's exact location and also the location of PCV valve. I want to clean them.

    Enviado desde mi GT-I9500 usando Tapatalk

  19. #19
    PakWheeler Follow
    spiderman-17's Avatar
    Join Date
    Jun 2016
    Posts
    106
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Quote Originally Posted by walls View Post
    Ok
    Will update the readings after obd scan. O2 sensor also shows catlytic convertor performance?
    @walls I Did a small video of what can be monitored (did not include abs and airbags data) while driving a vitz 2009 this morning, note how o2 works when engine is not in optimal temperature, but unfortunately i found a lot of traffic so the throttle was most of the time 0%

    The screens are transmitted wirelessly to a pioneer head unit from my android mobile phone,

    https://drive.google.com/file/d/0BxD...w?usp=drivesdk

    @DUDE007
    Yes it has both but i dont have the car at the moment so cannot send you pics

    The egr works if the car meet a specific condition, you can see it in video above

    The pcv is the first thing to clean if your engine is consuming too much oil before you do compression tests etc.

  20. #20
    PakWheeler Follow
    walls's Avatar
    Join Date
    Feb 2010
    Location
    Lahore
    Age
    30
    Posts
    215
    Follows
    0
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by spiderman-17 View Post
    @walls I Did a small video of what can be monitored (did not include abs and airbags data) while driving a vitz 2009 this morning, note how o2 works when engine is not in optimal temperature, but unfortunately i found a lot of traffic so the throttle was most of the time 0%

    The screens are transmitted wirelessly to a pioneer head unit from my android mobile phone,

    https://drive.google.com/file/d/0BxD...w?usp=drivesdk

    @DUDE007
    Yes it has both but i dont have the car at the moment so cannot send you pics

    The egr works if the car meet a specific condition, you can see it in video above

    The pcv is the first thing to clean if your engine is consuming too much oil before you do compression tests etc.
    That's very informative video.
    Thanks for sharing.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •