Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 22 of 22

Thread: Yaris petrol problem. HELP needed

  1. #1
    PakWheeler Follow
    roxicator's Avatar
    Join Date
    Aug 2006
    Location
    Rawalpindi
    Age
    33
    Posts
    27
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Yaris petrol problem. HELP needed

    Hi guys,
    I wanted some help regarding a problem in my yaris. I have a yaris 2002 manual with cng. Its awesome runs great on CNG, excellent performance with good consumption. (Thanks alta for this great car. Got it from your contact here in pindi) Ran outstanding on petrol but recently a problem has developed. When i start it on petrol and when just after starting the rpm is low, the techometer goes to 0 and the car starts to vibrate. The rpm is almost 0 and the car does not respond to the accelerator for about 6-7 seconds. It keeps on vibrating on almost 0 rpm even if i keep the accelerator pressed. Then after about 6-7 seconds, it gets ok. This is currently happening right after starting. Runs fine after that. I thought that maybe petrol and gas are getting mixed so I got it checked by removing all CNG equipment, all CNG pipes, emulator advancer etc, got throttle body serviced but it was still happening. The guy said that he has seen this problem in many vitz and platz and its either the injector or the fuel pump. Any help guys?? Storm and friends!!!
    I feel the need...The need for speed...

  2. #21
    PakWheeler Follow
    roxicator's Avatar
    Join Date
    Aug 2006
    Location
    Rawalpindi
    Age
    33
    Posts
    27
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    ok fit. Ye to aala scene hai agar exact problem code pata chal jaata hai ke kia cheez problem kar rahi hai. Waisay the light goes on when the sensor malfunctions right????
    I feel the need...The need for speed...

  3. #22
    PakWheeler Follow
    Deloy's Avatar
    Join Date
    Apr 2006
    Location
    Karachi
    Age
    41
    Posts
    203
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Engine malfunction code lights comes on when you have an error detected by diagnostics computer, it will know where the error is and will give you error code when OBD scanner is hooked on the system, so faulty part will be isolated and replaced.

    Deloy

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •