Survey by Qualaroo
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Thread: Expert help on Vitz '99

  1. #1
    PakWheeler Follow
    amoizp's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    37
    Posts
    110
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Expert help on Vitz '99

    Salams to all. Wish I had found this forum earlier! Have been a vitz '99 (silver, a/t, no cng) owner for about a year and over all it's been a great experience and very good value for the money!

    Except for a minor issue that started about 3 months ago. And that's what I was searching on when I found PW.COM.

    So here goes...

    Some times, when accelerating from dead stop (e.g. at a signal) the car wouldn't respond. It would go max to 5kmh for 2-3 seconds... during this time if I press the pedal more, the car sort of starts choking... and after 2-3 seconds everything is back to normal. Once it starts accelerating, it runs as good as anything and nobody can say there's something wrong with the car!!

    Now this problem used to occur very rarely. It was more noticeable when there was some load (e.g. a/c was on, more than 2 ppl were sitting or car was on a climbing road).

    During the past 3 months, since I first noticed this, the problem has slowly become more and more noticeable. Now everytime I start from a dead stop on a slightly climbing road, I see the 2-3 second lag in response. Even the choking has now become so severe that during this time the brakes become hard (maybe enough power is not being produced).

    I have already changed the spark plugs and gotten the throttle body cleaned up (don't know if the mechanic did it correctly). The "engine check" light is also normal - doesn't light up after the car is started. According to the silencer guy and a mechanic, the problem is not with the cat converter either. Now I have to leave the car with the mechanic as he'll clean up the sensor (probably the O2 sensor on the air intake) and see if it solves the problem. Otherwise he says that sensor will need to be replaced.

    Any suggestions?

    Plus, now that I think of it, it seems the most significant degradation came after the last service/wash done. Also, there is a very minor knocking sound that has developed along with this problem. Have tried hi octane too but even that doesn't reduce the slight knocking sound.

    Will appreciate the help. Thanks.

    A. Moiz
    -

  2. #2
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,366
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    is vitz OBDII ?
    if so it can be knock sensor malfunction
    Life is short and very unpredictable just like a Quarter mile .....

  3. #3
    Senior PakWheeler Follow
    toofast's Avatar
    Join Date
    Sep 2004
    Location
    Chizhou
    Posts
    18,163
    Follows
    0
    Following
    1
    Mentioned
    31 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Fuel filter?
    Even if you are on the right track, you will get run over if you just sit there.

  4. #4
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,366
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    @toofast
    very simple and nice catch (Y)
    do check the fuel filter to.changing the fuel filter of vitz is slightly complex
    Life is short and very unpredictable just like a Quarter mile .....

  5. #5
    Senior PakWheeler Follow
    adilyaqoob's Avatar
    Join Date
    May 2004
    Location
    Select City
    Age
    32
    Posts
    4,267
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Well something similar happened to me too with my se saloon auto. It also stopped responding when i started from zero. But after i changed the fuel filter, the problem went away.
    Change the fuel filter and maybe ur problem might get solved.

  6. #6
    PakWheeler Follow
    muraza75's Avatar
    Join Date
    Oct 2005
    Location
    Rawalpindi
    Age
    41
    Posts
    24
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    If your Vitz has automatic transmision than check the oil or it is going bad.

  7. #7
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,366
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    @muraza75
    gone bad indeed
    Life is short and very unpredictable just like a Quarter mile .....

  8. #8
    jz
    jz is offline
    Senior PakWheeler Follow
    jz's Avatar
    Join Date
    Dec 2004
    Location
    Lahore
    Age
    2
    Posts
    26,106
    Follows
    5
    Following
    0
    Mentioned
    185 Post(s)
    Tagged
    12 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i hope its not on cng,cuz mostly cng cars do that
    www.facebook.com/performancepartslahore

  9. #9
    PakWheeler Follow
    amoizp's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    37
    Posts
    110
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Thanks for the replies folks! Yes, fuel filter was my guess too initially, but a couple of people told me that vitz fuel filter is built into the fuel tank and cannot be replaced. One mechanic also told me that if it was the fuel filter then following 2 problems would be visible too:

    - Problem in starting the car
    - Loss of power at high speeds

    But since these problems didn't exist, I stopped going after the fuel filter. Though I did search on the net too but couldn't find anything on fuel filter replacement for vitz.

    and how do I know about the car being OBDII?

    Thanks again,
    A. Moiz
    -

  10. #10
    Senior PakWheeler Follow
    hash4u's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    38
    Posts
    24,366
    Follows
    18
    Following
    0
    Mentioned
    404 Post(s)
    Tagged
    13 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    3
    Good Answers
    13

    Default

    go to the toyota dealer ship and get the fuel filter changed.thats what my uncle did as part of regular mantainance. instead of experimenting with complex electricals of the car why not start with the simple things first ?
    Life is short and very unpredictable just like a Quarter mile .....

  11. #11
    PakWheeler Follow
    amoizp's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    37
    Posts
    110
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Yes, will take to toyota guys for the filter replacement first. Any suggestions regarding which toyota dealership/workshop is reliable (especially for vitz work)? I've heard some scary stories about some of them.
    -

  12. #12
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Did u check the toyota in Korangi area? I think its Toyota Southern Motors............

  13. #13
    PakWheeler Follow
    emenent's Avatar
    Join Date
    Aug 2005
    Location
    Islamabad
    Age
    35
    Posts
    634
    Follows
    0
    Following
    0
    Mentioned
    9 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    spark plugs problem AFAIK, I had the same problem when i have driven the car for 20 km then car starts to behave like this i checked with teh mechanic, the plugs are worn out and one plug was getting short at hight temperature.

    gpt NGK plug fitted instead of Denso this time

  14. #14
    PakWheeler Follow
    amoizp's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    37
    Posts
    110
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Attempt at going to one dealership not successful... they were supposed to call me back for appointment time to even see the car! Still waiting...

    Will try at another dealership today. But found something else too. Might help in diagnosing the problem.

    Couple of days ago the car (yes, vitz) was parked on a steep incline (front end raised at about 35-40 degrees). In this position, the choking started after pressing the pedal slightly even with transmission in "P". If I pressed it more, the engine was smooth again!

    Even this looks like the fuel filter, right?

    A. Moiz
    -

  15. #15
    PakWheeler Follow
    amoizp's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    37
    Posts
    110
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Problem solved... another toyota dealership found that the air sensor (fitted in the air intake) was malfunctioning, so replaced it!

    Thank you everyone again for the help!
    -

  16. #16
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Which Toyota dealership did u go to?

  17. #17
    Senior PakWheeler Follow
    omaqsood's Avatar
    Join Date
    Jan 2006
    Location
    Riyadh
    Age
    38
    Posts
    1,281
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Have you taken out the catalytic converter? Is your car auto?
    Perfect Male...

  18. #18
    PakWheeler Follow
    amoizp's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    37
    Posts
    110
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    omaqsood
    No didn't remove the cat converter. Yes, car is auto trans.

    tyrone_40
    Went to toyota society (on Khalid Bin Waleed Road).

    They did a good job over all. I also got the 40k maintenance done on the car. Got almost all fluids changed and throttle body and brakes cleaned up etc.

    But be careful on changing the fluids though. Better is to buy the recommended fluids (atf, coolant, oil, etc.) yourself and take to the dealer for changing them. Some of the stuff (like atf) they have available is not recommended for vitz.
    -

  19. #19
    Site Banned Follow
    HiOctane's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    30
    Posts
    86
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Well... A. Moiz please try to check out Vaccum in ur car engine coz same thing developed in my Manual Platz with Cng .. i took to cng they just try to fix tuning , that didn't solved , actually problem found later was my car vaccum pipe was leak ... I hope Vaccum might be the problem for ur car...

  20. #20
    Senior PakWheeler Follow
    tyrone_40's Avatar
    Join Date
    Jan 2005
    Location
    Other
    Posts
    1,600
    Follows
    0
    Following
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @amoizp

    Where on khalid bin waleed road is this toyota service? If u dont mind my asking how much did you pay for all this including service?

+ Reply to Thread
Page 1 of 2 12 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •