Survey by Qualaroo
+ Reply to Thread
Page 3 of 3 FirstFirst 123
Results 41 to 43 of 43

Thread: Speed Issue in Toyota Vitz

  1. #1
    PakWheeler Follow
    softouch's Avatar
    Join Date
    Sep 2008
    Location
    Islamabad
    Age
    37
    Posts
    39
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Speed Issue in Toyota Vitz

    Hello Fyq:

    i have Vitz 2001, A/T, CNG
    i have two major issues,

    1: on motorway i can only get speed of 110 while using O/D and 125 without O/D (But it reduce the Fuel average) so i did't use it for prolong. i oftenly have to drive on M/W and this really frustrate me so please let me know what to do about this. i showed it some mechanic in Pindi he scanned on Computer and told every thing is Ok, he also Cleared the Cylensor, but still same situation.
    2: i have 55 kg cylender installed and getting 100-110 in local and 130-140 on long. how could increase the Average and what maximum it could be.

    i hope you will reply my questions.

  2. #41
    PakWheeler Follow
    Ahkhan89's Avatar
    Join Date
    Jul 2010
    Location
    Islamabad
    Posts
    86
    Follows
    8
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by softouch View Post
    Hello Fyq:

    i have Vitz 2001, A/T, CNG
    i have two major issues,

    1: on motorway i can only get speed of 110 while using O/D and 125 without O/D (But it reduce the Fuel average) so i did't use it for prolong. i oftenly have to drive on M/W and this really frustrate me so please let me know what to do about this. i showed it some mechanic in Pindi he scanned on Computer and told every thing is Ok, he also Cleared the Cylensor, but still same situation.
    2: i have 55 kg cylender installed and getting 100-110 in local and 130-140 on long. how could increase the Average and what maximum it could be.

    i hope you will reply my questions.
    bro it may b due to ur spark plugs...................!

  3. #42
    PakWheeler Follow
    Electrical_Engineer's Avatar
    Join Date
    Sep 2009
    Location
    Taxila
    Age
    34
    Posts
    21
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    your probelm could be insufficnet valve clearnace (or commonly called tight Tappet, if car has driven more than 20-30 k kms )which prevent full compression and forbade engine to develop full power at normal RPM.
    very dirty plugs and clogged air filter can also be problem
    CNG adjustment can also be a problem

  4. #43
    PakWheeler Follow
    salman2k960's Avatar
    Join Date
    Jun 2007
    Location
    Lahore
    Age
    35
    Posts
    49
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default issue resolved?

    Quote Originally Posted by usman_hafeez2000 View Post
    @mafzaltareen

    Thanks for your info. I got plugs replaced, oil & air filters changed, throttle body cleaning. Still car maximum goes to 110. And its on petrol, still this low performance what else do i need to do or tune?
    is ur problem resolved?
    if yes, kindly post the solution.

+ Reply to Thread
Page 3 of 3 FirstFirst 123

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •