Survey by Qualaroo
+ Reply to Thread
Results 1 to 7 of 7

Thread: Corolla 1973

  1. #1
    PakWheeler Follow
    alimurtaza_123's Avatar
    Join Date
    Nov 2014
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Corolla 1973

    Dear All,

    I have corolla 1973 london model, working fine and running smothly. from quite some time the oil light is start flickering when on idle. once i press the accelerator it will goes off then come again on low speed and on corners when i slowing down the car.

    Please help.

    my machanic said that the oil pump need to be replaced, please advice


  2. #2
    Senior PakWheeler Follow
    capsat's Avatar
    Join Date
    Apr 2006
    Location
    Select City
    Age
    10
    Posts
    12,597
    Follows
    31
    Following
    6
    Mentioned
    1018 Post(s)
    Tagged
    19 Thread(s)
    Problems Posted
    2
    Problems Solved
    5
    Best Answers
    3
    Good Answers
    6

    Default

    change the oil filter to OEM new, please

    Quote Originally Posted by alimurtaza_123 View Post
    Dear All,

    I have corolla 1973 london model, working fine and running smothly. from quite some time the oil light is start flickering when on idle. once i press the accelerator it will goes off then come again on low speed and on corners when i slowing down the car.

    Please help.

    my machanic said that the oil pump need to be replaced, please advice
    - www.crackwheels.com - A skilled Dictator is much more beneficial to Country......than a Democracy of Ignorant people

  3. #3
    Senior PakWheeler Follow
    supraman2jz's Avatar
    Join Date
    Jun 2008
    Location
    Karachi
    Age
    33
    Posts
    2,700
    Follows
    1
    Following
    0
    Mentioned
    76 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    The oil light indicates you have low oil pressure. Check the quantity of oil from your dipstick. The oil pumps in these engines are pretty sturdy, there could be a number of reasons:

    1. Wrong type oil filter.
    2. Low oil.
    3. Dirty/clogged oil galleries.
    4. Contaminated oil.
    5. Dirty or clogged oil pick up.
    6. Bad oil pump.
    7. Check for any dents on the under belly of your oil pan.
    "Being between arabs, you call it "Jimmss Yukaan Sagheer", or GMC yukon." - Xulfiqar.

  4. #4
    PakWheeler Follow
    alimurtaza_123's Avatar
    Join Date
    Nov 2014
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    thanks, but i already have done the following things:

    Put a genuine toyota oil filter
    changed the oil
    tuning
    oil level is ok

    but the problem is there

  5. #5
    Senior PakWheeler Follow
    supraman2jz's Avatar
    Join Date
    Jun 2008
    Location
    Karachi
    Age
    33
    Posts
    2,700
    Follows
    1
    Following
    0
    Mentioned
    76 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by alimurtaza_123 View Post
    thanks, but i already have done the following things:

    Put a genuine toyota oil filter
    changed the oil
    tuning
    oil level is ok

    but the problem is there
    What type oil filter is it? These cars need the taller filters. The shopkeeper would try to sell you the smaller ones because they don't usually keep the taller filters as no one buys them, but they're the correct type for your K engine.

    Also what oil did you put? Did the light show up after the oil change?
    "Being between arabs, you call it "Jimmss Yukaan Sagheer", or GMC yukon." - Xulfiqar.

  6. #6
    PakWheeler Follow
    alimurtaza_123's Avatar
    Join Date
    Nov 2014
    Posts
    13
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Dear Xulfiqar,

    Yes i put the taller one, although it was difficult to find but i found one at Japan Autoes the genuine toyota filter
    and the oil was of caltax (the red one)

  7. #7
    Senior PakWheeler Follow
    supraman2jz's Avatar
    Join Date
    Jun 2008
    Location
    Karachi
    Age
    33
    Posts
    2,700
    Follows
    1
    Following
    0
    Mentioned
    76 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by alimurtaza_123 View Post
    Dear Xulfiqar,

    Yes i put the taller one, although it was difficult to find but i found one at Japan Autoes the genuine toyota filter
    and the oil was of caltax (the red one)
    Are you addressing Xulfiqar or me? If it's me, I'll take that as a compliment!
    "Being between arabs, you call it "Jimmss Yukaan Sagheer", or GMC yukon." - Xulfiqar.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •