Survey by Qualaroo
+ Reply to Thread
Results 1 to 6 of 6

Thread: Cultus Help required

  1. #1
    PakWheeler Follow
    moti_daku's Avatar
    Join Date
    Feb 2015
    Location
    Islamabad
    Posts
    23
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Question Cultus Help required

    AOA,
    I have some noob questions regarding cultus

    I read something about timing and STAP-00b, what is it? and how do i know if there is something like this in my cultus carby 2002 ??
    because i feel like my car is consuming alot of petrol, more than required, i feel it when i press the accelerator. and i can also smell petrol standing near the exhaust.
    I was searching on how to diagnose it, so found stuff related to timing and STAP-00b, but i have no idea about it

    How do i adjust petrol settings of my car?
    How do i adjust the settings of the accelerator i.e "race" kitni honi chahye itna press krne pe, type stuff


    Is there an auto choke function in cultus carby 2002? i know there is in 2012 cultus. If there is an auto choke function in 2002 then i guess mine doesn't work, how do i diagnose that?

    Thank you


  2. #2
    PakWheeler Follow
    shaaaan1's Avatar
    Join Date
    Nov 2014
    Location
    Rawalpindi
    Age
    22
    Posts
    8
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Bhae mix some 7 up with petrol try it its so effective.

  3. #3
    PakWheeler Follow
    moti_daku's Avatar
    Join Date
    Feb 2015
    Location
    Islamabad
    Posts
    23
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bump :/

  4. #4
    PakWheeler Follow
    cultusfan's Avatar
    Join Date
    Feb 2015
    Location
    Lahore
    Age
    44
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    I need some help, I have purchased a new cultus 2015, but when I start it in the morning RPM goes straight to 2000 and slowly goes down to 800-900, but it will take approx. 10min to be at 800RMP. Its EFI, NEW, and Petrol. Please shed some light, should I wait for 10min or drive after 30-40 sec.

  5. #5
    Senior PakWheeler Follow
    nasirjavaid's Avatar
    Join Date
    Jul 2013
    Location
    Lahore
    Posts
    3,083
    Follows
    8
    Following
    3
    Mentioned
    77 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    RPM reaching 2000 on start up is no issue as autochoke is working and when engine warms up it goes back to 1000RPM. But it shouldn't take that long if its new and tstat is working fine. Even my 2007 without tstat reaches 1000 in 5 mins.Check in how many minutes your temp needle reaches mid point and fan kicks in. Also try revving up a bit after 2-3 minutes. This also decreases rpm from 2000 to 1000 but don't know whey ... maybe experts can explain this behavior.

  6. #6
    PakWheeler Follow
    mohammadsajid's Avatar
    Join Date
    Jun 2008
    Location
    Jiddah
    Age
    63
    Posts
    45
    Follows
    1
    Following
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by cultusfan View Post
    I need some help, I have purchased a new cultus 2015, but when I start it in the morning RPM goes straight to 2000 and slowly goes down to 800-900, but it will take approx. 10min to be at 800RMP. Its EFI, NEW, and Petrol. Please shed some light, should I wait for 10min or drive after 30-40 sec.
    Congradulations on your new purchase. You may drive off slowly, if the traffic speed permits, after the oil pressure light goes off. Drive safely and enjoy your ride. Wish you many many happy kilometers on your new ride.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •