Survey by Qualaroo
+ Reply to Thread
Results 1 to 5 of 5

Thread: Mira engine warning light?

  1. #1
    PakWheeler Follow
    vtecyo's Avatar
    Join Date
    Oct 2012
    Location
    Lahore
    Posts
    334
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Mira engine warning light?

    So i have a Mira CVT and today coming back to Lahore the engine symbol on the display started to illuminate, what could be the reason?


  2. #2
    PakWheeler Follow
    vtecyo's Avatar
    Join Date
    Oct 2012
    Location
    Lahore
    Posts
    334
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    bump.....

  3. #3
    PakWheeler Follow
    hameeds01's Avatar
    Join Date
    Jul 2005
    Location
    Islamabad
    Posts
    892
    Follows
    0
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by vtecyo View Post
    bump.....
    is she on CNG??

    disconnect the Battery -ve terminal for 10mins & then reconnect it, if it appears again then take it to workshop for diagnosis test

  4. #4
    PakWheeler Follow
    sheazi's Avatar
    Join Date
    Jun 2009
    Location
    Lahore
    Age
    24
    Posts
    319
    Follows
    0
    Following
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    dc the battery terminal...wait for some time ...... the ecu restarts on connecting the terminal again...if light shows again go to workshop..also chk all the fuses

  5. #5
    PakWheeler Follow
    ch.talal's Avatar
    Join Date
    Mar 2014
    Location
    Lahore
    Posts
    663
    Follows
    0
    Following
    0
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    2

    Default

    Quote Originally Posted by sheazi View Post
    dc the battery terminal...wait for some time ...... the ecu restarts on connecting the terminal again...if light shows again go to workshop..also chk all the fuses
    He must have done something about the problem in past one year. By the way, I am also considering Masters degree in Forums mining business.

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •