Survey by Qualaroo
+ Reply to Thread
Results 1 to 10 of 10

Thread: Need Help: Chevrolet Exclusive

  1. #1
    PakWheeler Follow
    FaiqBarlas's Avatar
    Join Date
    Jul 2013
    Location
    Karachi
    Age
    26
    Posts
    19
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Need Help: Chevrolet Exclusive

    Hey Guyz,

    Assalamo a alaykum

    I owned a Chevrolet Exclusive 2004 from last year, the car is no doubt very comfortable, smooth drive nice road grip and good fuel consumption. But from the first month I am facing the same problem which is giving me a headache & has not resolved till now.

    The Problem is when the car gets heat up after driving for 30 mins or about 15-20 KMs the engine shut off automatically when I slow down the car on signals,stops, turns etc and then it does not start until the engine cool down again. And the likeliness of this happening depends on the heatness of engine when I drive with AC car heat up more and problem starts early. While I drive it on petrol it can run longer upto 30-40Km before problem start.

    During this time I have change the radiator with new, water body, Starting Coil, get fuel injectors service, fuel pump change , CNG Emulador with wiring has changed with new one but still same problem.

    Recently I once again changed the starting coil and check for 3-4 days but still the same problem.

    Yesterday on a recommendation of a guy I tried to reset ECU by plugging out the negative terminal of battery for 30 mins and then plugged it in again then I start the engine on idle for 10 mins then turn on AC for 5 mins turn it off then again on for 5 mins until the car reaches a constant rpm.

    After this ECU resetting (I am not sure weather it has reset or not) I went away for a trial to check the car's condition and now the result is worst now.

    Please note while the car is running it is perfect no missing or any other issue the problem starts only after some KMs of driving.

    I have been to several mechanics but no one has comeup with a solution despite fail attempts.

    What I should do now.

    Please need real help here.

    Thank You

    Faiq Barlas


  2. #2
    Senior PakWheeler Follow
    bilalahm's Avatar
    Join Date
    Jan 2004
    Location
    Islamabad
    Posts
    3,045
    Follows
    2
    Following
    0
    Mentioned
    23 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Faced the same problem in the same car with one difference, this behavior was faced only on CNG and not on petrol, took many months to troubleshoot and issue was traced and resolved. It was due to the solenoid which is used to stop the flow of CNG and allow it, also used to adjust the flow. In your case it might not be stopping the CNG flow even when you have switched to petrol when it gets hot hence the issue.
    Due to the placement of this part right behind the radiator in the cng setup I had, the plastic housing couldn't sustain the heat and cracked leading to its premature end of life. Attaching a pic from internet to give an idea of how the part looks need help chevrolet exclusive -1465236
    Apart from pakwheels, my blogs can be also be viewed at http://tajziat.blogspot.com/

  3. #3
    PakWheeler Follow
    FaiqBarlas's Avatar
    Join Date
    Jul 2013
    Location
    Karachi
    Age
    26
    Posts
    19
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by bilalahm View Post
    Faced the same problem in the same car with one difference, this behavior was faced only on CNG and not on petrol, took many months to troubleshoot and issue was traced and resolved. It was due to the solenoid which is used to stop the flow of CNG and allow it, also used to adjust the flow. In your case it might not be stopping the CNG flow even when you have switched to petrol when it gets hot hence the issue.
    Due to the placement of this part right behind the radiator in the cng setup I had, the plastic housing couldn't sustain the heat and cracked leading to its premature end of life. Attaching a pic from internet to give an idea of how the part looks need help chevrolet exclusive -1465236
    Same is here almost the problem is mostly on CNG and very rare on petrol. Few days before I went to a local mechanic on a friend's recommendation. He has changed the ignition and CNG switch both But still no difference. The problem is still at the same place. Please send the picture again this one is not working.
    One more thing when the car is not starting and I am trying & giving self the cng light turns red then i turn off & on the ignition 3,4 times then it becomes green again.

  4. #4
    Senior PakWheeler Follow
    ToxicDevil's Avatar
    Join Date
    Nov 2010
    Location
    Lahore
    Posts
    1,318
    Follows
    2
    Following
    0
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    13
    Problems Solved
    0
    Best Answers
    3
    Good Answers
    0

    Default

    Need Help: Chevrolet Exclusive - 416197 what do screws cng kit do gas
    the red circled ones are the coils also the high speed adjuster "T" has a solenoid in EFi cars

  5. #5
    PakWheeler Follow
    FaiqBarlas's Avatar
    Join Date
    Jul 2013
    Location
    Karachi
    Age
    26
    Posts
    19
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by ToxicDevil View Post
    Need Help: Chevrolet Exclusive - 416197 what do screws cng kit do gas
    the red circled ones are the coils also the high speed adjuster "T" has a solenoid in EFi cars
    Thank You very Much I think this assembly is called Regulator??

  6. #6
    PakWheeler Follow
    FaiqBarlas's Avatar
    Join Date
    Jul 2013
    Location
    Karachi
    Age
    26
    Posts
    19
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by bilalahm View Post
    Faced the same problem in the same car with one difference, this behavior was faced only on CNG and not on petrol, took many months to troubleshoot and issue was traced and resolved. It was due to the solenoid which is used to stop the flow of CNG and allow it, also used to adjust the flow. In your case it might not be stopping the CNG flow even when you have switched to petrol when it gets hot hence the issue.
    Due to the placement of this part right behind the radiator in the cng setup I had, the plastic housing couldn't sustain the heat and cracked leading to its premature end of life. Attaching a pic from internet to give an idea of how the part looks need help chevrolet exclusive -1465236
    Does anyone knows a good mechanic/workshop in Karachi that can solve the above issue.

  7. #7
    Senior PakWheeler Follow
    meh1's Avatar
    Join Date
    Feb 2012
    Location
    Sahiwal
    Posts
    1,361
    Follows
    0
    Following
    1
    Mentioned
    90 Post(s)
    Tagged
    1 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    if problem is on petrol and cng both, then it can not be related to fuel(filter, pump etc). you should travel with some electrician until it heats up and stops. at this point, check that a good spark is being created on all plugs.

  8. #8
    PakWheeler Follow
    FaiqBarlas's Avatar
    Join Date
    Jul 2013
    Location
    Karachi
    Age
    26
    Posts
    19
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by meh1 View Post
    if problem is on petrol and cng both, then it can not be related to fuel(filter, pump etc). you should travel with some electrician until it heats up and stops. at this point, check that a good spark is being created on all plugs.
    Yes I did that already, When it heatups and stopped I have checked the current from current oil and it was normal(same as in cold condition) but I have not checked the current from each plug seperately. I have also changed the current coil twice and checked but the problem was still there.

  9. #9
    Senior PakWheeler Follow
    argtr65's Avatar
    Join Date
    Dec 2008
    Age
    51
    Posts
    1,645
    Follows
    1
    Following
    0
    Mentioned
    74 Post(s)
    Tagged
    7 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Check main relay and related wiring for bad connection.
    Never loose hope in life,every step gives u something.

  10. #10
    Newbie Follow
    asadtanveer.17's Avatar
    Join Date
    Sep 2015
    Location
    Lahore
    Age
    23
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Same problem is with my chevrolet. Though when purchased its cng was removed and was used in petrol the problem is occuring while driven on petrol. It shuts off when it gets slow

+ Reply to Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •