Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 37 of 37
Like Tree1Likes

Thread: Premio 2007 high fuel consumption

  1. #1
    PakWheeler Follow
    freshna100's Avatar
    Join Date
    Mar 2009
    Location
    Karachi
    Age
    42
    Posts
    7
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default Premio 2007 high fuel consumption

    Hi,

    I recently bought Premio 2007 - 1800 cc. consumption of fuel is very high i.e 7.8 Km/Litre City with A/C

    Is this consumption normal? I have changed plugs from Toyota and they tuned it but still no results.

    I have changed oil / Filter and Air Filter.

    Is there anything i am missing?


  2. #21
    PakWheeler Follow
    freshna100's Avatar
    Join Date
    Mar 2009
    Location
    Karachi
    Age
    42
    Posts
    7
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    suggestions?????

  3. #22
    Senior PakWheeler Follow
    murtaza_murti's Avatar
    Join Date
    Sep 2008
    Location
    Karachi
    Age
    23
    Posts
    10,354
    Follows
    2
    Following
    0
    Mentioned
    53 Post(s)
    Tagged
    4 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by freshna100 View Post
    I got Irradium plugs from Plaza costs Rs. 1300/each.
    car is 1800 cc, 73000 on auction report, 23000 on ODO meter.

    would increasing gap between spark plug would help? any more suggestions?
    Your odometer reading has been flipped back. The engine you have is a 2ZR-FE which should give you around 10-11Km/L. Get the MAP/MAF sensor cleaned and if that does not work then get your fuel filter replaced.
    - '06 Toyota Belta 1.0L X - '68 VW Beetle 1300 DP - '89 Nissan B12 E16

  4. #23
    PakWheeler Follow
    mazher's Avatar
    Join Date
    Jul 2005
    Location
    Karachi
    Age
    43
    Posts
    454
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @freshna100...something seems to be wrong. because new premio has a CVT transmission. Combined with a fuel efficient 1.8L engine the car should give fuel average between 10-11km/litre. thats the normal for 2007 premio
    Suggest u get your car's sensors checked by a competent workshop like aristocars (on shahrah e faisal karachi)

  5. #24
    PakWheeler Follow
    mazher's Avatar
    Join Date
    Jul 2005
    Location
    Karachi
    Age
    43
    Posts
    454
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @freshna100..hows your car's performance now? any improvement in fuel consumption yet? typically, premio 2007 onwards with CVT has excellent fuel economy as CVT has a major role in lowering the fuel consumption.

  6. #25
    PakWheeler Follow
    iuhaq's Avatar
    Join Date
    Jun 2006
    Location
    Islamabad
    Age
    42
    Posts
    14
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Freshna! I have got the same car but it gives me 11.5 to 12.2 km/l in city with A/C.
    You should get the following checked:

    1. Exhaust catalyst blockage. If it is blocked, then it has to be removed immediately.
    2. Oxygen sensors cleaning (Intake as well as exhaust)
    3. Check the plug specifications and match them with original plugs.

    Hope it will rok for you.

    Take Care

  7. #26
    Senior PakWheeler Follow
    Xulfiqar's Avatar
    Join Date
    Aug 2003
    Location
    Other
    Age
    38
    Posts
    24,405
    Follows
    131
    Following
    0
    Mentioned
    3992 Post(s)
    Tagged
    94 Thread(s)
    Problems Posted
    0
    Problems Solved
    4
    Best Answers
    0
    Good Answers
    6

    Default

    Quote Originally Posted by iuhaq View Post
    Freshna! I have got the same car but it gives me 11.5 to 12.2 km/l in city with A/C.
    You should get the following checked:

    1. Exhaust catalyst blockage. If it is blocked, then it has to be removed immediately.
    2. Oxygen sensors cleaning (Intake as well as exhaust)
    3. Check the plug specifications and match them with original plugs.

    Hope it will rok for you.

    Take Care
    BLOCKED? it can only block itself if you somehow dump raw petrol in it on a hot running engine, otherwise its pretty much impossible to melt it to blockage. You cant block it with carbon soot too, as you are driving a petrol engine, and the convertor on a petrol engine gets VERY VERY VERY HOT. No carbon soot can survive in it - imagine furnace heat.

    If you remove this - your car will perform and sound like the stuff you flush down the toilet after relieving yourself.
    ZRS - Zulfiqar Racing Systems ..... - professionals at work - at crackwheels.com

  8. #27
    PakWheeler Follow
    HELLO494's Avatar
    Join Date
    Nov 2009
    Location
    Manshera
    Age
    46
    Posts
    55
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    "if you remove this - your car will perform and sound like the stuff you flush down the toilet after relieving yourself."

    LOL

  9. #28
    PakWheeler Follow
    mazher's Avatar
    Join Date
    Jul 2005
    Location
    Karachi
    Age
    43
    Posts
    454
    Follows
    0
    Following
    0
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    @freshna100...can you pl update me on the outcome? was the issue of high fuel consumption with your premio resolved? if so, what was wrong with the car and what did u have to do?

  10. #29
    Senior PakWheeler Follow
    khan4ever's Avatar
    Join Date
    May 2005
    Location
    Islamabad
    Age
    34
    Posts
    2,752
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Replace your fuel filter and fuel pump mileage of new model premio is easy 14 to 15 km per liter got one telling from experience.
    Bimmmmeeeer 4 Life

  11. #30
    PakWheeler Follow
    noorkhan01's Avatar
    Join Date
    Mar 2011
    Location
    Peshawar
    Posts
    18
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    dude i m having 1.8 premio and getting 12 km/l with a/c with rpm under 4...

  12. #31
    Senior PakWheeler Follow
    AZEEMMAJEED's Avatar
    Join Date
    Jan 2009
    Location
    Islamabad
    Age
    22
    Posts
    3,313
    Follows
    1
    Following
    0
    Mentioned
    43 Post(s)
    Tagged
    3 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default catalytic converter

    I think catalytic converter has been chocked time to get it removed your car will be back on its original condition replacing the converter is too expensive and shortlisted
    Everything I like is either fatal., illegal, immoral, addictive, expensive or impossible

  13. #32
    PakWheeler Follow
    jnazir53's Avatar
    Join Date
    Apr 2013
    Posts
    2
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by freshna100 View Post
    Hi,

    I recently bought Premio 2007 - 1800 cc. consumption of fuel is very high i.e 7.8 Km/Litre City with A/C

    Is this consumption normal? I have changed plugs from Toyota and they tuned it but still no results.

    I have changed oil / Filter and Air Filter.

    Is there anything i am missing?

    " My Premio 2007 gives 11.3 km/l with AC and now 12.5 km/l in city Islamabad. but make sure you drive very smoothly so as to keep the rpm close to 1000 all the time. Drive in "D" mode if you select "S" its consumption will jump to 7-8 km/l but engine response will be marvelous.
    you need to cheek CAT converters (catalyst converters) in the exhaust line. If it gets choked it will not only increase fuel consumption but reduces acceleration as well. Get your exhaust gases checked by any "Enercon" tuning center, which will give you idea about cat problem.
    Get some good silencer mechanic for cleaning cat converter.....DO NOT REMOVE one or both CATs as it will create other problems. Do not ask the price of new CATs as they are very expensive.

    let me for further querries if any. All Premio lovers are welcomed for any questions including English user manual (Yes it is free)

    Premio Lover and expert

    jnarir53@yahoo.com

  14. #33
    Senior PakWheeler Follow
    aamirq's Avatar
    Join Date
    Oct 2006
    Location
    Karachi
    Age
    31
    Posts
    1,732
    Follows
    0
    Following
    1
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    check the fuel pump ka pressure besides that get the cars throttle body cleaned and even have the cars fuel filter checked to see if its clogged or not! besides that ho sakta hai k injector ya injectors mein kachra phasawa ho ya koi coil/coils kamzoor ho! ya plugs kamzoor ho gaein hoon!
    "The world ain't all sunshine and rainbows. It's a very ruff, mean place, and no matter how tuff you think you are, it will always bring you to your knees and keep you there permanently if you let it.You or nobody ain't never gonna hit as hard as life, but it ain't about how hard you hit, it's about how hard you can get hit and keep moving forward, how much you can take and keep moving forward. If you know what you're worth, go out and get what you're worth, but you gotta be willing to take the hit."
    - Sylvester Stallone

  15. #34
    PakWheeler Follow
    payableondeath's Avatar
    Join Date
    Jun 2007
    Location
    Karachi
    Age
    27
    Posts
    387
    Follows
    0
    Following
    0
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    can someone pls guide me on different variants of Premio between 2007 and 2009 model as im planning to buy one for my own use after selling my civic reborn 08

  16. #35
    PakWheeler Follow
    furqan78's Avatar
    Join Date
    Mar 2016
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    Problems Solved
    Best Answers
    Good Answers

    Default

    Hi ,
    I have premio 2006 /2011.I have seen two lights on screen even after starting and driving car.one is engine check light second is ABS light .any idea how it can be fixed!

  17. #36
    PakWheeler Follow
    furqanalighazi's Avatar
    Join Date
    Jul 2012
    Location
    Islamabad
    Posts
    28
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    got 2008 premio 1.8 2zr getting 13 kmpl in city with ac

  18. #37
    PakWheeler Follow
    uzeemujeeb's Avatar
    Join Date
    Dec 2008
    Location
    Karachi
    Posts
    381
    Follows
    1
    Following
    5
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0

    Default

    goto some workshop with scan tool aka gari ka computer and check for error codes. try not to reset the lighy by playing with battery terminal. @furqan78

    Quote Originally Posted by furqan78 View Post
    Hi ,
    I have premio 2006 /2011.I have seen two lights on screen even after starting and driving car.one is engine check light second is ABS light .any idea how it can be fixed!

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •