Survey by Qualaroo
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 25 of 25
Like Tree12Likes

Thread: Toyota passo 2005 poor fuel consumption

  1. #1
    PakWheeler Follow
    yasirammaar's Avatar
    Join Date
    Feb 2012
    Location
    Karachi
    Posts
    16
    Follows
    0
    Following
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Exclamation Toyota passo 2005 poor fuel consumption

    AOA Guys. i recently bought toyota passo 2005 registered 2011. im the second owner. i found the car great except for the fact that its fuel consumption is poor. it gives me 9 Km/L !! As far as i know it should be giving me atleast 14 Km/L. I want to have an expert opinion that what can be the problem? and how to fix it? The engine oil has been recently changed so has filter.....Also can anyone guide me as to where i can get my car checked out in karachi...


  2. #21
    Senior PakWheeler Follow
    bradpit's Avatar
    Join Date
    Nov 2010
    Location
    Karachi
    Age
    42
    Posts
    2,064
    Follows
    1
    Following
    0
    Mentioned
    87 Post(s)
    Tagged
    2 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Quote Originally Posted by yasirammaar View Post
    AOA Guys. i recently bought toyota passo 2005 registered 2011. im the second owner. i found the car great except for the fact that its fuel consumption is poor. it gives me 9 Km/L !! As far as i know it should be giving me atleast 14 Km/L. I want to have an expert opinion that what can be the problem? and how to fix it? The engine oil has been recently changed so has filter.....Also can anyone guide me as to where i can get my car checked out in karachi...
    Brother go to Toyota Eastern Motors.
    All life is an experiment. The more experiments you make the better.

  3. #22
    PakWheeler Follow
    civic01's Avatar
    Join Date
    Apr 2012
    Location
    Peshawar
    Posts
    652
    Follows
    0
    Following
    1
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    where is o2 and maf sensors located ...can u plzzz share a pic if possible

  4. #23
    Newbie Follow
    iqbal11272's Avatar
    Join Date
    Jun 2013
    Posts
    1
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    i have Toyota Passo 2011 engine exhaust sensor is not proper work, give me 13/15 KM/LTR. If it working properly, passo 2011 give me 23/28 KM/LTR

  5. #24
    PakWheeler Follow
    maarij94's Avatar
    Join Date
    Jun 2015
    Posts
    5
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Hello, i have a 2007 toyota passo. Great car.

    I have had it for a while, but recently the compressor had to be replaced as there was an issue with the air conditioner. The car had been giving me a fuel avg of 14km/l since 2 years.

    But when got it replaced and after the car came back from workshop, the fuel average dropped to 5km/l.

    I drove it for a 100 kms, the mileage came up to 9.9.

    I know that the air filter and oil filter need to be replaced as they havent been replaced in a long time.

    So i wanted to ask, what else should i get checked? I mean, except for the air filter an oil filter, what other factors could be affecting my mileage?



    Sent from my iPhone using PW Forums

  6. #25
    PakWheeler Follow
    Itskhattak's Avatar
    Join Date
    Sep 2015
    Posts
    3
    Follows
    0
    Following
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0

    Default

    Oxygen sensor should be the problem. My passo is giving me 20 km upto the speed of 100kmph. For more pls contact itskhattak@gmail.com

+ Reply to Thread
Page 2 of 2 FirstFirst 12

User Tag List

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •